Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

No Receive Audio On Remote

Ken - NM9P
Ken - NM9P Member ✭✭✭
edited June 2020 in SmartSDR for Windows
I just got my new (refurb) laptop (HP Elitebook 8460p,  Intel i5 Dual Core 2500MHz,  750Gig Serial ATA,  4096mb RAM, DVD ROM,  14.0” WideScreen LCD, Windows 10 Professional 64 Bit, built in firewire, Express port, Displayport, mic, camera, Bluetooth, A.B.G. wifi, etc....for $155!)  An AWESOME deal! even if the aged battery's usual 4-hour lifespan is somewhat lower than 4 hours....

After initializing everything, I loaded SSDR and OpenVPN on it and tried to remote into my home station from the office.  I was using my wired headset and it worked perfectly.  When I got home and put it on WiFi it worked even better.  I connected my Logitech Bluetooth Headset/mike combo and enjoyed some more remote operation.....until....

I tried to change back to listening to the built-in speaker.....all of a sudden, there was no remote receive audio.

I have gone into the Windows audio utility (playback and record) and set everything to the correct Default audio channels...nothing....on headset, speaker, whatever...

I have uninstalled the Logitech headset from Device Manager and rebooted several times....nothing....

I have toggled every button and click box I can think of...nothing....

No remote receive audio on headphones, or speaker, no matter how I set it.

I CAN go to DAX and tell the Windows Audio utility to "listen" to a DAX channel and I can hear the receive audio through DAX.

My guess is that somehow the remote audio codex has gotten corrupted.

OR... that being a newly begun Windows 10 operation a background update somehow corrupted something?

So I guess I need to uninstall and reinstall SSDR.  I ran out of time last night due to other family obligations.....

Before I do this this evening, does anyone have any other constructive suggestions.

BTW... I DO get Remote receive audio on my Shack computer connected through a switch to the 6500 and then to the router, and on my office desktop via OpenVPN.  So the problem is not in the rig.

I am stumped, except for the reinstall.....

Ken - NM9P


  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited June 2020
    I have no suggestions but am curious if you are using OpenVPN on a router server or using OpenVPN software loaded into a PC?
  • Jay Nation
    Jay Nation Member ✭✭
    edited May 2019

    Maybe I'm seeing something similar, Windows Update updated some stuff yesterday. Last night, out of nowhere I started hearing, a tiny bit of noise on the right hand speaker that I couldn't account for, it wasn't ground loop hum, sounded more like an unterminated input line. then later I noticed I had horendous RFI on the speakers, whenever I tried to transmit. No issues earlier in the day with RFI, Ferrites, and even more Ferrites, on all of the audio lines, Ground Loop isolators on each audio line too. This morning I found that I had no output at all from my PC speakers, double checked all connections, tried the Speakers on another PC no problem with the speakers. I then reinstalled the Realtek HD Audio Drivers and it seems to be fixed. Might have been Windows update, can't prove it though.image The RFI on TX also was eliminated.

    My guess is right before I noticed the tiny bit of noise on the right speaker. the Update applied. Corrupting something. and possibly making it worse overnight. I was working on mic profiles when the noise started which is why I noticed it. All my Flexradios are feed into the PC soundcard on seperate input's and the speakers only connect to the Speaker output on the PC. So this morning I had no audio from any of them and no PC audio either. 

    The update I received yesterday had this number on it. KB3163018, Microsoft has acknowledged that it's causing problems "sometimes" I seems it doesn't install the way it was designed to. (Where have I heard that recently?)image

    73, Jay - NO5J
  • Ken - NM9P
    Ken - NM9P Member ✭✭✭
    edited December 2016
    I am using the OpenVPN server in my ASUS RT-AC66U Router.
    I recently discovered that it will work with BOTH OpenVPN and its standard PPTP VPN servers at the same time!  So I have the OpenVPN set up to use my Laptop and Office computers with OpenVPN Clients, and the PPTP to use my iPad and iPhone.  

    See down post for Update on my problem...
  • Ken - NM9P
    Ken - NM9P Member ✭✭✭
    edited June 2020
    UPDATE:  It's a Miracle!  (kidding)

    I left the laptop on last night and let Windows Defender do a whole disk protection scan, since it was new and kept giving me the "your computer is not protected" message that it always does before it does a full scan.

    I went home for a late lunch at 3:00 pm and the laptop had cycled OFF... perhaps after another update? 

    When I booted it up and opened SSDR, I had remote receive audio on the internal speakers!

    I can only speculate that ONE of the following happened....

    1) Testing Remote Audio with the other computers allowed the codec to reset...

    2) Another Update happened overnight that fixed the problem....

    3) Being completely powered off overnight instead of simply rebooting/restarting the laptop allowed something to reset...

    4) God really likes me......(;p)     (I didn't even have to lay hands on it and shout "Heal.....")

    5)  I had something set amiss that I didn't realize...possible, but I think I checked everything more than three times...)

    At this point, I am at a loss to explain.....But I am happy it doesn't require reinstallation of SSDR.

    Ken - NM9P

    Consider this one mysteriously SOLVED.  Perhaps a PEBCAK error.....
  • Rob Fissel
    Rob Fissel Member
    edited June 2020
    A way out there thought, but I know that you're a Bluetooth headset user, Ken. Any chance you had something paired to the laptop which auto connected but wasn't near/on you?

    Paired Bluetooth headsets play nice with SSDR, with a few caviats. Swapping default audio inputs in Windows Control Panel, or turning off my Bluetooth headset while SSDR is running always causes me issues.
  • Ken - NM9P
    Ken - NM9P Member ✭✭✭
    edited December 2016
    I had thought about that, as well as the Bluetooth conflicting with the 2.4 GHz WiFi.  So I turned the Bluetooth OFF on the computer and was trying to get it going just on the internal speakers.  I pulled out every trick I had in my book, and even a few I had never tried before, often rebooting in between efforts.......and then this morning....it works.....Computers can be really strange sometimes!

    "Garbage in...Garbage out"  but sometimes I think there are a few secret ingredients in there, too!  Ha!

    Ken - NM9P
  • Greg N8GD
    Greg N8GD Member ✭✭
    edited December 2016
    This is why I always tell folks if you really want to know the reliability (or not) of computers, look at Microsoft's EULA wherein it states that Windows is NOT to be used on life support systems!  Duh, with the stuff we see like this, I fully agree.  After having run my own computer consulting and repair business for 15 years before retiring, it's amazing I have any sanity at all.  I've seen a lot of weirdness on PCs and continue to do so on my own systems.  Thankfully my Flex 6K and SSDR have given me NO problems!

    Greg - N8GD

  • John S
    John S Member
    Hello to the group, just setting up my first attempt to remote to my laptop. I have the exact same problem. I have little or no precibal audio coming from the laptop, the audio is emanating from the desktop commuter. I do see one bar movement on DAX RX1. I'll cycle the laptop, Pray and lay my hands on it.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Make sure your default sound card in Windows is the one you are want to hear audio from the radio. SmartSDR only plays audio to the default device.

    I am confused since you mention both a laptop and a desktop. You will have to explain more.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.