Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

MMTTY and 2Tone RTTY decoders with N1MM

Steve-N5AC
Steve-N5AC Community Manager admin
edited June 2020 in SmartSDR for Windows
I'd like to hear of any issues or successes using SmartSDR v1.5 in RTTY mode with MMTTY and/or 2Tone with N1MM.  We worked on this functionality in v1.5 and feedback, good or bad, would be useful.  I know some of you may be testing this out over this weekend in CQWW RTTY ;-) [#1801]

Answers

  • Bill Axelrod
    Bill Axelrod Member ✭✭
    edited October 2017
    Steve,

         I was able to run MMTTY as a stand alone and as a RTTY engine in N1MM along with 2 tone since it was released on Monday UNTIL this morning.

         When I first installed V 1.5 I got the tone (mark) selector menu when in RTTY.  Somehow, that disappeared.  And now my mark and space are off frequency.

          I deleted and then re-installed V1.5 but no joy.  Now I am stuck.

    73....    Bill K3WA
  • Ed.G
    Ed.G FlexRadio Employee ✭✭
    edited December 2016
    Bill, are you saying you do not see the Mark and Shift entry boxes in the DSP tab of the Slice flag when you are in RTTY mode? 

    If so, can you try changing modes to something else and then RTTY again? Then click the DSP tab.
  • Bill Axelrod
    Bill Axelrod Member ✭✭
    edited October 2017
    No.  I am just senile.  They are there,  Just forgot where 'there' was.  All workes OK,Sorry.

    73..   Bill
  • Doug Hall
    Doug Hall Member ✭✭
    edited February 2017
    So far the RTTY mode in v1.5.0 is working very well, and it's a welcome enhancement for those of us who work RTTY, whether contesting, DXing, or ragchewing. It's really nice to be able to click right between a station's mark and space frequencies and be on frequency. And no messing around with RIT/XIT or other workarounds are necessary. Using 2 instances of MMTTY to work DX split is really smooth now. Like shooting fish in a barrel. Thanks for the RTTY mode in v1.5.0!

    Lots of RTTY activity on 20m this evening with people warming up and getting ready for the contest this weekend. Great chance to check our your RTTY setup.
    73,
    Doug K4DSP

  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited December 2016
    No problem Bill.  This only happens to me a couple of times a day!
  • k0eoo
    k0eoo Member ✭✭
    edited March 2017
    Once I got a little help I was able to get MMTTY integrated with V1.5.  Seems to work very well.  I then tried Fldigi and got that working this afternoon and made 5 contacts, 1 being DX, on 20m..... first ever for me....

    The only issue now is when I click on a spot in my logging program, DX4WIN, my 6500 goes to the spot but it switches to CW each and every time.  When I change it back to RTTY the freq is correct, its just a nucience....  I take it you have that issue solved with N1MM+?  I expect its an issue with my logging program but I don't know how it could know unless I'm able to lock the mode into RTTY....  Is that possible?

    Good work Steve and the FRS gang....

    Dennis, k0eoo
  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited December 2016
    My understanding is that all manufacturers use a different numerical value for CAT for RTTY.  This came up when we were assigning the values for each mode.  We attempted to find the "standard" but found out that there is not one.  Unfortunately it seems like the programs will have to find out what each manufacturer is using for their mode <-> number exchange and add that to their code.  I really dislike this answer as it leaves customers in a hole until everyone can update.  The industry is in need of a replacement for CAT...  We're using 30 for RTTY if that helps.
  • k0eoo
    k0eoo Member ✭✭
    edited December 2016
    DX4WIN is showing RTTY in its mode window when I'm connected to the radio , its just when I click on a spot it wants to change the mode to CW or SSB depending on what band segment I'm in....  So, I plan to get on their reflector and see if there is a way to turn that feature off.... Otherwise I've been having fun with V1.5 on RTTY, got a dozen contacts in the log....

    Regards, Dennis, k0eoo
  • km9r.mike
    km9r.mike Member ✭✭
    edited September 2015
    Point and click rtty w/o a need to fine tune to zero beat is huge. Also while working split with xit was doable, it was a little cumbersome for such a capable rig. Looking forward to enjoying these great features.

    I have never been able to incorporate two tone but point and click precise rtty may replace it if I am not mistaken about the benefit of two tone.
  • Ben Morris
    Ben Morris Member ✭✭
    edited May 2019
    I am dabbling in CQWW and I really like what you all have done for RTTY! Thank you very much. I am using N1MM Plus with 2Tone. Great job and as crowded as 20 is at the moment, having the easier use of the filters is very helpful.
  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited February 2017
    I am also playing non-seriously in CQWW.  Using N1MM+ with MMTTY in the main DI window and 2Tone in a second DI receive-only window.  Still experimenting with filter settings but everything is playing together nicely.

    Also, I'm using DXLab's SpotCollector for click tuning on interesting spots.  (Mostly for filling out Challenge slots.)

    SSDR RTTY mode is working very well.  About the only thing I could want, at this point, is a longer tail on the mark line to more quickly tune when I get to a transmission late. (I am using FlexControl for tuning, because Window's focus is on N1MM+.)

    73, Bob, N7ZO
  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited February 2017
    You can't help but love this target rich environment, especially with this beautiful waterfall:
    image
  • James Kennedy-WU5E
    James Kennedy-WU5E Member ✭✭
    edited June 2020
    Working the contest with MMTTY and it's working just fine, the only think I think it's strange. I have to used TX2 to transmit. so I'm using two slices REC on 1 and TX on 2 running FDX right now. it's fun

    Jim
    WU5E

  • James Kennedy-WU5E
    James Kennedy-WU5E Member ✭✭
    edited December 2016
    Can't get N!MM to transmit all all, so just using MMTTY

  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited February 2017
    Hi James,
    I have MMTTY doing the PTT even when using it through N1MM+.

    In N1MM+, no PTT through CAT and no other PTT port enabled:
    image

    And in MMTTY, PTT is enabled.  COM5, on my machine,  is an SSDR CAT [ptt rts] port.
    image

    73, Bob, N7ZO
  • Bob N7ZO
    Bob N7ZO Member ✭✭
    edited February 2017
    I just did some testing.  If you select "None" in the MMTTY panel for "PTT and FSK" as in the second picture above, and then select "PTT via Radio Command Digital Mode" in the N1MM configuration panel as in the first picture above, this also works.  N1MM is now doing the PTT.

    73, Bob, N7ZO

  • James Kennedy-WU5E
    James Kennedy-WU5E Member ✭✭
    edited June 2020
    WORKING VERY GOOD , ON 20M CALLING CQ TEST. Thanks
  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited June 2020
    I ran about 23 hours in CQWW RTTY test this weekend. See my post for more details. I was very pleased with how it ran with MMTTY. Now if I could just learn how to fine-tune all of the various modem/decoders in MMTTY I could really make it sing! I haven't tried FLDigi (my preferred digi program) with the new RTTY mode yet. And I haven't tried two-tone at all. MMTTY was easier to get running at first and I just stuck with it.
  • Ken W9IE
    Ken W9IE Member ✭✭
    edited March 2017
    Steve....    
    First Thanks for the RTTY changes... They make RTTY so much easier....
    My only comment and I do not know if it is SSDR in RTTY Mode or N1MM that will have the fix.

    I set up SSDR for RTTY and all is working OK,   Then I bring up N1MM and after it loads it
    last window SSDR switches to DIGI Low...   I change it back to RTTY and all is OK until I
    again start anew......

    It Ran flawless in the CQWWDX RTTY last weekend...   I ran 807 Q's with out a hitch...

    Thanks again for the RTTY Changes..

    Ken   W9IE
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    This sounds like N1MM is sending a ZZMD command to change slice A to DIGL
  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited December 2016
    Thanks for the report.  I've passed this along to the N1MM guys to see if they can add the mode designator in Logger+.
  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited December 2016
    Ken,

    I received a note back from the N1MM folks that the change was previously made and tested in Logger+.  Is your Logger+ up to date?  They also said you'll need to have this setting correct:

    image
  • Steve Gw0gei
    Steve Gw0gei Member ✭✭
    edited October 2015
    Yep changing mode control above fixed it for me - now stays on rtty when I click on a spot. Gave away some points in cqwwrtty as gw6j using n1mmplus with Mtty engine s01v and it worked very well- thanks guys this is getting better for contesting every release. Next step for me is to learn how to set up two tone engine and implement so2v for future rtty contests. 73 steve gw0gei / gw6j
  • Ken W9IE
    Ken W9IE Member ✭✭
    edited December 2016
    Thanks Steve.....
    I always stay up to date on changes....
    Making the change in the Mode Control Window did the trick...
    I had it set   "RTTY to AFSK"   kinda made sense hi   hi ...
    Thanks again Steve you guys at Flex are the Greatest....

    Ken   W9IE
  • Fred-NA2U
    Fred-NA2U Member ✭✭
    edited January 2016
    Bob, I tried these settings and still can't get MMTTY going in N1MM+ with my 6300.

    73 from the desert, Fred/NA2U
  • Fred-NA2U
    Fred-NA2U Member ✭✭
    edited January 2016

    Bob, I stayed at it and I think it finally took.  MMTTY kept changing "None" back to Com7.  I finally got "None" to stick.  It looks like it's working.  I'll know when I fire up for WAE RTTY tomorrow night!  Thank you!!!

    73 from the desert, Fred/NA2U

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.