WSJT-X "error in sound input"

  • 2
  • Problem
  • Updated 1 week ago
My WSJT-X install is reporting "an error opening the audio input device has occurred" when I load the program.  It won't connect to my DAX channels and I can't copy any of the digital modes using WSJT-X.

I'm running SmartSDR version 3.1.8.145, and WSJT-X v2.1.0 - the 32 bit version.  My desktop is running Win 10 Pro Version 1903.  I've uninstalled and then re-installed WSJT-X.  I've rebooted my computer.  I'm able to connect to my 6600M and all looks good.

I was originally running the 64bit version of WSJT-X when this all started.  I uninstalled the 64bit version and then installed the 32bit version.  Still didn't work.  I've had no luck with it resolving itself.  My audio inputs and outputs in the device manager looks good, too.  Doesn't matter which DAX Channel I use.  The error is the same. After I updated the SmartSDR software to the V3.1.8.145 the WSJT-X software continued to worked fine.  Then, out of the blue, it's stopped working. 

I don't see the issues of corrupted inputs in my Device manager like when I did the 1803 updated last year.  The inputs were pretty hosed after that update and with the help of the community board I was able to correct those problems.  I don't see that problem this time.

I'm sure this was a MS software update/tweak that caused this.  I normally can figure these things out but this one has me stumped.  Anyone else had this issue?  If so, what did you do to correct it?  Thanks.

Tom
WQ5O
Photo of Tom - WQ5O

Tom - WQ5O

  • 45 Posts
  • 5 Reply Likes

Posted 2 weeks ago

  • 2
Photo of Bob  KN4HH

Bob KN4HH

  • 109 Posts
  • 21 Reply Likes
I had the same problem and Flex suggested that I try the procedure described at this link
https://wintechlab.com/microphone-not-working/

This fixed all my DAX issues using third party software

Bob
KN4HH

Photo of Dave KØKQ

Dave KØKQ

  • 11 Posts
  • 4 Reply Likes
1.  Like KN4HH said, microphone needs to be active.
Settings / privacy /  Microphone (in left pane) /  allow apps to use microphone should be on.

For some reason, this affects the digital audio in/out of DAX or VBAudio. 
Mine got turned off during a windows 10 update. 

2.  Control panel / sound. Make sure your "recording" and "playback" are properly set up. 

3.  Make sure "PC Audio" blue box is active on main SDR pane. (a real gotcha!)

4. In WSJT-X settings / audio make sure input and output are set up pointing to VBAudio or DAX.

Hopefully something here triggered your solution.
Good Luck...Dave



Photo of Tom - WQ5O

Tom - WQ5O

  • 45 Posts
  • 5 Reply Likes
Thanks Brothers.  That did the trick.  Gotta love Microsoft doing things to your system just "because"!  LOL! 

73 to you both.

Tom
WQ5O