WinLink RMS Express Setup Guide & Demo (WL2K Mode)

  • 11
  • Praise
  • Updated 2 years ago
  • (Edited)
This demo is to show how to send email via WL2K.

Download and install RMS Express here:  http://www.winlink.org/RMSExpress The current version as of this document is rms_express_install_1-2-30-0.zip .

Download and install the newest version of VOACAP itshfbc here: http://www.greg-hand.com/versions/   The current version as of this document is itshfbc_120722.exe

Make sure in SmartCAT you have both a CAT port and a dedicated PTT port.   In my example, COM4 is my CAT port and COM5 is my dedicated PTT port.  Create Slice A DiGiU/3K and enable DAX 1 with TX.  Enable the DAX button on the P/CW Panel.

Open RMS Express and click on Files -> RMS Express Setup



Enter your call sign and 6 figure Grid Locator.   If you donate to Winmor, enter your key here ( I cleared mine for this demo).   Their work is worth donating to!

Click Message -> New Message.  In the To: field, if you put an email formatted address with an @ sign, the gateway will try to deliver it out of the WinLink system onto the internet.   If you simply place a call sign, such as K6OZY, it will keep it in the system and try to deliver it to that ham when they check for email on any node.  

When you send your first email, the WinLink system will create your account.   If you do not use it within a certain time period again, the system will delete your account.

Fill out the various portions of the email just as you normally would, but be brief.  Remember, this is going over HF and bytes are slower.

Click on Post to Outbox.   Now you have an email queued for delivery.  

Make sure "Winmor WL2K" is selected in the Open Session drop down box and click "Open Session:"



This opens the Winmor Winlink 2000 session manager and TNC.   We now need to setup the specifics for the radio.

Click on Setup -> WINMOR TNC Setup.  Select the DAX Audio TX/RX 1 sound cards.   Change your Inbound Session Bandwidth to 1600hz.   Increase your drive level to 100.   This will not overdrive with your DAX set to default RX Gain of 50 and Default TX Gain of 44.  Click Update.



Click on Setup -> Radio Setup.  Pick Flex radios from the radio model.  Pick "USB Digital" mode.  Set your Radio Control Port to COM4 and PTT Port to COM5.   It is required to use a dedicated PTT port to get the quick response required for PACTOR.



Click Update.   This will restart the TNC.

Click on the Channel Selection button.  It will open a new window.  Click on "Update Table via Internet" to download an initial list of gateways.  After the propagation paths are calculated, sort by Path Reliability.



RMS Express will show you all channels.  Double Click the gateway for the best band for your station's capabilities.  It should now switch to that band and check for busy status.   Make sure your station is ready for transmit (i.e. tuned, power, etc), and click Start.   It is very cool to watch this system work.   It is very robust and reliable.  Please watch my video for a full demo of sending an outbound email.



I will record another video showing Peer-to-Peer (P2P) so you can deliver messages and attachments between two parties without using any WinLink Infrastructure.   I find this particularly useful in EmComm situations where I need to move binary files back and forth.
Photo of K6OZY

K6OZY, Elmer

  • 532 Posts
  • 198 Reply Likes

Posted 4 years ago

  • 11
Photo of Richard Clafton W4/G7EIX

Richard Clafton W4/G7EIX, Elmer

  • 455 Posts
  • 117 Reply Likes

Very nice.  Thanks for sharing this.  Always good to have a reference for something I have not played with yet.

Photo of stan Hirson

stan Hirson

  • 10 Posts
  • 0 Reply Likes
I have no idea in the world how to do this:  "Make sure in SmartCAT you have both a CAT port and a dedicated PTT port.   In my example, COM4 is my CAT port and COM5 is my dedicated PTT port."

Where are instructions for assigning CAT ports?  I've been spinning my wheels on this issue. 

Thanks,

Stan Hirson
W2VID
(Edited)
Photo of Jay / NO5J

Jay / NO5J

  • 1577 Posts
  • 228 Reply Likes
Stan
Here are the Instructions ...
http://www.flexradio.com/downloads/smartsdr-cat-user-guide-pdf/

73, Jay - NO5J
Photo of stan Hirson

stan Hirson

  • 10 Posts
  • 0 Reply Likes
Thanks,

I've jiust downloaded it and am looking forward to using them!  Looks like a big help.

Stan, W2VID
Photo of stan Hirson

stan Hirson

  • 10 Posts
  • 0 Reply Likes
I have been following the instructions on the CAT Uer Guide and when I get to the crucial window on RMS Express, I cannot get the drop down to take a comm port.  Here  is what I get:


I cannot get it to choose anything other than "None" in the Serial Port to Use. I've tried a bunch of them from the CAT menu....

Thanks!

Stan  Hirson, W2VID
Photo of Rick Williams

Rick Williams

  • 13 Posts
  • 2 Reply Likes
I'm curious.  I followed your instructions and video, it worked, but is the freq supposed to update in the radio when you select a node station from the list?  I had to manually put in the freq on my 6500.

Thanks
Rick, KT9B 
Photo of Craig McVeay

Craig McVeay

  • 21 Posts
  • 1 Reply Like
The instructions above have gotten me right to the very edge of having Winlink and Winmor working but now, I have a hangup.

Running Winlink 1.4.0, Winmor TNC 1.5.10.0, SmartSDR 1.8.4.168 and it's all on a Windows 7 box.

Everything seems to work just fine until I try to connect to a node.  Regardless of what node I pick, the rig tries to connect 10 times with a very short TX and then, on the 11th try, it sends my call sign in CW, drops the TX and the attempt fails.  Some of these are on stations that were busy not long ago (within 10 minutes) but have been silent for a few minutes (and then busy again).

DAX is selected, DAX 1 is selected in Slice A.  Two CAT ports (4 for CAT, 5 for PTT).

Anyone up and running with these versions of Winlink and Winmor?

Craig
N0CSM
Photo of K6OZY

K6OZY, Elmer

  • 532 Posts
  • 198 Reply Likes
Hi Craig,

I use RMS Express daily both WinMor and Pactor on my Flex radios.

Can you verify that you are sending RF?  Do you see the MIC meter move near but not into the red?  Do you see that RF power is going out?  Are you using DIGU?

What is the link quality rating of the nodes you are attempting?  The bands have been quite bad lately.
Photo of Craig McVeay

Craig McVeay

  • 21 Posts
  • 1 Reply Like
All indications are that there is power going out - Red light on Flex, TX relays click, SmartSDR shows a spike.  However there's no power out indication on the RF meter and with MONI turned up, no indication of audio going out.  I'm getting the impression that the PTT is talking to the radio but there's no data being sent to initiate the connection.

DIGU - Yep
3k - Yep
Winmor capture is set to DAX Audio RX1 in the TNC settings and DAX is selected in the P/CW box on the right
Winmore playback device is set to DAX Audio TX

I have 5 stations that are at 100/100 and they have both 20, 40, an 80m (N2LEE & K3ERA).  I can see when they are busy.

Earlier, I checked everything with Fldigi just to make sure that I was pushing sound to the radio from the computer and PSK31 was working just fine.
Photo of K6OZY

K6OZY, Elmer

  • 532 Posts
  • 198 Reply Likes
If you see no movement in the meter in MIC panel or output power then this is definitely your problem.

First thing to check is if audio is flowing from RMS Express into the DAX Control Panel.   If you look at the DAX CP while transmitting, do you see a red meter move on the Transmit portion at the top?  If not, make sure it is enabled and check your target output sound card in RMS Express.

If so, lets move to SmartSDR.  Make sure the DAX button is pressed, and lets set the MIC selection to "MIC" in case it was set to PC.   If the MIC selector is set to "PC", you won't hear DAX MON.   Also make sure your slice has the proper DAX channel enabled.
(Edited)
Photo of Craig McVeay

Craig McVeay

  • 21 Posts
  • 1 Reply Like
Before I respond, let me thank you for your time and patience!

I was going through the steps to answer your questions and, magically, it started to work!  I was able to send a test message to my commercial email from within Winlink.

Thank you very much!
Photo of James Kennedy-WU5E

James Kennedy-WU5E

  • 310 Posts
  • 32 Reply Likes
working great on my 6500 and windows 10
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 121 Reply Likes
Well, that was incredibly simple!  I followed your instructions and sent and received my first test message on my first attempt.  Thanks for such a complete description.  I'd been thinking about installing WinLink for some time, but had never wanted to take the time to decipher everything that I'd read in non-Flex related literature.
Photo of K6OZY

K6OZY, Elmer

  • 532 Posts
  • 198 Reply Likes
Great!  Please like my guides (top right of the thread window) if it's useful as this helps me know who has benefited from it.
Photo of Mark wt0e

Mark wt0e

  • 5 Posts
  • 0 Reply Likes
Thanks for the kind contributions of information! 

However, I am having one hang-up and I don't know how much it is effecting my connections or overall throughput.  I have a 6700 and set up the radio and software as instructed here.  When I transmit during a session, I get a information line (error?) in the "WINMOR Sound Card TNC" window which indicates there is a 400-600ms latency from transmit to receive (mode).  It makes no difference where my SmartSDR software is having audio sent--to the radio or from the computer (i.e. "REMOTE" button pushed).

I read somewhere on the Winlink site that 250ms is the limit for transmit to receive latency, but I seem to have about twice that latency between TX and RX.

I have a modest antenna, but have only successfully completed two sessions of contact. 
1.  Is this the reason?

2.  Why do you think I have this latency when I don't hear of other Flexradio 6000 users having the issue when I watch their demos?

Thanks much!

Mark wt0e
Photo of Mark wt0e

Mark wt0e

  • 5 Posts
  • 0 Reply Likes
Update:  It seems from other threads I have since read that above-"normal" latency from transmit to receive is fairly normal and in my  range ought not prohibit communications--maybe make it even slower though than WINMOR already is <grin>.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
WinLink Express (not RMSExpress!) has been updated some time ago. You'll find the newest version here:https://www.winlink.org/WinlinkExpress and you have to apply for a password, or WinLink Express won't work.
This has been necessary because of abuse by non-hams and spam.
Be also careful with the length of your mails and do not post bigger pictures.
I use a SCS PACTOR modem instead of WinMor, which is much more stable and faster.
73, Alex - DH2ID
(Edited)
Photo of Justin - KL2D

Justin - KL2D

  • 95 Posts
  • 39 Reply Likes
This was a great tutorial, I have been meaning to play with WinLink for some time and stumbled across this. Got me up and sending emails in about 20 minutes. THANK YOU VERY MUCH!!

73

Justin
KL2D