Windows Security Update KB4015217 causing Poor Network Diagnostic reports on Windows

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
Noticed the Network Diagnostic bar graph on Poor (Red) with many dropped packets reported - 72% over time. Audio and signals on the pan adapter were normal.  Spent a few hours diagnosing the problem - New Patch Cables - New switch and on and on - connected Wireless .  Well this morning used the Maestro via Ethernet and all bars were green - So it hit me that a Windows update was installed yesterday.  Update KB4015217 was in fact installed - So I uninstalled it to see how things would go.  Upon reboot after uninstallation, I have 5 green bars-solid all is well.  Flex may need to tweak something due to KB4015217 if they can duplicate the issue.  Wanted to throw this out in case others are seeing the same issue. 
Photo of Joe Bales

Joe Bales

  • 28 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
I have entered this problem report into our bug tracker as issue #4610 for additional investigation. Thank you for the defect report.
Photo of Joe Bales

Joe Bales

  • 28 Posts
  • 3 Reply Likes
Read a few writes regarding issues with failed/incomplete installs of KB4015217 - So I reinstalled it again and again and finally after the 3rd install I am getting 5 Green Bars consistent -  I think I have it under control by doing that - hopefully others will also - 
Photo of Joe Bales

Joe Bales

  • 28 Posts
  • 3 Reply Likes
Well that did not last long.  back to Red -  Maestro all Green Bars -  we shall see what happens with issue #4610  - thanks
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
In the interim, you may need to back out KB4015217.  Since this is an OS issue, there may not be much we can do.
Photo of Joe Bales

Joe Bales

  • 28 Posts
  • 3 Reply Likes
Just did that - and modified Group Policy to prompt before downloading/installing updates.  Have about a 1 month old fresh install of Windows 10 and forgot to make the change.   All Green now so far.
Photo of N7VR

N7VR

  • 6 Posts
  • 0 Reply Likes
Hi Tim,
Please note this is for the Windows 10 OS and does not apply to the Windows 7 OS.  
I have noted in my test here that the section that:
"Addressed issue that increases CPU usage when IP forwarding or weak host is enabled."
is producing errors.
I have submitted a bug report on this on the Microsoft Windows 10 OS System.
Jim Fuller N7VR
 
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9178 Posts
  • 3525 Reply Likes
Thanks Jim