Windows 8 and SmartSDR losing connection

  • 2
  • Question
  • Updated 4 years ago
  • Answered

SmartSDR will lose connection to the radio under Windows 8 if the SmartSDR is not minimized. Anyone see this condition?


Photo of James Kennedy-WU5E

James Kennedy-WU5E

  • 295 Posts
  • 31 Reply Likes

Posted 4 years ago

  • 2
Photo of George Molnar, KF2T

George Molnar, KF2T, Elmer

  • 1529 Posts
  • 541 Reply Likes
I think you mean "is minimized," right? No problem here (Windows 8.1).
Photo of ai6re

ai6re

  • 93 Posts
  • 17 Reply Likes
I have had the same experience on Windows 8.1 with SSDR lost connection while it is not minimized but not the currently focused window. I think Windows 8.1 treats tasks differently as CW Skimmer no longer functions on Windows 8.1. It fail to get serviced by the system in time to function correctly.
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
So to maintain radio connection you must minimize Ssdr? If that's the case how do you even know if it's running?  8.1 here. Works great.
Photo of ai6re

ai6re

  • 93 Posts
  • 17 Reply Likes
My SSDR works fine on 8.1 as long as I am checking the window from time to time. If I leave it running and the window is open in the background it will suddenly get disconnected after something more than 30 minutes. I usually click on the SSDR window more often than 30 minutes so most of the time it is not a problem. If it does lose the connection re selecting the radio and it will restart.
Photo of Reggie-k6xr

Reggie-k6xr

  • 413 Posts
  • 32 Reply Likes
8.1 runs fine here as well. No apparent problems even when running MacLoggerDX or DXLabs suite simultaneously. 
Photo of Jon - KF2E

Jon - KF2E

  • 622 Posts
  • 180 Reply Likes
You could probably solve this by disabling ALL power management so that Windows always runs. Your HDD is probably spinning down after a period of inactivity. 

Jon...kf2e
Photo of Steve N4LQ

Steve N4LQ

  • 568 Posts
  • 92 Reply Likes
Good idea Jon. It just occurred to me that I use a separate monitor for SSDR and never need to minimize.
Photo of Rob - AG6RK

Rob - AG6RK

  • 8 Posts
  • 2 Reply Likes
This disconnect happens to me in a random pattern and I'm running Windows 7 with all current updates, system disk is an SSD, and no power saving enables in Win7 except for turning off monitor after 5 min's of inactivity. About half the time it disconnects, need to power cycle the 6500. Hopefully this is fixed in V1.4
Photo of K1UO - Larry

K1UO - Larry

  • 731 Posts
  • 119 Reply Likes
I have the exact same random disconnects with Win 7, an SSD disk and power management turned off here as well Rob.  Usually no other external activity except leaving it and other Ham programs left open and running.  
Photo of Dudley - WA5QPZ

Dudley - WA5QPZ

  • 212 Posts
  • 45 Reply Likes
Jim,

You may want to turn this into a Help Desk question.. 

Make sure your Windows is up todate

Check that the Startup tab in the Radio Setup menu,  says,   "GPU Capability: Maxumum Graphics Acceleration"  if not change your graphics settings,  to prove this minimize the waterfall,  SmatSDR is very graphic intensive . 

Set you Power Options to "High Performance" 

Laptops are usually pretty graphic/performance challeneged verses a desktop. 

 
Photo of Guy G4DWV/4X1LT

Guy G4DWV/4X1LT

  • 1687 Posts
  • 387 Reply Likes
SSDR says "GPU Capability: Maxumum Graphics Acceleration"  when used with my laptop's integrated graphics card and runs maxed out without issue. It's an Intel 3000 HD which I do not think is known for its 3D grunt, hi hi.

Merry Christmas and Happy New Year.
(Edited)
Photo of James Kennedy-WU5E

James Kennedy-WU5E

  • 295 Posts
  • 31 Reply Likes

THANKS MY Windows 7 Desktop will be back tomorrow. Now I know I need a more powerful laptop.


Jim

WU5E


Photo of KM4CQG

KM4CQG

  • 222 Posts
  • 34 Reply Likes
Windows 8.1 with no such issue.

Look elsewhere for the problem I have ran the 6300, 6500 @ 6700.


Good luck
Ian
(Edited)