Status of 2.0 upgrades with radios that were crashing

  • 3
  • Question
  • Updated 1 year ago
I was wondering if anyone that was having crashes has upgraded to 2.0?    My plan is to give 2.0  a week or so before I retrieve the radio from is air conditioned resting place in the warehouse, not being an early adopter, but I would like to get a few reports on how 2.0 is working for those who had issues with the previous version.  

Paul -W4PGM
Photo of Paul Mandel

Paul Mandel

  • 82 Posts
  • 21 Reply Likes

Posted 1 year ago

  • 3
Photo of Michael Coslo

Michael Coslo

  • 854 Posts
  • 211 Reply Likes
Eventually I will update - probably in a month, after the initial flurry of updaters. I'll let people know then. 

note: I only had one crash which was fixed, so I might be an outlier. 

note 2: an update hosed my WSPR setup, so I did the uninstall-reinstall tango, and it fixed it. Been fine since. 

note 3: I still really think, hope, and cajole that FlexRadio Systems will consider my FlexRefresh idea of a small application that you can run as  a matter of habit every time Windows does an update. It would be a psychological boost, much better sounding than "A Windows 10 update hosed me again"

note 4: the latest update has been hosing some video drivers. 
Photo of Jim Gilliam

Jim Gilliam

  • 867 Posts
  • 187 Reply Likes

I have mentioned this before. I use a USB drive to run my Windows operating system. It gives me the pleasure of always going back to my hard drive if something goes awry and I don't play this waiting game. WinUSB allows one to image their operating system on a USB drive and you can run wild not caring what happens.


Jim, k6QE

Photo of Mark - WS7M

Mark - WS7M

  • 1026 Posts
  • 364 Reply Likes
Wow air conditioned warehouse... Is it connected and working there?

I have not been able to be very active due to work time constraints so 2.x was interesting to me as I could probably use my radio more remotely.

So far it is stable.  Here are a couple of things:

1) Read the quick start guide front to back and read it again before you attempt the upgrade.  I think the vast majority of issues have been people not following a step.  

2) I DID NOT use a google or facebook login for SmartLink.  I am not sure if that is any issue but to me it was one more possible weak link.  I created my own account based on my email and a password.

3) I disagree with the FRS employee that said you do not need to uninstall SmartSDR 1.x.  Well he is partially right but once you do update to 2.x you really cannot use 1.x as it will require you to downgrade your firmware.  So I uninstalled it.    My sequence:

a) Reboot the computer
b) Reboot the radio
c) Run SmartSDR 1.x and make sure I can find the radio and connect to it
d) Disconnect and quit SmartSDR, SmartSDR CAT and DAX control panel
e) Using programs and features in control panel:  uninstall SmartSDR.  Uninstall FlexVSP.
f) Reboot
g) Install SmartSDR 2.x

4) After installing SmartSDR 2.x BEFORE you try to do anything with smartlink, run SmartSDR and your radio should show up with an UPDATE label.  Go ahead and update it.

5) When the radio is updated attempt to connect to it locally (no smartlink) using SmartSDR.  This is where you will probably be prompted to purchase a license.  I used paypal and had no issues.  I assume credit cards have worked ok.

*** At this step quite a few people have had issues getting the server to refresh and show their copy as licensed.  If this happens I think you need to call FRS so probably best to do this during regular hours in case there is a problem.  I did not have one.  It just worked.  I had to refresh twice but after that it locked in.

6) Again attempt to connect to your radio locally (no smartlink).  You should be able to connect and run as you did before in 1.x.

7) Assuming you get this far, follow the process in the quick start guide for setting up and registering the radio for SmartLink.  You will need a mic or key to actually key the radio.  In my case I was able to use my WinKeyer USB and I had to send like three V characters and it came back and said it was all good to go.   As soon as I did this my copy of SmartSDR 2.x I had running at work and logged into my SmartLink account suddenly showed my radio.

From this point on I could connect to my radio over smartlink anywhere that I had installed 2.x and logged into SmartLink.

That last statement is key:  You need to remember your SmartLink login/password as you will use it on your laptop, your iPad, your phone, any additional computers etc.

At this point is fully possible now for you to go to a friends house, even a non-ham, install SmartSDR 2.x on his or her Windows computer, login to SmartLink and run your radio remote and show it off.

Of course you can do this on your own laptop but if you had a ham friend that wanted to try your radio and you were feeling generous you could do exactly that.  Install 2.x for him/her, give him/her your SmartLink login/password and they can run your radio remote.

At this point in time you have the following abilities:

1) Voice Rx/Tx  IE if the remote computer has a mic of some kind you can transmit using it
2) CW using the cwx window

You cannot do anything that requires DAX as digital audio is not coming over yet.

You also cannot directly control other shack devices like rotators, amps, etc through this interface.  For that you will still need a VPN or other access to your shack.  

When FRS comes out with power genius amp then you will be able to control that.  But anything else you are on your own.  For this reason I still have a VPN setup so I can control various parts of the shack.

This is probably more than you wanted to read but it is what worked for me.  After installing it feels like the same SmartSDR that it always was.   SmartLink offers a low-bandwidth connection which seems to work ok on slower LANs but probably not all.
Photo of Michael Coslo

Michael Coslo

  • 854 Posts
  • 211 Reply Likes
Tim, have the adult beverage of your choice - on me. I'll reimburse you when I see you at Hamcation in February. 

Aww, heck - have a couple. You deserve it.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
:-)
Photo of Norm - W7CK

Norm - W7CK

  • 747 Posts
  • 152 Reply Likes
I actually asked the author of DDUtil about a year ago if he would be willing to implement a client that could be used when running remotely.  He declined and if I remember correctly said he didn't have any plans to implement that functionality.

I'd sure love to see a Client/Server DDUtil.  That would give us FULL control of our amps, tuners, rotors as well as a clean interface to our Flex 6000s.

Norm - W7CK
Photo of Bill W2PKY

Bill W2PKY

  • 461 Posts
  • 79 Reply Likes
Sad to say my radio crashed after 24 hours.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
Bill, based on your HelpDesk ticket, your radio did not crash (a fatal error); the firmware was still running.  You had a disconnect (which can be caused by numerous reasons not related to a crash) and when you powered down the radio normally, CAT threw an inner exception error. 
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3593 Posts
  • 1446 Reply Likes

@Norm

A lot of us would be happy to pay for a Web Interface to DDUTIL so we do not need to VPN to be able to control Amps, Rotors, SteppIR's

Yes I know you can send frequency data via USB but that is not sufficient for remote control

Photo of Jeffrey Kerber, N3VE

Jeffrey Kerber, N3VE

  • 119 Posts
  • 18 Reply Likes
Howard, I too would pay for that.
Jeff
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4025 Posts
  • 1248 Reply Likes
Wouldn't it be nice to have a gob of DDUtil macros remotely available, too!
Photo of Larry Benoit

Larry Benoit

  • 65 Posts
  • 15 Reply Likes
DDUtil will work natively for remote operations without VPN. There is a simple and effective solution for using DDUTil to control accessory equipment with serial interfaces while using SmartSDR 1.x or  2.0 for remote operations: Ethernet to serial adapters.    

While I haven't upgraded to 2.0,  I've installed a USR-540 (4 port serial to Ethernet adapter) and operated seamlessly over a LAN and WAN with excellent results. VPN is not needed to support these adapters, nor is a running computer in the shack. I've also successfully employed Startech Ethernet to serial adapters. 

73,
Larry KB1VFU
Photo of Roy Laufer

Roy Laufer

  • 439 Posts
  • 45 Reply Likes
Getting back to the original question:

I had a consistent string of crashes with the last non-beta version of 1.10.

I updated to 2.0 yesterday and had a little problem with my 2M FM signal dropping out for milliseconds. I down-graded, then re-flashed 2.0, powered down, unplugged it and then started it back up and now FM is fine.

In the 1.10 past the crash interval varied, from 3 hours to 36 hours...

It's been 38 hours and no crash!

Thank you FRS!

73,
Roy AC2GS
Photo of Rick W7YP

Rick W7YP

  • 72 Posts
  • 42 Reply Likes
Like you, I had a nonstop string of crashes with 1.10.  I was hoping that 2.0 would make that ancient history for me; sadly, I've crashed twice in my first 38 hours on 2.0 with two HF pans and one 2m pan.  I hope you have better luck.

Rick
Photo of Mike - VE3CKO

Mike - VE3CKO, Elmer

  • 357 Posts
  • 134 Reply Likes
I would more call a lockup, but seemed more prevalent when I both panadapters were open on the 6700 with one of them on 2m. So far all good.
Photo of Rick W7YP

Rick W7YP

  • 72 Posts
  • 42 Reply Likes
I've crashed twice in my first 38 hours under 2.0 with two HF pans and one 2m pan.  I hope you have better luck.

Rick
(Edited)
Photo of Lee

Lee, Elmer

  • 677 Posts
  • 285 Reply Likes
I've been running V 2.× for 6 months in the alpha channel. I't's VERY STABLE.

73 W9OY
Photo of Rick W7YP

Rick W7YP

  • 72 Posts
  • 42 Reply Likes
In the first 38 hours of running after upgrading to 2.0,  I had the radio crash twice.  Unlike the regular crashes I was having with 1.10.16, neither of these crashes trashed my panadapter and slice receiver configurations.  The radio responded to a short push of the on/off switch, albeit it took roughly 60 seconds to shut down.

I'm working with Tim at FRS to resolve this issue.  I'll keep the group aware of our progress.

Rick
Photo of Kevin - KS0CW

Kevin - KS0CW

  • 89 Posts
  • 11 Reply Likes
i was beginning to wonder if this was going to rear it head... 
Photo of Kevin - KS0CW

Kevin - KS0CW

  • 89 Posts
  • 11 Reply Likes
FWIW... my radio under 1.x has always responded to a short push of the on/off switch, albeit it took some time to shut down....
Photo of Rick W7YP

Rick W7YP

  • 72 Posts
  • 42 Reply Likes
Lee, would you mind sharing what, if anything, you have hooked up to your 6XXX's USB ports and what panadapters and slice receivers you have configured?

Thanks!

Rick
Photo of Andy M5ZAP

Andy M5ZAP

  • 164 Posts
  • 35 Reply Likes
Hi,

I have had no Flex lockups since installing V2.0 on day of release. However my lockups were rather sporadic and often clustered in groups.

 I will report back if I do get any lockups on V2.0  So far so good!!