SmartSDR-IOS update Version 2.3 is here !

  • 7
  • Praise
  • Updated 9 months ago
SmartSDR-IOS V2.3 is ready for download at Apple App store.


Thanks to Marcus DL8MRE !

Hey, why you not let some "stars" and a comment about this software at APP store?

Marcus did a great job, do a good support and has a "open ear" for our feature requests!




73 Chris
DL5NAM
Photo of Chris DL5NAM

Chris DL5NAM

  • 593 Posts
  • 130 Reply Likes
  • good

Posted 10 months ago

  • 7
Photo of John - K3MA

John - K3MA

  • 273 Posts
  • 78 Reply Likes
TU, very nice.
Photo of KF4HR

KF4HR

  • 138 Posts
  • 49 Reply Likes
I really like the color intensity panadapter fill.  Excellent idea Marcus!
(Edited)
Photo of Chris DL5NAM

Chris DL5NAM

  • 593 Posts
  • 130 Reply Likes
Yes, and that in combination with the spotted calls (DX cluster option) shows very useful. 

Have Marcus asked to have also a "peak hold" function  in scope window - cross my fingers. I don't know is t possible.

Chris
Photo of Chris DL5NAM

Chris DL5NAM

  • 593 Posts
  • 130 Reply Likes
Photo of Bob G   W1GLV

Bob G W1GLV

  • 670 Posts
  • 112 Reply Likes
Nice work Marcus. Love the app.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3571 Posts
  • 1431 Reply Likes
Just wrote a review for the APP Store... still the best app in the store
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2266 Posts
  • 899 Reply Likes
Btw I believe TMobile smartlink users may be good to go now. There is an IPv6 option in the settings which enables IPv6.
Photo of Bob  KN4HH

Bob KN4HH

  • 95 Posts
  • 21 Reply Likes
I have been running SmartSDR for iOS on the T-Mobile network for three days. and all functions are supported.  However, you must be running iOS 11.2.5 and SmartSDSR for iOS 2.3.0.  You must also enable the IPv6 option in SmartSDT for IOS
(Edited)
Photo of K3SF

K3SF

  • 186 Posts
  • 53 Reply Likes
well it use to work on my ipad 2 running ios 9.5.3 apple no longer provides ios updates for this ipad2
and
now not able to download the updates to smartsdr
and
smartsdr wont run cause it wants the latest data updates  ;-(

might be good idea to identify list of ios products it now currently run on


i do have ipad pro and iphone 8 where it runs perfectly

Paul K3SF
Photo of K3SF

K3SF

  • 186 Posts
  • 53 Reply Likes
hi guys

true App store does say ios 10 BUT I have been running it on ipad 2 with ios 9.5 and  it still runs  BUT when i go to update data is says update data from app store BUT wont update data from app store.  just trying to understand if it really necessary to update data and what impact it may have on version i am currently running on the ipad2

i am running against the demo cause i am waiting for my 6600m to arrive it did work ruuning my 6300 but that was over 8 months ago when i sent it in as part of the trade-in program...

even if i can not run the panafall i would like to still use it a a control surface

just trying to understand what are the issues being left behind...
note the ipad 2 can not be updated to ios10 even though it has the compute power to do handle it ;-((

here are recent screen captures from the ipad2

Paul K3SF


(Edited)
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
I think the pragmatic answer is since you are using the older version of the app it will work with your radio until it doesn't.
Photo of K3SF

K3SF

  • 186 Posts
  • 53 Reply Likes
hey tim

i agree...

i was just just hoping that chris may be able to provide some insight  as to when that may be.

BUT
The real question is can the older app run fine use older data on older ios with the current flex radios running current ssdr?



i havent be able to test as no flex here currently to try it. i do know my 6600m should be shipping soon so i can test it live.

Like i said before i do have ipad pro and iphone 8 each running latest ios
and no issues there...latest app, latest app data..


paul K3SF
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9152 Posts
  • 3478 Reply Likes
we don't do reverse regression testing. 

If you are getting a 6600, it will not work with that version of the iOS app.  The radio must run SmartSDR v2.1.30 or greater and version 2.1.30 is only supported with version 2.3.0 of the iOS app.
(Edited)
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2266 Posts
  • 899 Reply Likes
From the manual:

In addition to App updates, I am providing so called Data-Updates. Such Data-Updates can be used to update certain databases of the App such as the DX-Cluster Server database or Bandmap.This way, I can provide updates easier and quicker without the long lasting AppStore release process.Once there is an update available, normally, you will get notified and can install a Data-Update straight away. However, my App will only check for Data-Updates once per day and only if you are connected via WiFi to prevent wasting your data plan.For this reason, please check from time to time, if there is a Data-Update available by hitting the Check for Data Update button.

So it looks like you can just ignore the update if your iOS device doesn't support the update. 

If it keeps nagging you, you may want to send a note to Marcus and see what he can do, but iOS apps are not really friendly to downgrading. 

As an iOS developer myself - I feel the pain of having to support older devices, not because they are old but because occasionally Apple just blows that up when they force you to use certain minimum versions for App Store submission and also certain features are only available in later versions and the code is not backwards compatible.
Photo of Harry Williams

Harry Williams

  • 98 Posts
  • 8 Reply Likes
I do not see any option to do the update. I have version 2.2.2. If I tap check for data updates in the app it says "data update available". When I go to the app store there is the app does not show and I have no option to update it. How do I resolve this??

Thanks,
Harry
W0LS
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2264 Posts
  • 897 Reply Likes
If you are not on iOS 10 and above no update is available. 
Photo of Harry Williams

Harry Williams

  • 98 Posts
  • 8 Reply Likes
Hi Ria...ios settings says I am at 11.2.1. I am updating now to 11.2.5...

Harry
Photo of Harry Williams

Harry Williams

  • 98 Posts
  • 8 Reply Likes
Problem...after I updated the ios from 11.2.1 to 11.2.5 the update option was displayed and all is well.

Thanks.....

Harry
W0LS