Smartlink & Flex6300 problem.

  • 1
  • Question
  • Updated 10 months ago
Hi guys ! I have update the last V2.017 firmware on my flex6300 but I have the problem with the port TCP & UDP on Smartlink connection .
I enable the UPnP on my router but the test is KO , also I enable the forwarding ports but the test is KO .
This is the firmware problem on Flex6300 or ISP problem ??

TNX de IK6QOO Gianluca
Photo of Gianluca Ianni

Gianluca Ianni

  • 3 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 824 Posts
  • 168 Reply Likes

Did you register your radio with Smartlink? That is the procedure where you have to key your radio locally to be recognized as a valid ownerr.


Jim, K6QE

Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 195 Reply Likes
Gianluca

It is not very clear what problem  you are experiencing.    Can you post a screen picture of the problem you are seeing?   I am not sure what KO means.  

You might want to try rebooting your radio as well and see if you have the same problem as that will ensure that uPNP registers with your firewall.

However, to answer your question, no, there is not a firmware problem.  I am unsure about your ISP.

73, Mike va3mw
Photo of Ken Hansen

Ken Hansen

  • 247 Posts
  • 65 Reply Likes
Gianluca - Something I discovered with my SmartLink setup was that once I made a change on the network settings panel (choose auto or manual port forwarding), I need to 'Save' my change before I could test it.

Also, I was baffled by why there were '-1's in the two port fields, it wasn't obvious to me that I needed to pick two unique external ports to forward to the radio. Once I set the network config to 'manual' port forwarding, set the two ports to be the same internal and external (4993 & 4994), and established a port forwarding rule in my firewall directing those two ports to my Flex 6300's IP address, I got the green light.

Hope this helps, Ken, N2VIP
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9029 Posts
  • 3430 Reply Likes
The "-1" indicates the radio does not have any values for the TCP and UDP ports.
Photo of Gianluca Ianni

Gianluca Ianni

  • 3 Posts
  • 0 Reply Likes
Thank you all !!
My flex 6300 is registered on smartlink , the KO is the red when i send the test  , in manual mode i replaced the -1 value with 4994 & 4993 ports and i redirect this port on router ports forwarding.
Other port forwarding services work well .
My doubt  is a firmware bug of 6300 or ISP problem ??
Photo of Ken Hansen

Ken Hansen

  • 247 Posts
  • 65 Reply Likes
Gianluca, I'm confused, you are properly routing each port with the proper message traffic (TCP & UDP), and still having problems?

Please clarify, and also please explain how your radio is connected to the internet - I suspect you are set up as:

ISP -> modem/router -> network switch -> flex

Correct?
Photo of Gianluca Ianni

Gianluca Ianni

  • 3 Posts
  • 0 Reply Likes
my setup is :
 ISP>modem/router>flex6300  

I redirect the 4994tcp to 4994/IP_Flex6300 and 4993upd to 4993/IP_Flex6300    but the test is RED

also i enable the UPnP on mt router and i set to automatic but the test is RED .

I suspected the problem is my ISP .