No connectivity between CAT and FLdigi

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I just installed Smart Cat for the first time and started the program. It found my 6500 and assigned a 3rd party port to com 6. I then started FLdigi and assigned com 6 for cat control. I went back to the cat port map and it shows com 6 as unknown. I se no cat functions in Fldigi and no ptt.
I would appreciate some assistance.

Bob, KN4HH
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
This is what my FLdigi CAT setup looks like.



You can get the SmartSDR.xml from the FLdigi XML archives.
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
Thanks, Robert. I found the SmartSDR.xml file and dropped it into the Fldigi directory. I started SmartCAT, then I started Fldigi and went to configure CAT. I used your settings. I clicked open and found the SmartSDR.xml file and clicked on it. It never appears in the definition window and I get no other responses.

Any ideas
Bob, KN4HH
Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes
BoB: I found that I had to copy the SmartSDR.xml file to the Fldigi folder "RIG".
After you open the Fldigi-Configuration-Rig-RigCAT window, Open the SmartSDR.xml file then select initialize Button. It will change from Red Font to Black Font. After you open the SmartSDR.xml file and the initialize button does not have RED font, then you are not finding the .xml file. Also ensure that you have the RigCAT box checked.
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
I'm sure when I get this figured out, it will be embarrassing. I have no RIG folder in Fldigi. I created one and dropped the SmartCAT.xml file in it. I went to the Fldigi configuration page and clicked on open and found the folder I created and clicked on the file. This time the description box comes up with rig.xml and not the SmartSDR.xml file. I am running Fldigi 3.21.77.
Photo of W4EY

W4EY

  • 153 Posts
  • 7 Reply Likes
Bob look on your computer hard drive for a "USER" folder and subfolder with your name. This is the USER name used when you start Windows. This name is usually the user with system admin. In this User/Name folder you should see the FLDigi folder. THERE should be a RIG file in the FLdigi folder. Put the SmartSDR.xml file in this folder. FLdigi should have several folders in the FLdigi folder. Example is the DATA, MACRO and other folders where the FLdigi macros are stored. I use FLdigi 3.21.77 also. SmartSDR.xml should show up in the RIG xml box and the Inatilized Button should have a RED font. When you push this button the font will turn black.
Then SAVE the config.
Photo of James Kennedy-WU5E

James Kennedy-WU5E

  • 290 Posts
  • 31 Reply Likes
BOB, I went followed what you said above and copied the file , but SmartSDR.xml will NOT show up in the not sure what the problem is. If I could convince my buddy n8wp to get a flex 6500 he would beat this battle.

Jim
WU5E
Photo of Ned K1NJ

Ned K1NJ

  • 298 Posts
  • 75 Reply Likes
In Fldigi menu bar: Files> folders > fldigi config...
will bring you to the directory where fldigi wants to see
the .SmartSDR.xml file. You can make note of it and put
the .xml file there. Of course, there may be other problems,
but that's a start.

Ned, K1NJ
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
Thanks, guys for your patience. I placed the SmartSDR.xml file in the correct folder. When I go to the Fldigi config page, nothing is in the description window. I then click on Open and the SmartSDR file is displayed. When I click to open the file, the computer goes into a wait state and never does execute.
Now, when I downloaded the XML file from Fldigi, it did not save as an xml file but rather displayed the xml code of the file. I tagged all the code and pasted it into a notepad text file and changed the extension to .xml

Many thanks for all of your suggestions. It has to be some subtle thing I am overlooking.

Bob, KN4HH
Photo of Ned K1NJ

Ned K1NJ

  • 298 Posts
  • 75 Reply Likes
Try right clicking smartSDR.xml on the fldigi page and use
"save link as". I found that this worked after trying something
like what you are doing. It doesn't like being downloaded as
a pure text rendition of the xml file (left click, file opens, etc.)

Ned
Photo of Robert -- N5IKD

Robert -- N5IKD, Elmer

  • 488 Posts
  • 152 Reply Likes
Bob,
What Ned described is the best way.

Alternately you could change the file extension, but you have to see it first. You can follow these instructions from the Microsoft web site to make the extension visible.

Open Folder Options by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options.

Click the View tab, and then, under Advanced settings, do one of the following:

To hide file extensions, select the Hide extensions for known file types check box, and then click OK.

To display file extensions, clear the Hide extensions for known file types check box, and then click OK.
Photo of Robert Watson

Robert Watson

  • 22 Posts
  • 0 Reply Likes
SUCCESS! Many thanks to you all. Each one of you gave me a piece of the puzzle. First, I needed to know about the config file, then where to put it and lastly to save the target to the Fldigi folder rather than importing the xml code into a text file and moving it to Fldigi. All is well and BTW DAX worked first try.

Thanks again to all,
Bob, KN4HH
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8459 Posts
  • 3157 Reply Likes
Excellent!!!!!