Multiple WSJT-X working but band indicator is RED

  • 1
  • Question
  • Updated 8 months ago
I have multiple WSJT-X instances running on my 6600 like I did on my 6500 before.
I use the WSJT version provided from WO2X with the hamlib changes to support the new radio models.
I'm using the TCP port numbers different per-slice.
First instance completely works fine, second and third instance work fine to read the frequency of the slice, transmit and receive audio but the band indicator is shown in red and the drop-down button to set the band is empty ..

Has anyone seen this, and what might be the issue ?
Clicking testCAT or testPTT also works fine.

Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes

Posted 8 months ago

  • 1
Photo of YV5WZ

YV5WZ

  • 393 Posts
  • 48 Reply Likes
Check you have Frequencies saved in settings
Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes
Interesting .. the two other instanes have those frequencies list in settings empty
for some reason... the first instance has 120 entries there... will see if there's an
easy way to copy them over...

But that seems to be the issue indeed, thanks for pointing that out
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 123 Posts
  • 40 Reply Likes
In the instances with missing frequencies, go to Settings / Frequencies, and right-click on the frequency list. You will see a "Reset". Clicking on that reset will repopulate the frequency list for you.
Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes
ok, that's probably the easiest repair...  maybe my INI file got corrupt and that list disappeared.. a bit weird .. but up and running again now. thanks for the help
Photo of Ted  VE3TRQ

Ted VE3TRQ

  • 123 Posts
  • 40 Reply Likes
There was a release candidate or two of wsjt-x that lost the frequency settings some time ago. The same technique was recommended to fix that problem, so this carries over to running multiple instances quite nicely. Also gives you a way of reverting the the "standard" setting for frequencies if you have been experimenting.
Photo of Wim

Wim

  • 90 Posts
  • 17 Reply Likes
repaired it by copying that frequency list from one .INI file to the other
section named FrequenciesForRegionModes="@Varian..."
Photo of YV5WZ

YV5WZ

  • 393 Posts
  • 48 Reply Likes
I'm Glad you're Back in Business

Cheers!