Let's please get Version 1.xx fixed first then continue on Version 2.xxx

  • 1
  • Idea
  • Updated 1 year ago
  • Planned
  • (Edited)

It seems to me that the fixes for V1.10xx should have
been completed well before continuing on with a beta release of V2.xxx.  I would really like to have the updates that fix Version 1.10.16.174 which should have already been completed and released.  Why are these updates coming out after Version 2.xxx is released?  This makes no since.  It appears to me that Flex is still having issues with unfixed problems in V1.10xxx and these same problems continue to be issues in V2.xxx. With the amount of time it is taking to get V2.xx released I feel they have lost programmers that fully understood the original code which has now grown to millions of lines. New programmers will take a very very long time to catch up and may never understand the code written years ago for V1.xx. This is why I think the new software is taking so very long to complete. I am 73 years old and have programmed many applications since 1978.  The thing I hated about programming was you are caught in a continuing loop of updates and improvements. I have found it is very difficult to divorce myself from a project and expect others to pick it up quickly. It just does not happen.  I no longer write code. I rather work with hardware where there is a completion point.  Just some of my thoughts... Best of luck to Flex on getting this completed.  The frustration has been the very long wait...

Photo of David Livingston

David Livingston

  • 121 Posts
  • 27 Reply Likes

Posted 1 year ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Official Response
David,

If you have not heard, we are planning on releasing a 1.11 bug fix release after SmartSDR v2.0 is released.  We will be incorporating the bug fixes and several performance enhancements that we developed while working on SmartSDR v2.0.