Issue with ATU status message

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
The following is an excerpt from a log of messages received from the Radio hardware to my custom client program after performing a "normal" startup (initializeRadio). I'm only showing the ATU messages. Note that in the third and fourth messages that the "atu" string appears in the middle just after "TUNE_MANUAL_BYPASS" and just before the "memories_enabled".

Could this be a bug? Admittedly, my code is new and may not be correct but after looking at it for some time, I think I'm actually receiving what is shown below. I've actually logged it coming in from the socket before any processing is done in my code.

It looks as though the "_enabled=0" portion of the message immediately following the "atu" has been dropped.

It's very repeatable, I've done it multiple times with the same result.

c4|sub atu all

S7F0D191E|atu status=TUNE_MANUAL_BYPASS atu_enabled=0 memories_enabled=1 using_mem=0

S0|atu atu_enabled=1

S7F0D191E|atu status=TUNE_MANUAL_BYPASS atu memories_enabled=1 using_mem=0

S7F0D191E|atu status=TUNE_MANUAL_BYPASS atu memories_enabled=1 using_mem=0

Here's the sequence of commands that I sent to the Radio (they're in Swift but I think you get the gist):

commandToRadio("client program xxxx")
commandToRadio("client gui")
commandToRadio("sub tx all")
commandToRadio("sub atu all")
commandToRadio("sub meter all")
commandToRadio("sub pan all")
commandToRadio("sub slice all")
commandToRadio("sub gps all")
commandToRadio("sub audio_stream all")
commandToRadio("sub cwx all")
commandToRadio("sub xvtr all")
commandToRadio("sub memories all")
commandToRadio("sub daxiq all")
commandToRadio("sub dax all")
commandToRadio("info", callback: infoResponseCallback)
commandToRadio("version", callback: versionResponseCallback)
commandToRadio("ant list", callback: antListResponseCallback)
commandToRadio("mic list", callback: micListResponseCallback)
commandToRadio( "client udpport \(vitaManager.vitaPort)")
Photo of Doug - K3TZR

Doug - K3TZR

  • 93 Posts
  • 11 Reply Likes

Posted 3 years ago

  • 1
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3467 Reply Likes
Official Response
Doug - this defect was recently fixed in one of the alpha versions we are testing for the next release.  So it will be fixed with the next general release of SmartSDR which should be coming soon.