IOS SmartSDR vs K6TU

  • 1
  • Problem
  • Updated 2 years ago
  • Solved

I spent more time today with the horror show that is an Apple device that refuses to do an in-app purchase and figured finally if I install it on my failing iPad2 (it has to be reset several times to get working) so finally I was able to get on and install SmartSDR and then crossed my fingers and was able to purchase the app.

I opened SmartSDR on the new iPad Pro and clicked restore, BOOM, worked! I connect to the radio and I can hardly hear a thing, I crank the volume on the iPad and then crank up audio in the app to 100, still not very loud, say this isn't so guys!

I fired up K6TU and it gets easily twice as loud as SmartSDR, maybe I'm missing a setting, is there more than two places to modify volume?

Second item, it's much easier to tune in a signal on K6TU, I can go right to the exact frequency, on the iPad I'm trying to gently zero in and goes right by so I have to back track and miss it again.

I'm going to read the manual when I hit the sack shortly, hopefully there is something I missed because the Maestro volume is easily more than twice as loud as the iPad Pro 12.9 running SmartSDR.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Posted 2 years ago

  • 1
Photo of K6OZY

K6OZY, Elmer

  • 532 Posts
  • 198 Reply Likes
On the SmartSDR IOS app, you need to turn up the slice volume and the IOS volume too.  Did you?

Also, for precise tuning, touch the black slice area in the Pan Adapter, and a popup window appears. At the bottom is a slider you move left and right for fine tuning based on your Step setting.
Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 121 Reply Likes
Yes, I'd also like to know how you set up OpenVPN.  My Netgear R6400 supports OpenVPN, but indicates it doesn't support iOS or Android.
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

It's using TAP mode = TCP port 12974 as well as TUN mode = TCP port 12973, I got lucky in that the Netgear Nighthawk R7000 generates the files needed for Windows,  Smartphone and IOS. All I had to do was install OpenVPN connect on the iPad Pro, once I imported the files via iTunes the iPad saw the config, I fired up my MiFi at home and tested it and it worked great.

I also created an account for Dynamic DNS so when my Comcast IP changes it auto-updates.

(Edited)
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Rick,

I'm heading to work, job number two for today, I will look further into this when I'm off later today.

I found this article and I'm sure your R6400 supports it, I just need to verify.

http://www.smallnetbuilder.com/other/security/security-howto/32542-setting-up-and-using-openvpn-on-n...

Photo of Rick Hadley - W0FG

Rick Hadley - W0FG

  • 579 Posts
  • 121 Reply Likes
Thanks. I read the article, but it only appears to apply to Windows. Guess I should have bought the R7000 instead of the R6400.. Let me know if you see something I may have missed.
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes
I wrote the latest below, the SmartSDR app froze on my iPad and after rebooting it SmartSDR will no longer connect to the radio over VPN (it does list it however) so I have some troubleshooting to do, for the 24 hours it worked, I loved it.
Photo of spopiela

spopiela

  • 81 Posts
  • 10 Reply Likes
I had SSDR iOS working at home on my iPad and also used open VPN while connecting through my cell phone Data while tethered to my iPhone hot spot. Today, I am remote from home and trying VPN. I could tunnel into the home network with open VPN and could run ssdr iOS on the iPad. The only problem is that I can't get a waterfall to display. Everything else works on the app, but the waterfall. I have just a dark screen below the spectral display. I have tried every imaginable setting on ssdr and the IPAD. I've got 50 MHz down and 10mhz up going through the tunnel. I have control over network routers on both ends and they are not showing any issues. I suspect the 6500 at home received a command to shut down the waterfall and I can't bring it back remotely. I'll have to investigate that possibility and also my VPN settings on the router. I used The Udp option vs the top/ip and that might be the culprit . If anyone has any ideas, I would appreciate suggestions. Thank you.
Stan N1THL
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 148 Posts
  • 40 Reply Likes
Even though it's difficult or almost impossible to support individual VPN setups, what I can tell you is, that if you can connect but don't see the waterfall, most likely the UDP Data on port 4991 is not passing through your VPN. This could be either because port 4991 is not open or your settings don't let UDP traffic pass through.
I hope this helps.
Vy 73, Marcus, DL8MRE
Photo of spopiela

spopiela

  • 81 Posts
  • 10 Reply Likes
Marcus, thank you for the comment. I'll check out the VPN setup later today when at home. I was going to try the K6TU remote app on receive at this remote QTH but could not find it on the App Store . If it would. work with a waterfall that would give me more insight into my problem. I'll post some more forensics later today. By the way, the IOS app is exceptional with the IPad. I could have saved myself the expense of a Windows laptop , if you had released it a bit sooner. ;<)
Stan N1THL
Photo of spopiela

spopiela

  • 81 Posts
  • 10 Reply Likes
I couldn't get ssdr to show a waterfall working remotely on my Windows laptop. When I got home, I hooked up to the LAN and had the same problem with IOS app and Windows laptop. Unfortunately, I reset both my router with a new firmware update for a time and date issue and reloaded SSDR so I'm limited on explaining why everything worked perfectly on my laptop. My IOS app worked perfectly also. Sounds like router was messing up but issue was not limited to VPN.
Stan
N1THL
Photo of Jay -- N0FB

Jay -- N0FB, Elmer

  • 534 Posts
  • 211 Reply Likes
SmartSDR for IOS has all the same volume controls as does its Windows counter-part.   Check the manual at 6.1.   It walks you through all sound settings that could be causing you issues.   These would be true on the windows or on the Mac.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes
I have the sound issues sorted out now, I think part of the issue was expectations that my new iPad Pro 12.9 would play louder than my old iPad 2. After the first response I was able to get it to a point where I could hear it clearly. I have since read some of the manual as well. :)
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Well, yesterday the SmartSDR IOS app froze on my new iPad and it no longer works over VPN, it shows the radio, you select it and it just goes back to the tap to select screen. I just got home I reset my R7000, the radio, I powered up the MiFi and ran a test connect, it shows the rado but you tap to select and nothing.

I go onto my home wireless and of course it works perfect so I got 1 full day of enjoyment using the iPad Pro remotely until it stopped working. I uninstalled OpenVPN and the config files, I'll create new files and I'll uninstall the SmartSDR app and re-install and report back.

I had hoped to show this off to family to get a few interested in Amateur Radio, so much for that this weekend.

Connecting via the same OpenVPN on my laptop works fine for SmartSDR on Windows so at least that still works. More testing via iPad Pro, nada, nothing has changed except for the app locking up yesterday on the iPad.

Hitting the sack and re-visiting when I get home tomorrow after work.

(Edited)
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 148 Posts
  • 40 Reply Likes
Dear OM,

the issue is most likely with your VPN. The FlexRadio needs some additional settings and it is usually not enough when you can already use the VPN from your Windows PC.

For instance, the Radio uses a Discovery protocol that needs to have broadcast packets to pass through your VPN via UDP over port 4992. The Data (FFT, Audio, Meter etc.) will be send as well via UDP Port 4992 and the command interface uses TCP Port 4991.

Most likely, if you can "see" the Radio but can't connect or can connect but don't see the Waterfall then UDP Data through port 4992 is nor passing through.

It is very hard to say, which part of your VPN configuration broke. It could even be an issue with the OpenVPN implementation on your router. Strange that they said that they don't support iOS because there is a client for OpenVPN for iOS which works well - at least with a standard OpenVPN Server installation. Drawback of this App is that you sometimes have to start the App and re-connect in order to get the VPN running. iOS comes with it's own VPN client so no App is needed (like on Windows 10) but the App makes the configuration a bit easier.

By the way, either way whether or not you are using an App on iOS for the VPN, you should always see the a [VPN] Icon in the navigation bar of your device. If that's not there, you are not running on a VPN.

So if you like to stick with the VPN of your router, I would also suggest to start the configuration from scratch and try to consider what I wrote before.

A working alternative is to use a RaspberryPi along with SoftEther which is easy to setup and several OM did provide instructions here in the Community forum and other websites. This setup has also the advantage, that no App is needed on the iPad/iPhone and the RaspberryPi is easy to backup and restore in case of issues or messed up configurations.

Hope this helps a bit

vy 73,
Marcus, DL8MRE
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes
Marcus, isn't that 4991? TCP command and response on 4992?
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

I believe I found it, looking at attached devices on the R7000 when my laptop and iPad are logged onto OpenVPN the laptop gets a 192.168.1.26 address but the iPad now gets 192.168.254.1 address, just WTF?

I found where the connection log is on the IOS OpenVPN app and I see the log states that "Error parsing IPv4 route: tun_prop_error: route is not canonical then DHCP assigns the .254.1 address.

This is not how it was working on Saturday.


UGH.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

When this worked, waterfall and other functions worked fine, K6TU doesn't see the radio either and I believe the log points me to the answer, what I don't get is why it's now giving 192.168.254.1 when that's not in the config, this is some strange IOS OpenVPN thing that I have to wrangle with.

Unfortunately it also requires iTunes to upload the files to the iPad where Andriod isn't as closed so I could do it on any laptop.

Thanks Apple. :(

Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 148 Posts
  • 40 Reply Likes
Walt, yes, thanks you are right:

- Commands: TCP via port 4992
- Data (FFT, Audio etc.): UDP 4991
- Discovery: UDP 4992 (via broadcast)

Thanks again.
Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes
Correction: by default, however, as more clients connect with the radio from the same IP, they take different UDP ports as the 'endpoint' is IP:port and two apps can't bind to the same endpoint.
(Edited)
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Well, apparently OpenVPN assigns smartphones/iPads the IP subnet .254.x and handles the routing which is why discovery works but for some reason connecting to the radio no longer works. I just got my Note 5 onto OpenVPN and it gets assigned .254.2.

So, SmartSDR for IOS finds the radio but tapping to select does nothing, where on Saturday all day up until the app froze, it worked apparently with these current settings.

I have an old iPad 2 at home that I am going to reset to factory spec if it lets me (it has some issues) and we'll see how OpenVPN works on that, I know it won't work for a hill of beans if it does connect but all I care about right now is the app connecting to the radio.


Photo of Walt - KZ1F

Walt - KZ1F

  • 3040 Posts
  • 643 Reply Likes
Are they getting assigned the same ip, i.e. x.x.254.2? If that's the case it won't work if you have two apps connecting simultaneously. What happens is this. It opens a return port for UDP packets for the spectrum, waterfall, meters etc and when it connects to the radio object it gets passed what port number to use for the radio to act like a client to your app passing the vita packets. as I recall the radio.connect() passes back a true/false. This is what flexlib and xpslib do, cannot guarantee this is what Marcus does. But make sure your iPhone and iPad are both not running Macrus's code simultaneously. It may be inadvertantly thereby keeping the connection and port 'taken'.  "small steps Ellie, small steps".

On a smartphone/tablet your idea of not running is not the OS's idea of not running.
(Edited)
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

I only have one device that I connect at a time and always make sure a device that was being used is disconnected before trying another.

The iPad worked great on Saturday until SmartSDR froze, I had to power cycle the iPad, once it came up, SmartSDR has not connected to the radio since, even though it sees it.

I have removed OpenVPN and will re-install when I get home since I need iTunes to upload the OpenVPN files.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

I forgot to address this one, Quote - "On a smartphone/tablet your idea of not running is not the OS's idea of not running."

If I disconnect the device from the VPN, not running is exactly that, not running. It doesn't matter if somebody forgets to close SmartSDR or if the OS has it open in the background, if you disconnect the device from the network, there is no way for it to cause a problem for another device.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

I removed OpenVPN from my iPad Pro, deleted the config files and then created new config files with the R7000 and tried to connect to the radio after connecting via OpenVPN, no dice, it sees the radio but does not connect, something happened to this device after SmartSDR froze on it and it will not connect to the radio anymore.

My 4 year old iPad 2 connected to the radio fine via the VPN, it was choppy but worked. So it looks like I'll be restoring the iPad Pro to factory settings and starting over when I have the time.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Ok, this makes no sense, when you go into the iPad settings for VPN it states to use the OpenVPN app to connect. So of course I ignored that and clicked to turn on the VPN from within the settings app which connected instantly to the R7000 and then opened SmartSDR, clicked on the radio and wouldn't you know it, I'm connected to the radio and listening to QSO's on 80m!

I'm going to let it run in the background for a bit and hopefully it doesn't freeze again.

Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 148 Posts
  • 40 Reply Likes
Dear OM (still don't know your name or Call). As you can see and as mentioned, it is not a problem of my App but of your VPN. When the App froze, your VPN was gone and the App froze because it didn't receive any more data even though the TCP data channel still seemed to be intact and reports a available radio.

For the reason why your VPN stopped working there could be a couple of reasons. My assumption is, that there might have been set some kind of timeout (e.g. on your Router (VPN Server) side or on your Client configuration for the OpenVPN App.

However, next time when the App freezes, tap the home button and check for the [VPN] Icon I mentioned in my previous post - or open the OpenVPN App and see if you are still connected.

Anyway. It is good that you solved it and for others who may run into the same issue, please keep in mind what I wrote about the [VPN] Icon at the top of the main iOS screen. It it is not there, you are not connected via VPN.

vy 73,
Marcus, DL8MRE
Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

Marcus,

Thank you for responding. Let me clear this up, the VPN was connected at the time of the freeze up and for each and every attempt to connect to the radio. I'm not blaming SmartSDR, for all I know it's something within IOS that crashed, who knows but I it was still connected to the VPN.

Hitting the home button did absolutely nothing so I power cycled the iPad and reconnected to the VPN. SmartSDR saw the radio but wouldn't connect to it, I'm not blaming SmartSDR, just stated that ever since the app froze, it has not connected to the radio since (until today), from 4 different locations and while using my AT&T MiFi.

For the sake of clarity I never once said the VPN stopped working, I stated the radio would be seen but could not connect. Each and every time I have not been able to connect, the VPN was active and showed the radio as available, every time. The problem was I could select it and it would take me back to the "tap to connect" screen.

I have reconfigured the VPN from the R7000 to the iPad and it still didn't work, could this be something strange dealing with the VPN, absolutely. Again, not blaming your app, the VPN is best effort for sure and since I have zero control over the config files because its through Netgear I have to assume if it works once, it should be repeatable.

I don't know how selecting VPN from IOS Settings, where Apple states to use the OpenVPN app works, makes zero sense but it seems to.

Thanks for putting out this app Marcus, I've been enjoying it quite a bit iPad issues aside. :)

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

I was going to eat lunch at my desk and now while connected to the VPN it says search error, rebooting and recycling the R7000 and iPad does nothing so I'll try later.

VPN is connected, I checked the status on the R7000 and it shows things exactly like it always does, that the iPad is connected, the same address, everything looks the same.

I'm going to contact Netgear and ask if there is a way to go with one configuration, I believe that within the OpenVPN config there are various methods it tries, depending on which one succeeded it works or it doesn't. I'm going to see how much is in the OpenVPN log, maybe that will yield some information.

Photo of KC9NRN

KC9NRN

  • 324 Posts
  • 32 Reply Likes

If somebody wants to close this I'm sure this is a Netgear/OpenVPN thang. It's now working of course and I did nothing to change anything except to wait 10 minutes.

This conversation is no longer open for comments or replies.