I am trying to get my new 6600 working with WSJT-X RX works CAT does't

  • 2
  • Problem
  • Updated 3 months ago
  • Solved
I am setting up wsjt-x with my new 6600. Not clear what to put in the box for network. latest SRD and SRD CAT software. I have put in the Radio as Flex 6xxx and tried a number of Network Servers names. I have set up a com port and also set up a TCP port 60001 as discussed in some of the community postings. Tried the Kenwood 2000 Rig to no avail. The receive side of WSJT-X is working fine and decoding. Using Slice A. In the wsjt-x settings when i Test CAT is turns Red and get a message Rig Failure Hamlib error: Protocol error while opening connection to rig 
Or Hamlib error: Invalid configuration while opening connection to rigRig. 

Any suggestions would be appreciated. The inputs in the community seem to be different for different radios and different software versions. Maybe I missed something in the documentation. WSJT-X ver 1.8.0 K1JT . Has been working great with my FT1000MP MarkV. Flex 6600 also works will with HRD. 

73
Bill
W9JJB
Photo of bahillen

bahillen

  • 40 Posts
  • 11 Reply Likes

Posted 5 months ago

  • 2
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1086 Posts
  • 220 Reply Likes
Official Response
WSJT-X 1.80 release version on their site does not have an updated Hamlib library in it to support the new models of Flex radios (6400/6600). I have contacted the Hamlib developers and their current version of Hamlib is now updated.

I am in contact with the WSJT-X development team to have them update the Hamlib library in the official version on their site.

I have compiled Hamlib and WSJT-X with the changes. This is the same current version of WSJT-X (1.80) but includes the updated Hamlib to support the 6400/6600 radios.

Here is a link to download it from my Dropbox. 
https://www.dropbox.com/s/9qucywqxybjng0d/wsjtx-1.8.0-win32.zip?dl=0 

Just unzip, then install. You do not have to uninstall the 1.80 version you already installed.

As per previous instructions you need to create a TCP CAT port (which you did) and then choose Flex 6xxx for radio type and enter the IP 127.0.0.1:5004 (5004 is the TCP port I created, substitute the port number for whatever you created.

73
Dave wo2x