How do I determine what is causing SmartSDR to run "choppy?"

  • 3
  • Problem
  • Updated 4 months ago
Sometimes SmartSDR for iOS seems sluggish. It's usable but it's not as "flowing" as the desktop version, and sometimes there are audio dropouts. I have seen this on local LAN with a new iPad Pro and iPhone 7+ and also via VPN. Same VPN connection runs dpSDR and SmartSDR for Windows without issues. 

I am wondering if there is any diagnostic that SmartSDR for iOS has to determine what the problem is? 

I should also say that sometimes it runs absolutely perfect. So this is baffling.

My local network connectivity is 802.11ac into a netgear managed gigabit switch and I'm pretty sure it's not the wifi as nothing else gives problems. 
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes

Posted 2 years ago

  • 3
Photo of Rick - W5FCX

Rick - W5FCX

  • 188 Posts
  • 40 Reply Likes
I'm running purely remote and sometimes see the same thing over VPN. I have found it's usually network latency in excess of 50 milliseconds combined with FPS and/ spectrum update rate set too high.

Try:

1) clicking on network icon and watch latency and packet error rates to identify issues there

2) reducing slice FPS to 3 and spectrum refresh to around 50.

I have this config saved as Remote Operation and use it when operating remote over VPN from PC, iOS and Maestro. Solved my issues.

Rick
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
I doubt that it's latency. My latency is at worst 10-15ms, most times 2-3ms.  The connection I am on (at work) is a gigabit fiber connection from Level3 that I almost have entirely to myself.  It also doesn't explain the local issues. 
Photo of Rick - W5FCX

Rick - W5FCX

  • 188 Posts
  • 40 Reply Likes
Yeah that's odd. Did you try reducing the FPS and waterfall update rates to see what difference that makes?
Photo of Larry - W8LLL

Larry - W8LLL

  • 381 Posts
  • 75 Reply Likes

I was having the same problem, check out this post for info on how I solved it on my end.

https://community.flexradio.com/flexradio/topics/smartsdr-for-ios-cutting-in-and-out

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
Lowering fps seems to help some. I am thinking that even the latest hardware cannot keep up with the CPU demands of the app.
Photo of Larry - W8LLL

Larry - W8LLL

  • 381 Posts
  • 75 Reply Likes
Try my suggestion in the link, it has worked for me and others for the ssdr ios studdering issue. Regular ssdr local and remote was never an issue, it was just the ios studdering. It seems to be either an incompatibility between ssdr ios and the 802.11ac standard on some routers or possibly the mixed frequencys, 20 mhz seems to work well. My older 802.11n router does not have an issue playing nice with ssdr ios.
(Edited)
Photo of Rob Fissel

Rob Fissel

  • 270 Posts
  • 47 Reply Likes
Ria, considering you've told me the basics of your home network, and you're experiencing this while on your home LAN in addition to VPN WAN, something is amiss here.

I can't say I've ever had an issue while on the home WLAN with buffering/stuttering issues on my iOS devices. I've deployed several access points on 5GHz throughout the house to resolve any dead spot issues. All of my local SmartSDR activity that takes place outside of wired connections occurs on 5 GHz channels. I have had issues in the past on 2.4 GHz with SSDR on my MacBook Air while in different parts of the house, but a full blown separate 5 GHz network resolved those issues. I've never attempted to connect the iOS devices to the 2.4 GHz network for SSDR actives, but can try. 

I also had some minor issues on the 5 GHz network. Forcing the AP's to slave to a 20 MHz channel solved this. I think that an issue may have been the device and or AP trying to switch between 20/40/60 MHz channels, but I have no empirical data to back this up. 

Even living in a rural area, and not having to compete with every 2.4 GHz router in the neighborhood, the 2.4 spectrum is still competing with Bluetooth devices, your microwave, etc. 
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 263 Posts
  • 36 Reply Likes
I've had a problem with my Maestro talking to my 6300 for as long as I've owned it.  I called Dudley at Flex a few weeks ago and he asked about my network arrangement between the two units. 

The only device intermediate of the two was a gigabit switch.  Dudley advised that I replace it with a 100Mb switch.  His explanation was that the 6300, when connected to the gigabit unit, auto detects the faster device and can produce so much data that, on occasion, it can overwhelm the switch creating a log jam and therefore latency. 

Of course given such a switch's location, this could occur no matter what the rest of the network looks like, WAN, LAN or VPN.  He said that when connected to the slower switch, the 6300 auto detects this and cuts back on data quantity.

This advice seems counter intuitive to me but I followed his suggestion yesterday and put in the slower switch.  So far I've had five green bars on the Maestro ever since.

Dudley also had some suggestions for gigabit switch models that would do better than mine but I lost track of them as I had a slower unit on the shelf.  Maybe he can chime in here with that information.

73
(Edited)
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 263 Posts
  • 36 Reply Likes
I'll update how things are going here in the next few days. Please do the same. My Maestro & 6300 have been & will remain powerd on 24/7.

I'll also detail the switch models I've tried after my week long testing is complete.
(Edited)
Photo of W4KCN

W4KCN

  • 28 Posts
  • 6 Reply Likes
I have wrote some software that utilizes the FlexLib API and allows radio control via the web.  I have ran into issue where my router (ASUS N66U) is too taxed(?) and requires a reboot to clear the issues.  Basically, the traffic just comes to a crawl and updates from the API are severely degraded.
Photo of WX7Y

WX7Y

  • 519 Posts
  • 94 Reply Likes
I think on the N66U there is an option called "traffic manager" like my AC-66u does, look under the QOS section.
you can enable traffic control and set the 6000 series IP to 100mb under the "Bandwidth Limiter" section.

It worked for me.

73's
Bret
WX7Y
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
Well that would not be true for me as I'm using enterprise grade managed switches (I do systems and networking for high traffic websites and streaming video/audio as my day job). 

I don't think the problem is the network. SmartSDR for Windows works just fine. It's just iOS and I am thinking the Apple SoCs just can't keep up just yet.

Thanks for all of the responses everyone. 
(Edited)
Photo of Bob - W7KWS -

Bob - W7KWS -

  • 263 Posts
  • 36 Reply Likes
The switch that seems to have solved my issue between the Maestro and the 6300 is a D-Link DES-1105 100Mb unit.

So far it has been six days since I switched the Maestro and 6300 from a Netgear GS108-TV1 gigabit switch to the D-Link.  Since then the Maestro and 6300 have been up 100% and powered on 24/7 with five green bars every time I look at it.

When I first got my Maestro last May, I was using a TRENDnet TEG-S80g gigabit switch.  It seems that use of these two different gigabit switches combined with the 6300, Maestro and a couple of other computers, was coincident with my problems.

Now, the D-Link has only three connections.  The Maestro the 6300 and one cable to the Netgear for WiFi and Internet access.  I'll try the WiFi soon and maybe later my VPN to see if they work as they should.

I've got my fingers crossed but so far, so good.

By the way, DAX from the 6300 to my PC may have been a big contributor to traffic through the switches.  For now I've turned DAX off.

73
(Edited)
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 141 Posts
  • 40 Reply Likes
Maybe a funny coincidence that might help:

Until today, I have not had any choppy audio dropouts but today I did. It then turned out that my iPhone accidentally connected to an Apple Airport Extreme AP which I setup for testing and forgot to remove the connection from my device. Normally, these WiFi APs are not too bad. I was using it for other purposes few times but I am normally using manageable professional WIFi APs. While having these issues, the Apple router was very close to my iPhone, connected via 1GBit and using 5GHz.

Once I switched back to my original WiFi router, which is a Ubiquity UAP-AC-PRO router (also connected to a NetGear ProSafe GB Switch - like the Airport Extreme Router) all went back to normal. No dropouts, all smooth. After finding out this, I tried the same with some of my other devices iPad Air 2, iPad Pro, iPhone 7 plus, iPhone 6 plus and even iPhone 5s. All the same, when working with the Apple AP, it gets choppy and I experienced audio dropouts. Not all the time, sometimes I had to wait quite some time. Once I switched back to the Ubiquity AP, all went well.

I can't see any issue on the Netgear Router when connecting via the Apple AP so it seems to be an issue with the Airport Router.

By the way, Ria, you asked to include some network traffic measurements to the App, maybe similar to the Windows Version. That's already implemented but I removed it for two reasons: 1.) When testing the App and especially during development time, I did use and test the App in poor network situations (e.g. high latency, poor bandwidth) and I found that measurement didn't really help much. But moreover 2.) these routines slowed down the App quite a bit as I had to add them in code sections where I was highly optimizing the code and everything I tried really slowed down the code. Not on an iPad Pro but on slower devices so I decided to remove that code again.

vy 73,
Marcus, DL8MRE
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
Hi Marcus,

I missed this but I haven't had choppiness on any of my devices lately. It's been running smooth, except when I switch tasks or running VPN remote with poor wifi or 4G/3G (which is probably expected).
Photo of Marcus - DL8MRE

Marcus - DL8MRE

  • 141 Posts
  • 40 Reply Likes
Hi Ria,

yes, that's also what I can confirm. I never have any choppiness except when I (accidentally) switch back to my Airport Routers - which seem to be very bad whenever I try them. I am using the aforementioned Ubiquity APs which I can really recommend. If somebody has issues with WiFi (e.g. not working roaming, connection dropouts, wrong bandwidth allocation) I can only recommend these APs. However, these APs are for business purposes and not for private home users as they require some expertise when setting them up and for fine-tuning.

Another suggestion to users who don't want to or can't switch their WiFi APs is, to try to switch to 5GHz if they are currently using 2.4GHz. This doesn't mean that the connection will be faster as 5GHz can even be slower for longer distances but often, the 5GHz band is not as occupied as the 2.4Ghz channels. It is at least worth a try.

Finally, the AP can be the bottleneck if there are many other devices connecting using one and the same AP. So if the signal is choppy in the App, I would to see if this changes, if such other devices (PCs, Laptops, Apple-TV etc.) are switched off.

73,
Marcus
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
We use the Unifi APs in a test lab I have at work so I can confirm they do work well.
Photo of Dennis Daniel KM6DF

Dennis Daniel KM6DF

  • 83 Posts
  • 6 Reply Likes
I am having the same issue with my asus router any suggestions
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2246 Posts
  • 872 Reply Likes
WAN or LAN?
Photo of Cal Spreitzer

Cal Spreitzer

  • 342 Posts
  • 60 Reply Likes

Hi Ria,

What version of iOS are you currently using?  Can you correlate any of your issues to any of the recent iOS releases?  I recently updated my iPAD Mini to 10.3 and noticed today there is a 10.3.1.  Mine was working perfectly for several weeks but I've also noticed some choppiness this past week. 

Cal/N3CAL

 


Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
I run 10.3.1. 

No choppiness here on wifi. Cellular has it but that is to be expected with 4G LTE in the middle of rockefeller center NYC. 
Photo of Dennis Daniel KM6DF

Dennis Daniel KM6DF

  • 83 Posts
  • 6 Reply Likes

I am using on a WAN and also have the latest update 10.3.1

Dennis

Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
If you are running it on WAN it could be anything from your router to your upstream internet connection, to the client internet connection. The router is unlikely as I've set up ASUS routers for others without issue.

If your upload speed on your home internet is less than 3Mbps, you're going to have problems.

If the download speed on the internet you are using remotely is less than 3Mbps, ditto. 4G LTE and good 3G (HSPA+) will work. Anything less will not. Public wifi is a crap shoot. 

Latency is also a killer. Ping times in the hundreds of msec do not play nice. 

If your internet is fine, then you can look into maybe replacing the router and VPN with something better, maybe an IQ Router or similar. 
Photo of Rory - N6OIL

Rory - N6OIL

  • 252 Posts
  • 46 Reply Likes
Also another to check is how many apps are still running in the background and do that double press your home button, you should it open up like a deck of cards then start by swiping them up to quit the program one by one. Then what I do is hold down the power and home button at the same time and do a reset.
Photo of Andy M5ZAP

Andy M5ZAP

  • 161 Posts
  • 35 Reply Likes
I beleive one of the main culprits for choppy audio on SSDR iOS is the device scanning the wifi channels. If you leave SSDR running in the background and open "settings ,wifi" each time you see the iOS scan for wifi networks it makes the audio choppy. I beleive it does this scan in the background periodically and as SSDR only uses a small buffer for latency issues it causes audio dropout. I also intend to test my iPad with wired Ethernet using the iPad camera adapter and a USB to Ethernet adapter and check all is clear.
(Edited)
Photo of Dennis Daniel KM6DF

Dennis Daniel KM6DF

  • 83 Posts
  • 6 Reply Likes
I thought I would give some more info. I have just bought the newest ipad with the a9 chip the ios is 10.3.1 at the base station we are using 1.10.16 smartsdr and it has a cat 6 to a ASUS RT-AC68 router. the modem is a xfinity running at 241mb download and 13mb upload 15 pings at the remote site it also has a xfinity modem but running as a router also and it is running at 30mb down load and 6 upload with 23 pings. The smartsdr ios is 1.2.8. The audio is choppy no matter what I do.
thanks
Dennis   
Photo of David Decoons wo2x

David Decoons wo2x, Elmer

  • 1084 Posts
  • 220 Reply Likes
Check with Xfinity and see if they can swap for a modem instead of a modem/router. Or if they can set it to bridge mode instead of router mode.
Photo of Tony Taddeo

Tony Taddeo

  • 60 Posts
  • 28 Reply Likes
Another possible case of choppy audio occurs when using a Bluetooth headset due to cross interference of Bluetooth and your 2.4ghz wifi network. Some access points and Bluetooth heads handle this better than others. In this case setup a 5ghz wlan and connect to this. Most access points will allow you to have different wlan names for both 2.4ghz and 5ghz wireless networks.
Photo of Ria - N2RJ

Ria - N2RJ, Elmer

  • 2252 Posts
  • 874 Reply Likes
That's an important point. To solve this if your router/AP has a band steering feature, use it.
Photo of Joe, KQ1Q

Joe, KQ1Q

  • 79 Posts
  • 19 Reply Likes
I have the same choppy waterfall and choppy audio problem on SmartSDR for iOS, ver 2.3.0:0.53, iOS 11.2.6, 9.7-inch iPad Pro. 
Radio: 6400M, firmware: v2.1.33.106
Router: Asus RT-AC87R, firmware: 3.0.0.4.382_50010

The 6400M is plugged directly into the RT-AC87R router.

If using 5 Ghz, SmartSDR for iOS is choppy, whether the router is set to auto or 802.11n compatibility, and whether channel width is 20, 40 or 80 Mhz. Lowering the display fps rate helps some but doesn't solve it.

If using 2.4Ghz it is smoother but not totally smooth. Whether the router is set to auto or 802.11n mode and channel width makes no difference.

This is a LAN issue so ISP should make no difference, but ISP is Comcast. The iPad Pro running a network test achieves 350 mbps down, 30 mbps up, ping= 10 ms, jitter = 1.4 ms

This seems similar to the issue discussed in this thread: https://community.flexradio.com/flexradio/topics/smartsdr-for-ios-cutting-in-and-out
Photo of Andy - KU7T

Andy - KU7T

  • 107 Posts
  • 7 Reply Likes
I have gotten less choppiness when putting laptop (client running SmartSDR) into High Performance mode. Default is Balanced and Power saver is a non starter. Funny thing is, High Performance is hidden in Windows 10. I can post the command later if people are interested (I am not on that device right now).

Andy
KU7T