Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How do I determine what is causing SmartSDR to run "choppy?"

RiaRia Member ✭✭
edited June 11 in SmartSDR for iOS
Sometimes SmartSDR for iOS seems sluggish. It's usable but it's not as "flowing" as the desktop version, and sometimes there are audio dropouts. I have seen this on local LAN with a new iPad Pro and iPhone 7+ and also via VPN. Same VPN connection runs dpSDR and SmartSDR for Windows without issues. 

I am wondering if there is any diagnostic that SmartSDR for iOS has to determine what the problem is? 

I should also say that sometimes it runs absolutely perfect. So this is baffling.

My local network connectivity is 802.11ac into a netgear managed gigabit switch and I'm pretty sure it's not the wifi as nothing else gives problems. 
«1

Comments

  • Rick - W5FCXRick - W5FCX Member
    edited November 2019
    I'm running purely remote and sometimes see the same thing over VPN. I have found it's usually network latency in excess of 50 milliseconds combined with FPS and/ spectrum update rate set too high. Try: 1) clicking on network icon and watch latency and packet error rates to identify issues there 2) reducing slice FPS to 3 and spectrum refresh to around 50. I have this config saved as Remote Operation and use it when operating remote over VPN from PC, iOS and Maestro. Solved my issues. Rick
  • RiaRia Member ✭✭
    edited October 2016
    I doubt that it's latency. My latency is at worst 10-15ms, most times 2-3ms.  The connection I am on (at work) is a gigabit fiber connection from Level3 that I almost have entirely to myself.  It also doesn't explain the local issues. 
  • Rick - W5FCXRick - W5FCX Member
    edited December 2016
    Yeah that's odd. Did you try reducing the FPS and waterfall update rates to see what difference that makes?
  • Larry _ W8LLLLarry _ W8LLL Member ✭✭
    edited December 2016

    I was having the same problem, check out this post for info on how I solved it on my end.

    https://community.flexradio.com/flexradio/topics/smartsdr-for-ios-cutting-in-and-out

  • Rob FisselRob Fissel Member
    edited October 2016
    Ria, considering you've told me the basics of your home network, and you're experiencing this while on your home LAN in addition to VPN WAN, something is amiss here.

    I can't say I've ever had an issue while on the home WLAN with buffering/stuttering issues on my iOS devices. I've deployed several access points on 5GHz throughout the house to resolve any dead spot issues. All of my local SmartSDR activity that takes place outside of wired connections occurs on 5 GHz channels. I have had issues in the past on 2.4 GHz with SSDR on my MacBook Air while in different parts of the house, but a full blown separate 5 GHz network resolved those issues. I've never attempted to connect the iOS devices to the 2.4 GHz network for SSDR actives, but can try. 

    I also had some minor issues on the 5 GHz network. Forcing the AP's to **** to a 20 MHz channel solved this. I think that an issue may have been the device and or AP trying to switch between 20/40/60 MHz channels, but I have no empirical data to back this up. 

    Even living in a rural area, and not having to compete with every 2.4 GHz router in the neighborhood, the 2.4 spectrum is still competing with Bluetooth devices, your microwave, etc. 
  • Bob - W7KWS -Bob - W7KWS - Member ✭✭
    edited June 6
    I've had a problem with my Maestro talking to my 6300 for as long as I've owned it.  I called Dudley at Flex a few weeks ago and he asked about my network arrangement between the two units. 

    The only device intermediate of the two was a gigabit switch.  Dudley advised that I replace it with a 100Mb switch.  His explanation was that the 6300, when connected to the gigabit unit, auto detects the faster device and can produce so much data that, on occasion, it can overwhelm the switch creating a log jam and therefore latency. 

    Of course given such a switch's location, this could occur no matter what the rest of the network looks like, WAN, LAN or VPN.  He said that when connected to the slower switch, the 6300 auto detects this and cuts back on data quantity.

    This advice seems counter intuitive to me but I followed his suggestion yesterday and put in the slower switch.  So far I've had five green bars on the Maestro ever since.

    Dudley also had some suggestions for gigabit switch models that would do better than mine but I lost track of them as I had a slower unit on the shelf.  Maybe he can chime in here with that information.

    73
  • Rob G6EIHRob G6EIH Member
    edited December 2016
    I was having some problems with network quality on a remote Maestro connected via VPN, two green bars down to zero with choppy audio. Everything at the shack end was connected to a gigabit switch as I was chasing the need for speed. Both ends of the link are the same 20mb up and 80mb down which should have been good enough.

     Saw the reply from Bob and when I got home yesterday removed the gigabit switch and put an old Netgear 100mb switch back in place, guess what, my office remote Maestro now has five green bars the choppy audio has gone and very low dropouts 0.01% after 4 hours.  I guess it was a case of network overload with the 6k connected to a gigabit switch.

     An added bonus is that my home Maestro Wi-Fi network quality has also improved.


    Thanks for sharing Bob

  • Jon_KF2EJon_KF2E Member ✭✭
    edited October 2016
    This makes me wonder if the drivers in the Flex couldn't need a driver upgrade. The common thread with all of these network problems is the NIC in the Flex. Since it is a basically a Linux computer maybe it needs better drivers?

    Jon...kf2e
  • Rob G6EIHRob G6EIH Member
    edited December 2016
    You could be right.
  • EA4GLIEA4GLI Salvador Member ✭✭
    edited November 2016
    I really do not want to downgrade my LAN to 100Mbit just to accommodate one device. I really hope they find a solution for this issue. I also agree that it has to be an issue with the nic on the Maestro. 
    The Maestro is a Dell tablet, which originally doesn't come with Ethernet, so I am sure that NIC is an addition. Knowing the make and model and driver of that device could shed light into networking problems.

    In my case, a physical reconnect of the network cable while the Maestro was ON solved dropouts..... weird.


  • Ted_Spiegel_NX6CTed_Spiegel_NX6C Member ✭✭
    edited December 2016
    I found that power cycling the LAN switch between the radio and the Maestro, an AirLink 10/100/1000 LAN switch, cures stuttering and occasional lost connections between the Maestro and the radio.
    Ted
    NX6C
  • Bob - W7KWS -Bob - W7KWS - Member ✭✭
    edited December 2016
    Beware! With my netgear gigabit switch, after a reset, the problem returned in a day or two.
  • Bob - W7KWS -Bob - W7KWS - Member ✭✭
    edited December 2016
    By the way, there is apparently no need to downgrade your entire LAN. Just put the slower switch between your 6xxx & the rest of the network. According to Duddly, the 6xxx will auto detect the slower connection & act accordingly.
  • Ted_Spiegel_NX6CTed_Spiegel_NX6C Member ✭✭
    edited December 2016
    Bob -W7KWS,
      Thanks for the info.  I've pulled a 10/100 speed LAN switch out of the 'inventory' and placed it between the 6700 and Maestro.   Maybe this will cure the (very) occasional Maestro dropping the connection.  
    Ted
    NX6C
  • Rob G6EIHRob G6EIH Member
    edited December 2016
    Ted, that was what I did here as no point in downgrading everything else that's working good.
  • Burch - K4QXXBurch - K4QXX Member
    edited October 2016
    Is there a particular model switch that people are using? 
  • Bob - W7KWS -Bob - W7KWS - Member ✭✭
    edited December 2016
    I'll update how things are going here in the next few days. Please do the same. My Maestro & 6300 have been & will remain powerd on 24/7.

    I'll also detail the switch models I've tried after my week long testing is complete.
  • W4KCNW4KCN Member
    edited October 2016
    I have wrote some software that utilizes the FlexLib API and allows radio control via the web.  I have ran into issue where my router (ASUS N66U) is too taxed(?) and requires a reboot to clear the issues.  Basically, the traffic just comes to a crawl and updates from the API are severely degraded.
  • WX7YWX7Y Member ✭✭
    edited October 2016
    I think on the N66U there is an option called "traffic manager" like my AC-66u does, look under the QOS section.
    you can enable traffic control and set the 6000 series IP to 100mb under the "Bandwidth Limiter" section.

    It worked for me.

    73's
    Bret
    WX7Y

  • RiaRia Member ✭✭
    edited October 2016
    Lowering fps seems to help some. I am thinking that even the latest hardware cannot keep up with the CPU demands of the app.

  • RiaRia Member ✭✭
    edited October 2016
    Well that would not be true for me as I'm using enterprise grade managed switches (I do systems and networking for high traffic websites and streaming video/audio as my day job). 

    I don't think the problem is the network. SmartSDR for Windows works just fine. It's just iOS and I am thinking the Apple SoCs just can't keep up just yet.

    Thanks for all of the responses everyone. 
  • Larry _ W8LLLLarry _ W8LLL Member ✭✭
    edited December 2016
    Try my suggestion in the link, it has worked for me and others for the ssdr ios studdering issue. Regular ssdr local and remote was never an issue, it was just the ios studdering. It seems to be either an incompatibility between ssdr ios and the 802.11ac standard on some routers or possibly the mixed frequencys, 20 mhz seems to work well. My older 802.11n router does not have an issue playing nice with ssdr ios.
  • Bob - W7KWS -Bob - W7KWS - Member ✭✭
    edited December 2016
    The switch that seems to have solved my issue between the Maestro and the 6300 is a D-Link DES-1105 100Mb unit.

    So far it has been six days since I switched the Maestro and 6300 from a Netgear GS108-TV1 gigabit switch to the D-Link.  Since then the Maestro and 6300 have been up 100% and powered on 24/7 with five green bars every time I look at it.

    When I first got my Maestro last May, I was using a TRENDnet TEG-S80g gigabit switch.  It seems that use of these two different gigabit switches combined with the 6300, Maestro and a couple of other computers, was coincident with my problems.

    Now, the D-Link has only three connections.  The Maestro the 6300 and one cable to the Netgear for WiFi and Internet access.  I'll try the WiFi soon and maybe later my VPN to see if they work as they should.

    I've got my fingers crossed but so far, so good.

    By the way, DAX from the 6300 to my PC may have been a big contributor to traffic through the switches.  For now I've turned DAX off.

    73
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2019
    Maybe a funny coincidence that might help:

    Until today, I have not had any choppy audio dropouts but today I did. It then turned out that my iPhone accidentally connected to an Apple Airport Extreme AP which I setup for testing and forgot to remove the connection from my device. Normally, these WiFi APs are not too bad. I was using it for other purposes few times but I am normally using manageable professional WIFi APs. While having these issues, the Apple router was very close to my iPhone, connected via 1GBit and using 5GHz.

    Once I switched back to my original WiFi router, which is a Ubiquity UAP-AC-PRO router (also connected to a NetGear ProSafe GB Switch - like the Airport Extreme Router) all went back to normal. No dropouts, all smooth. After finding out this, I tried the same with some of my other devices iPad Air 2, iPad Pro, iPhone 7 plus, iPhone 6 plus and even iPhone 5s. All the same, when working with the Apple AP, it gets choppy and I experienced audio dropouts. Not all the time, sometimes I had to wait quite some time. Once I switched back to the Ubiquity AP, all went well.

    I can't see any issue on the Netgear Router when connecting via the Apple AP so it seems to be an issue with the Airport Router.

    By the way, Ria, you asked to include some network traffic measurements to the App, maybe similar to the Windows Version. That's already implemented but I removed it for two reasons: 1.) When testing the App and especially during development time, I did use and test the App in poor network situations (e.g. high latency, poor bandwidth) and I found that measurement didn't really help much. But moreover 2.) these routines slowed down the App quite a bit as I had to add them in code sections where I was highly optimizing the code and everything I tried really slowed down the code. Not on an iPad Pro but on slower devices so I decided to remove that code again.

    vy 73,
    Marcus, DL8MRE



  • edited November 2019
    I am having the same issue with my asus router any suggestions
  • RiaRia Member ✭✭
    edited April 2017
    Hi Marcus, I missed this but I haven't had choppiness on any of my devices lately. It's been running smooth, except when I switch tasks or running VPN remote with poor wifi or 4G/3G (which is probably expected).
  • RiaRia Member ✭✭
    edited April 2017
    WAN or LAN?
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited April 2017
    Hi Ria,

    yes, that's also what I can confirm. I never have any choppiness except when I (accidentally) switch back to my Airport Routers - which seem to be very bad whenever I try them. I am using the aforementioned Ubiquity APs which I can really recommend. If somebody has issues with WiFi (e.g. not working roaming, connection dropouts, wrong bandwidth allocation) I can only recommend these APs. However, these APs are for business purposes and not for private home users as they require some expertise when setting them up and for fine-tuning.

    Another suggestion to users who don't want to or can't switch their WiFi APs is, to try to switch to 5GHz if they are currently using 2.4GHz. This doesn't mean that the connection will be faster as 5GHz can even be slower for longer distances but often, the 5GHz band is not as occupied as the 2.4Ghz channels. It is at least worth a try.

    Finally, the AP can be the bottleneck if there are many other devices connecting using one and the same AP. So if the signal is choppy in the App, I would to see if this changes, if such other devices (PCs, Laptops, Apple-TV etc.) are switched off.

    73,
    Marcus



  • RiaRia Member ✭✭
    edited April 2017
    We use the Unifi APs in a test lab I have at work so I can confirm they do work well.
  • Cal  N3CALCal N3CAL Member ✭✭
    edited November 2019

    Hi Ria,

    What version of iOS are you currently using?  Can you correlate any of your issues to any of the recent iOS releases?  I recently updated my iPAD Mini to 10.3 and noticed today there is a 10.3.1.  Mine was working perfectly for several weeks but I've also noticed some choppiness this past week. 

    Cal/N3CAL

     


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.