Expert 2K-FA setup with DDUtil - autodrive problem

  • 1
  • Question
  • Updated 2 years ago
I am interfacing my Flex-6500 to an Expert 2K-FA. I am using DDUtil v3.2.3, SmartSDR 1.6.21, SDR-Bridge with CW Skimmer, and N1MM+ logger. I have much of it working but I'm having a few issues. I have the following COM ports set up: SmartSDR using COM4/14, USB interface with 2K-FA using COM 5 (for the Term_2K_USB control of amp from PC), a serial port to USB adapter between the amp and PC using COM6, N1MM+ using COM7, and a FlexControl using COM99. The amp follows the frequency and band changes ok and switches antennas as programmed. However, the problem is controlling the drive power. First of all, I set ACC TX to enabled in SmartSDR radio setup to activate the PTT. In DDUtil, I have configured AutoDrive for 12w on 40m for amplifier and 8w for barefoot. If I toggle the OPER button in DDUtil, the power level changes correctly in SmartSDR. The problem is that there is no link between the OPER button in DDUtil and the OPERATE button on the 2K-FA. It doesn't matter if I select Amp Follows DDU PTT or DDUtil Follows Amp PTT. When I set the 2K-FA to OPERATE, it overrides the power settings in DDUtil and sets the SmartSDR power to 20w for low output, 40w for mid output and 60w for high output. What am I doing wrong???
Photo of Les Brown

Les Brown

  • 19 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Tim - G7GFW / F4VQP

Tim - G7GFW / F4VQP

  • 110 Posts
  • 36 Reply Likes
I have a feeling that you can also set the drive levels on the SPE itself, could be that?

Tim
Photo of Les Brown

Les Brown

  • 19 Posts
  • 0 Reply Likes
Here is more detail on my DDUtil setup that I didn't mention. I am confused about some of the proper port settings. In the ports tab, I have selected COM6 for RCP1. This is the port between the PC and 2K-FA using the USB to serial adapter. I'm not clear on what port to set in the Amps tab for SPE and what it does. I tried to set up a port pair COM9/109 in SmartSDR CAT and use that, but it doesn't seem to do anything. A small SPE window appears with several buttons, but they don't do anything.
Photo of KY6LA - Howard

KY6LA - Howard, Elmer

  • 3467 Posts
  • 1328 Reply Likes
No. You set drive in DDUTIL
Photo of Sergey, R5AU

Sergey, R5AU

  • 802 Posts
  • 96 Reply Likes
Les, you should use DDUtil instead of Term_2K_USB:

all works fine

DDutil operate with Radio via Ethernet
However with AMP with RS232
Photo of Sergey, R5AU

Sergey, R5AU

  • 802 Posts
  • 96 Reply Likes
Just reply with correct pics with freq and more details, I have just other COM ports numbers in the system :


Photo of Les Brown

Les Brown

  • 19 Posts
  • 0 Reply Likes
Thanks guys for your input. I think I found my problem and it now works. I foolishly assumed that I had to set the CAT control in the 2K-FA to Flex Radio. I found the web page on the DDUtil site for configuring the 2K-FA. You have to set the CAT control to Kenwood! After following the rest of the port configuration settings, all works fine.

I really miss the ability to see the 2K-FA front panel display on the PC though. You can't use the term_2k_usb at the same time since the port is used by DDUtil. Maybe we'll see a better display built into DDUtil one day.