DAX woes with HRD

  • 1
  • Problem
  • Updated 4 years ago
I've gone a few rounds now with trying to get DAX to run on my Win7 machine.  Everything else on my 6300 seems to be going ok.  DAX is running, and when I go to the control panel I can see signal (red line) however, if I press on #1, I get an immediate error "An error has occured while trying to open a DAX driver.  Make sure no other applications are using RESERVED DAX devices... etc."  So, I have restarted, re-installed, etc.  I'm not sure what to do next.  I noticed that inside DM780 there are no DAX channels listed, so I'm definitely not close to running. Flex SW is the latest version.  it's Win7-64.. all up to date.  I also have an M-audio 1010 interface for my audio.  I'm not running any other VAC sw or anything like that.  Anybody got ideas?
Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Jim Gilliam

Jim Gilliam

  • 459 Posts
  • 71 Reply Likes

Try right clicking on the speaker icon in the lower right hand corner of your computer. Click on playback devices and see if the DAX channels are listed. If not, there might be a problem with your installation.


Jim, K6QE

Photo of Mack McCormick

Mack McCormick, Elmer

  • 316 Posts
  • 115 Reply Likes
I'm pretty certain disabling the audio interface for your M-Audio device in Device Manager will fix the issue. I have a similar problem with two MOTU 828 Mk 3's. It's the MOTU drivers. Let me know if that works for you.

Mack
W4AX
Alpha Tester
Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like
hmm. that would be pretty unacceptable to me, since that's my entire audio routing system for my PC.  However, I shall try it to see what happens.
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
Most of these recurring problems reside inside the registry. I recommend to set up a new OS on a clean new harddisk and keep the old one as a backup. If that doesn't work, take another pc or notebook. Sometimes it can also be a hardware problem. My working systems run on lenovo pc's and panasonic toughbooks.

Alex, DH2ID
Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like
This is a new OS and clean setup already.  thanks.
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 189 Posts
  • 23 Reply Likes
Are you sure you are using the right DAX channels?  There are several.  Some may be in use/reserved by Flex.  Also, if you have some other software (e.g. MTTY under N1MM or something) there really could be someone else who "owns" the channel, though usually you can have more than one program listening to the receive audio.

But, the easiest thing to get wrong is the DAX channel.
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1752 Posts
  • 534 Reply Likes
Make sure, inside of DM780, you use:

Input ...: DAX Audio RX 1           
              DAX RX Audio

Output ..: DAX Audio TX 1
                DAX TX Audio

(Edited)
Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like
thanks, but I have no DAX to select yet.. it does not exist in the list of sound devices.  First DAX needs to be properly registered and seen by the PC, which it is not.  
Photo of Larry Loen  WO7R

Larry Loen WO7R

  • 189 Posts
  • 23 Reply Likes
Then something went wrong with your installation.  I would uninstall and then make sure everything installs this time.  I think there's an option you can accidentally set to put in less than everything.  Anyway, at this point, that's what I would try.
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1752 Posts
  • 534 Reply Likes
Mine installed without a problem on a Win7 64bit machine. I used this installer:
http://www.flexradio.com/downloads/smartsdr_v1-3-8-126_installer-exe/
Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like
Thank you to all who have commented and attempted to help me.  This community is fantastic.  So, here's an update:
I uninstalled 1.3.8 again, and this time I also uninstalled my M-Audio drivers.  I then re-installed 1.3.8, and DAX came up correctly and is now passing signal to DM780.  I have since re-installed the M-audio drivers, and everything seems to be co-existing just fine.
However, it is now smartCAT that will not connect to the DM780 radio panel.  I have confirmed that CAT is talking to the HRD rig control program as it changes frequency and mode and will key up.  I have even configured a separate PTT port on DM780 to key transmit faster , and that works.  
However, I get an error message and a locked up DM780 when I try to connect to the HRD IP server address.  This address is supposed to be the same as the PC. I've double-checked the address inside the IP server tab. I have also tried "local host", with no luck.  It just locks up or rejects the connection.  I have turned off Windows firewall, and I have gone into my router and specifically port forwarded port 7809.  I'm not sure what to try next.  
As always, I am grateful for any suggestions from those successfully using the latest HRD sw with the latest flex sw.
73,
Doug
Photo of Alex - DH2ID

Alex - DH2ID, Elmer

  • 891 Posts
  • 166 Reply Likes
Good idea, Sal, something I have forgotten... ;-)
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1752 Posts
  • 534 Reply Likes
I love DDUtils, it controls my rotor, amp and radios. It even sends band data into the amp for auto band switches. Great piece of software.

http://k5fr.com/ddutilwiki/index.php?title=Main_Page
Amazing job by Steve K5FR
Photo of Lee

Lee

  • 84 Posts
  • 19 Reply Likes

How would DDUTILS 3 work to control a Ameritron 1306 ??

Thanks,

Lee

Photo of AA1UI

AA1UI

  • 15 Posts
  • 1 Reply Like
Thanks Alex, I gave up on HRD rig control, installed the latest minideluxe, and all is right with the world once again!  DM780 is working!  Thanks again!
Photo of EA4GLI - 8P9EH - Salvador

EA4GLI - 8P9EH - Salvador

  • 1752 Posts
  • 534 Reply Likes
Btw, I can have DDUtil install in one PC and control the Flex with another computer in the same LAN and all the functions will work. No need to install DDUtil on the second PC.