DAX RX issue on Ver. 2.5 and up!

  • 3
  • Question
  • Updated 2 weeks ago
I believe this happens with SSDR Ver. 2.5 and up. Some folks may not realize that it is happening so I’ll describe the symptoms. When changing profiles watch your DAX. Say you are running WSJT(although it happens in CW, and SSB as well) notice your RX indicator in the lower left hand corner of the WSJT-X program. On a dead band you’ll have this set around 30dB or so. Now change bands or even reload the profile for the dead band while keeping an eye on that indicator. Sooner or later you’ll see it at 50 or 60dB. DAX RX is out of whack. You’ll also know this is happening when you open the DAX window and see the red indicator cranking to around 3/4 of full scale.
 
The only fix I have found is turning DAX off and then back on for the appropriate slice or by changing the numeric value of the DAX slider. Doing so settles it back down. I have to do this on nearly every band change.
 
Has anyone found a fix for this? Maybe a better workaround then what I mentioned above or running a wire to the PC and not loading DAX? Thank goodness this does not happen on DAX TX as there would be a whole lot of overdriven Flex radios out there.
 
Three months ago Eric at Flex stated “We are aware of this issue (DAX RX Gain sometimes not syncing) and have it in our system as #7578.”
https://community.flexradio.com/flexradio/topics/v2-4-9-update-2-5-1-issue-with-audio-in-jtdx-wsjt-x?utm_source=notification&utm_medium=email&utm_campaign=new_reply&utm_content=topic_link
 
I thought the DAX issues were fixed so yesterday I upgraded from 2.4.9 to 3.1.7. This DAX issue is NOT fixed and is a real pain to deal with!!!

Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes

Posted 3 months ago

  • 3
Photo of Michael Walker

Michael Walker, Employee

  • 1112 Posts
  • 328 Reply Likes
John

Do you see this on 2.6 as well?  May DAX changes happened in 2.6 that was released this week.  I don't see it on 2.6 or 3.1.7 (but I have to admit, I have not seen the problem you are having).

Mike 
(Edited)
Photo of AH0U

AH0U

  • 354 Posts
  • 52 Reply Likes
I have the same problem on my 6700 running 2.6..... thought it was just me
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
Good question and I do not know. I did see it on 2.5 and hated it so much that I went back to 2.4.9. I never tried 2.6 as I purchased 3.1.7 yesterday.

Edit to add:
Windows 7pro
Flex 6700
(Edited)
Photo of Michael Walker

Michael Walker, Employee

  • 1112 Posts
  • 328 Reply Likes
What you can do is install 2.6 or 3.1.  That will update DAX to the latest build.

If you don't like 2.5, you can then go back and run 2.4 (do not uninstall the previous versions - no need to do so regardless what others say).

Now, when you run 2.4, it will  use the latest version of DAX.  Give that a try.

Thanks for supporting the team and purchasing 3.  

73, Mike va3mw
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
Thanks Michael and I am a little confused by your solution. SSDR ver. 2.4.9 works great with the older version of DAX. Yesterday I paid for version 3 of SSDR which has the latest version of DAX which is causing a problem. A known problem according to Eric at Flex.

I thank you for the reply but if I understand correctly, you're stating that I should go back to version 2.4.9 of SSDR but keep the newer ver. of DAX found in 2.5 and above which has this known problem? Heck, if I must go back to ver. 2.4.9 does that mean I can return ver. 3 to Flex for a refund? I do not want to go there. I simply started this thread in the hopes that someone smarter than me has found a better work around for this KNOWN problem besides what I mentioned above.

Right now nearly every time I change bands/profiles I must bring up DAX and fix it as well.
Photo of Ed Stallman

Ed Stallman

  • 58 Posts
  • 6 Reply Likes
John, if you are using the 64 bit of WSJT-X , try the 32 bit 

Ed
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
Thanks Ed. I used the WSJT-X reference above because many folks were using that software. The problem is much less apparent if I use wsjt to change bands rather than the profiles in SSDR. But doing so defeats the purpose of profiles.

Even if wsjt is not running, I see the same problem.
Photo of John - AI4FR

John - AI4FR

  • 276 Posts
  • 80 Reply Likes
Maybe this will help.

Normal DAX on a dead band with 2 slices open.


Picture below shows DAX out of whack.



I took the bottom screen shot first then change the numeric value for each DAX RX gain by one for the top picture. I normally have them on 24. So I dropped it to 23 which fixed the problem. Change bands, and I move the RX gain back to 24 to fix the problem again upon a band change. Often the same fix can be accomplished by turning them off and then back on again.
Photo of Gary NC3Z

Gary NC3Z

  • 151 Posts
  • 34 Reply Likes
I am having this same issue with 3.1.7 and put a HD ticket in the other day and supposedly it's in Eric's queue to look at. I had been doing a bunch of diagnostics with Tim. Good to see that it's not just me, I started to feel like that.

Essentially I run about 25 on my DAX sliders and when I startup SSDR again the sliders still say 25 but the output acts like it's at 50. It's not difficult to recover but I feel like we are going backwards with DAX issues.
Photo of Gary NC3Z

Gary NC3Z

  • 151 Posts
  • 34 Reply Likes
Oh, and thanks for the old link where Eric admits it's an issue, I updated my HD ticket with this info. Wish Tim had told me this was an outstanding DAX issue and I was not loosing my mind.
Photo of Paul - K6HR

Paul - K6HR

  • 126 Posts
  • 22 Reply Likes
I have the same problem here. Whether running 2.5 , 2.6 or 3.0 under W10 64.

The DAX RX levels increase by themselves and require readjustment, and if the radio has been running for 3 days the DAX TX Audio becomes distorted and requires a restart.

Also, some of my DAX RX channels are missing in both of my SSDR installations. Both my 6700 and 6500 SSDR are missing some DAX RX channels. They are installed on separate W10 64 PC's. I followed the "manual installation" for DAX and I'm still missing some RX channels.

I've learned to live with it, and was hoping an upgrade to v3 would fix it.

Photo of Gary NC3Z

Gary NC3Z

  • 151 Posts
  • 34 Reply Likes
With 3.1.7 I did a complete and total uninstall per the process and it still persists.

Photo of KF4HR

KF4HR

  • 862 Posts
  • 281 Reply Likes
I recently upgraded from an older Windows 7 PC to an updated Windows 10 PC and have noticed something similar when running FLDigi (with SSDR 3.1.8).  Upon activating the FLDigi program its waterfall is not bright enough to see.  Then when I open the DAX Window and make any adjustment to the Slice A RX Gain Slider, the FLDigi Waterfall appears and works fine.  It's almost like I have to wake the DAX feature up!  Unfortunately I have to go through this sequence every time I start FLDigi.  I never had this happen with my older PC. 
(Edited)