6400 PWR-SPKR Jack

  • 1
  • Question
  • Updated 7 months ago
I'm using the PWR-SPKR jack on the back of the 6400 to go into my mixer. What I've noticed with multiple 3.5mm stereo cables (TRS) is that when the plug is pushed all the way into the jack there is no audio. I have to pull the plug out just a bit to get the audio out of the jack. Seems like the contacts for the jack are not aligned properly. Has anyone else noticed this or is it just me?
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 61 Posts
  • 10 Reply Likes

Posted 7 months ago

  • 1
Photo of Ernest - W4EG

Ernest - W4EG

  • 203 Posts
  • 38 Reply Likes
Check your stereo plugs. I bought several from Asia and I was having the same results. The quality control on their manufacturing left  a lot to be desire.
I have not had any further issues after buying from reputable State side companies.
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 59 Posts
  • 10 Reply Likes
No... when I say a little I'm talking around 2mm... all my plugs are the same length. Maybe the jack is made in Asia and needs it's tolerances checked.

What have I bought? Can't use NB or WNB and the audio jack is... well... jacked up. How many other things am I going to find?
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
In my experience, the "cheaper" Asian?? 3.5mm plugs are physically skinnier than 3.5mm. I avoid buying clones and counterfeits, A connectors job is basically to Connect. Out of spec imitations, might save you a few pennies, while providing extra trouble. If you are careful, you can get what you paying for. If your careless, it's a crapshoot.

73 - NO5J
(Edited)
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 59 Posts
  • 10 Reply Likes
It's not the diameter of the plug, it's the length, when the plug is seated into the jack, no audio, pull the plug out about 2-2.5mm and you have audio. All my plugs are the same length just like the ones that came with my Elecrafts and Heil adapters.
Photo of Jay / NO5J

Jay / NO5J

  • 1572 Posts
  • 227 Reply Likes
Ok, it could be an out of spec jack socket too. If you haven't yet ...

https://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Support

You have the same Satisfaction rights as everyone else does. 

73 - NO5J
Photo of Scott Russell - N1SER

Scott Russell - N1SER

  • 61 Posts
  • 10 Reply Likes
Helpdesk ticket opened. Thanks!