4G Router and Smartlink - So near yet so far.

  • 1
  • Problem
  • Updated 5 days ago
  • (Edited)
Hi,
Have tried a 4G router before but due to UK providers using CGNAT and not having a IP address was unsuccessful.

I now have a Three 4G router (Huawei B535) and it definitely doesn't use CGNAT and has an WAN IP address visible the same as shown in the router.

I cannot however get the router to allow UPnP or manual port forwarding, the SmartLink test fails. The router has facility for both UPnP and Manual port forwarding and I have tried configuring these.

If using smartlink the radio is visible with the correct IP but the device (iPhone using smartlink or PC running SmartSDR) will not connect.

Smartlink runs fine on my ADSL BT connection.

Now hears the mad thing....If I connect the flex to the 4G network and a PC to the BT router (so a completely different network) it connects over Smartlink. Even though the Smartlink still fails its tests. No other devices will connect though !!??

Any help would be greatly appreciated as I seem so close to getting the 4G network working. 
Photo of Andy M5ZAP

Andy M5ZAP

  • 201 Posts
  • 40 Reply Likes

Posted 7 days ago

  • 1
Photo of Steve K9ZW

Steve K9ZW, Elmer

  • 1600 Posts
  • 783 Reply Likes
Wife uses "Three" as her UK cellphone provider, and they are reasonably good at troubleshooting the stuff we broke.

My understanding is CGNAT is "port forwarding unfriendly."  Read that some relief was there with PCP (Port Control) but as my hands on testing is limited to my UK time on the ground when I'm not otherwise busy I never dug very deep into making it work.  

For us mere mortals, the CGNAT scheme is explained at:  https://en.wikipedia.org/wiki/Carrier-grade_NAT

And the PCP part at:  https://en.wikipedia.org/wiki/Port_Control_Protocol

(I fall into the aware but no-mastery category on this sort of stuff.  Usually my study ends when I get things working and problems solved. Kudos to Andy for having a good go at making the new 4G routers work!)

73

Steve
K9ZW

Blog:  http://k9zw.wordpress.com  


Photo of Lasse Moell

Lasse Moell

  • 149 Posts
  • 28 Reply Likes
Andy,
I have played a bit with 4G using Telenor as provider... And yes using standard settings for APN it was CGNAT, making life hard. But searching the net, I found that sometime the provider do have several different APN, and one that I tried did have public IP, but as most 4G nets, most ports are closed. But with a public IP it is possible to use VPN to contact the LAN. A bit messy but still do-able. This is a research for my summer house, and I just got an offer for installing fiber to the house, as neighbours do have it, only £4000.... Ouch!
Photo of Andy M5ZAP

Andy M5ZAP

  • 201 Posts
  • 40 Reply Likes
Hi Lasse.
My provider is Three and their APN for the 4g home internet does not use CGNAT so I do have a public ip. (Three is the only non specialist UK 4g provider that doesn’t use cgnat. Their mobile phone data APN uses cgnat) My problem is I can’t open the ports either with UPnP or manually. I’ll give a VPN a go and let you know how I get on.

Thanks

Andy M5ZAP
Photo of Lasse Moell

Lasse Moell

  • 149 Posts
  • 28 Reply Likes
Andy,
I have a small pi-clone configured as a SoftEther server,  and it works great! I did have the VPN server and a small 4G router (Teltonika RUT950) and conecting a client from my fiber wan, with no problem. So you should have no problems using 4G. Normally I do the other way round, have the server on my fiber WAN,  just to get acess to my home LAN.