Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

4G Router and Smartlink - So near yet so far.

Have tried a 4G router before but due to UK providers using CGNAT and not having a IP address was unsuccessful.

I now have a Three 4G router (Huawei B535) and it definitely doesn't use CGNAT and has an WAN IP address visible the same as shown in the router.

I cannot however get the router to allow UPnP or manual port forwarding, the SmartLink test fails. The router has facility for both UPnP and Manual port forwarding and I have tried configuring these.

If using smartlink the radio is visible with the correct IP but the device (iPhone using smartlink or PC running SmartSDR) will not connect.

Smartlink runs fine on my ADSL BT connection.

Now hears the mad thing....If I connect the flex to the 4G network and a PC to the BT router (so a completely different network) it connects over Smartlink. Even though the Smartlink still fails its tests. No other devices will connect though !!??

Any help would be greatly appreciated as I seem so close to getting the 4G network working. 


  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited December 2019
    Wife uses "Three" as her UK cellphone provider, and they are reasonably good at troubleshooting the stuff we broke.

    My understanding is CGNAT is "port forwarding unfriendly."  Read that some relief was there with **** (Port Control) but as my hands on testing is limited to my UK time on the ground when I'm not otherwise busy I never dug very deep into making it work.  

    For us mere mortals, the CGNAT scheme is explained at:  https://en.wikipedia.org/wiki/Carrier-grade_NAT

    And the **** part at:  https://en.wikipedia.org/wiki/Port_Control_Protocol

    (I fall into the aware but no-mastery category on this sort of stuff.  Usually my study ends when I get things working and problems solved. Kudos to Andy for having a good go at making the new 4G routers work!)



    Blog:  http://k9zw.wordpress.com  

  • Lasse MoellLasse Moell Member
    edited December 2019
    I have played a bit with 4G using Telenor as provider... And yes using standard settings for APN it was CGNAT, making life hard. But searching the net, I found that sometime the provider do have several different APN, and one that I tried did have public IP, but as most 4G nets, most ports are closed. But with a public IP it is possible to use VPN to contact the LAN. A bit messy but still do-able. This is a research for my summer house, and I just got an offer for installing fiber to the house, as neighbours do have it, only £4000.... Ouch!
  • Andy M5ZAPAndy M5ZAP Member
    edited February 11
    Hi Lasse. My provider is Three and their APN for the 4g home internet does not use CGNAT so I do have a public ip. (Three is the only non specialist UK 4g provider that doesn’t use cgnat. Their mobile phone data APN uses cgnat) My problem is I can’t open the ports either with UPnP or manually. I’ll give a VPN a go and let you know how I get on. Thanks Andy M5ZAP
  • Lasse MoellLasse Moell Member
    edited December 2019
    I have a small pi-clone configured as a SoftEther server,  and it works great! I did have the VPN server and a small 4G router (Teltonika RUT950) and conecting a client from my fiber wan, with no problem. So you should have no problems using 4G. Normally I do the other way round, have the server on my fiber WAN,  just to get acess to my home LAN.
  • Douglas MaxwellDouglas Maxwell Mr Member ✭✭
    edited March 13
    Hi Andy,
    I have now moved away from remote operation in the UK. I did have SKY ADSL which did work with SMARTLINK, but uplink was 0.2Mb/s at best. I switched to Three 4G using a HUAWEI B525 4g router and got 30Mb/s uplink using stacked LP yagis in the loft, but i can't get smartlink automatic or manual port forwarding to work (Virtual servers menu entry on the router). I do have eWeLink software on my iphone and use smart switches to successfully switch the PSU, flex and Maestro on remotely over 4g, its just smartlink that doesn't work.
  • Andy M5ZAPAndy M5ZAP Member
    edited March 15
    Hi Douglas The setting in the Huawei modem for port forwarding is a bit ambiguous. I don’t currently have access to the modem but I’ll let you know as soon as I can
  • Wilbur DoolittleWilbur Doolittle Member
    edited March 15
    1. Open your web browser (e.g. Internet Explorer, Firefox)
    2. In the address bar, type
    3. Press Enter.
    4. Enter your Modem username (the default is admin)
    5. Enter your Modem password (the default is admin)

  • Douglas MaxwellDouglas Maxwell Mr Member ✭✭

    Any update on this situation? Any port forwarding details for the Huawei B525 router would be appreciated.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.