1.6 & WSPR

  • 1
  • Question
  • Updated 2 years ago

Hi,

I upgraded to 1.6 and everything seemed to working until I went to use WSPR. Everything seems to function except no transmit, so I suspect it’s a PTT problem. Below are my settings. It seemed logical to me to use Com 5 for PTT. I guess I was wrong. Any suggestions?


Photo of KC0EM

KC0EM

  • 55 Posts
  • 7 Reply Likes

Posted 2 years ago

  • 1
Photo of Ed.G

Ed.G, Software Engineer

  • 86 Posts
  • 20 Reply Likes
Can you take screenshot of your DAX control panel? The TX Stream must be enabled (highlighted blue). 

Also, in SmartSDR is the DAX button selected in the mic selection panel? 
Photo of Rob Fissel

Rob Fissel

  • 270 Posts
  • 47 Reply Likes
Turn your PTT method to CAT instead of DTR and get rid of the PTT COM port. That is what is working for me...

I'd suggest also upgrading to WSJT-X 1.6 - which contains WSPR-2. No more switching between programs!
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3872 Posts
  • 1177 Reply Likes
Some questions to consider.  Disregard if you have already considered these...
I see that Ed has already addressed some of these...

1) Does your WSPR program have a CAT command method of PTT?  If so, you can have the program use that instead of a serial DTR method and save a COM port.  Why use two of them when one will suffice?

2) Do you have the DAX TX Channel button active in the DAX Control panel?

3) Do you have the DAX Button active on the Transmit panel (Next to the MIC controls)

4) If you are using the Serial PTT method on Com 5... when you defined the COM port, did you click the box that said use DTR to key it?

5) Is your COM5 port a leftover from your previous SSDR/CAT installation?  If so, you may need to delete the port, reboot the computer, check to make sure that it doesn't remain as a phantom/ghost  port, then redefine port 5 as a PTT/DTR port.

Good luck,

Ken - NM9P
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3872 Posts
  • 1177 Reply Likes
WOW...Fast group.  I see that two other guys typed faster than I did and beat me to the answers...but there weren't as wordy as I am!

Ken - NM9P
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3872 Posts
  • 1177 Reply Likes
I Just noticed...you have CAT port enabled in your WSPR program for COM 5 and your PTT port defined for COM 4.  But your SmartCAT ports are defined the other way...PTT is on COM 5 and CAT is COM 4....There's yer problem...

But I would use a single port for CAT and use CAT PTT anyway....
Photo of Rob Fissel

Rob Fissel

  • 270 Posts
  • 47 Reply Likes
What you meant to write, Ken, is that our answers weren't as complete as yours!

It also looks like he's using an old version of WSPR. WSJT-X 1.6 is really great - improved decoding performance, and folds in a lot of other modes into the same software - WSPR, FSK441, etc. 
(Edited)
Photo of KC0EM

KC0EM

  • 55 Posts
  • 7 Reply Likes
Starting at the top. DAX is selected. Below is the DAX control panel.
Photo of KC0EM

KC0EM

  • 55 Posts
  • 7 Reply Likes
Still no luck, but I am out of time and must get back to work. Tnxs to all. 73
Photo of KC0EM

KC0EM

  • 55 Posts
  • 7 Reply Likes

Hi,

I want to thank everyone for their help. When I tried WSPR this morning, it was working. I suspect one of your suggestions fixed the problem and all I needed to do was restart the computer.

At 75, I am not new to computers and wrote my first programs in what would be called machine language these days, and I think the last programming language I was really proficient in was FORTRAN. After leaving the EE community, I played with C++, but never became proficient in the language. I love this mixture of computing and amateur radio. It’s also great that there are always people here willing to rescue this “old timer.”

GD DX & 73