"Unable to connect to the radio. Please try again"

  • 1
  • Problem
  • Updated 3 weeks ago
I have a bizarre problem.  Out of the blue, SmartSDR has stopped connecting to my radio (Flex 6300), giving me the message "Unable to connect to the radio.  Please try again".


I have the radio plugged directly into the PC via ethernet.  Its the exact same setup that's been working in the past.  My radio was registered through SmartSDR, current firmware, etc. 


I've tried uninstalling and re-installing SmartSDR, turning off all antivirus/firewalls, restarting computer and radio multiple times, and even uninstalling some of the latest Windows software updates in case they were at fault.  But I still get this error.  My radio appears in the initial SmartSDR selection window, and it's marked as "Available".  When I hover over it I get the Serial #, IP address, etc.  I can log in to my account fine.  But when I click "Connect", I get the error message above.  Same results when hitting the "connect" button in the DAX/CAT windows.   I just can't connect no matter what I do.  This is the exact same setup that was working fine a couple weeks ago.


Any suggestions or advice?


Thanks!

Randy 

Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like

Posted 3 weeks ago

  • 1
Photo of Mike - WB8CXO

Mike - WB8CXO

  • 64 Posts
  • 14 Reply Likes
Did you try powering down the radio. Physically remove power for 5-10 seconds. Reconnect power then power up the radio to factory defaults?
Photo of Mack McCormick

Mack McCormick, Elmer

  • 378 Posts
  • 130 Reply Likes
Randy,

It's a  network issue somewhere. Do you have another computer and ethernet cable you can try? As you've noted be certain that antivirus is turned off. So of them block the network connection unexpectedly. If another computer and cable don't work then I would open a help desk ticket.

73,

Mack
W4AX
Alpha Team
Photo of Tim - G7GFW / F4VQP

Tim - G7GFW / F4VQP

  • 165 Posts
  • 68 Reply Likes
I had the same problem some time ago. Turned out that for some reason the Computer IP and the Radio IP were not on the same range. Took me  ages to spot it but a few minutes to sort out.

First of all find your computer IP address and subnet mask, several ways to do this depending on type of OS & computer.

Now start SSDR and hover over the RADIO, a box should popup showing, amongst oether thins, the radio IP and subnet mask.

Lets assume something is not right:

Computer IP = 192.168.0.9
s/n mask = 255.255.255.0
Default Gateway: 192.168.0.254

Radio IP = 169.156.9.21
s/n mask = 255.255.0.0

The computer and radio will NEVER talk to each other in a 'normal' domestic environment.

So how to fix it?

Lets assume you are running Windows 7.

Open Network & Sharing Center.
On the left hand side click on CHANGE ADAPTOR SETTINGS
This will open a box showing you network adaptor
RIGHT CLICK on the Adaptor
Select PROPERTIES
Another box will open
Click on Internet Protocol Version 4
This will open another box
Click on PROPERIES
You should see that the radio button Obtain an IP address etc has a dot in it.
The line below should say:
Use the following IP address
Click the radio button next to Use the....
Now,, using the example above, type in to the IP address section:169.156.9.51
Follow this and type into the Subnet Mask: 255.255.0.0
In the default gateway address type: 192.168.0.254]

Now click on OK

Now, close the Network and sharing Center and SSDR

Now start SSDR, with any luck you should be able to connect to the radio.

If you can, the follow the instructions in the SSDR manual to set a fixed IP address for the radio using an address of 192.168.0.XXX, I suggest something like 157 for the XXX part as it is unlikelyto be used by anything else.

Once you have done that you will lose connection to the radio. That is a good sign.

Now go back through the the Network and Sharing stuff and simply check the radio button next to Obtain an IP address....

Close the Network and Sharing Center and, if it was me, reboot the computer.

When it is back up, you should be able to connect to your radio.

Hopefully I haven't made any mistakes with the above, if I have I am sure someone will let me know!

Hopefully, the above will get your radio back on line for you.

Tim
Photo of Randall Steffens II

Randall Steffens II

  • 28 Posts
  • 1 Reply Like
Thank you Tim!!  That solved my problem!  I really appreciate the comprehensive instructions. Everything is working perfectly after following your directions above.  

I wonder how this IP issue occurred?  It's really strange.  One day it worked, the next day it didn't!

Anyway, I'm extremely grateful.

Randy NC8U
Photo of James Whiteway

James Whiteway

  • 948 Posts
  • 263 Reply Likes
It may be the radio lost its IP address if it was powered down and the power supply was too for an extended period of time. I had that experience once on my home network. That may not be the reason for you. But, it could be a possibility.
James
WD5GWY
Photo of Tim - G7GFW / F4VQP

Tim - G7GFW / F4VQP

  • 164 Posts
  • 68 Reply Likes
Hi Randy,

No problem, a pleasure to be able to help and glad you were able to fix the problem.

Cheers

Tim