(Memory Channels) last few digits of frequency changing.

  • 2
  • Problem
  • Updated 4 months ago
  • (Edited)

I noticed my channel list a lot of them have 1 at the end  or .999.
I have  cold rebooted and restarted every thing they come back.
Some frequencies are rounded off numbers as well, like 14,299.000 instead of like 14.300 or
a bunch of them similar rounding 14.299.001,or  14.164.999
When I clicked to use them they where not 14,299.000 it would be right on 14,300.000 on the flagpole/slice.


I spent like 30 minutes to correct this and they came back.

A while back I did the calibration on the radio against wwv wondering if that did it the ppm did change some.

Where is this coming from? I don't use memories a whole lot but just went through and corrected all of them for them to come back oddly again.
I never seen this before.
 73 Jeff.

Ideas? reset time?
Afraid to re-import saved files it may do it again.

VERSION 2.4.9
Photo of AA0KM

AA0KM

  • 356 Posts
  • 65 Reply Likes

Posted 4 months ago

  • 2
Photo of Rob G6EIH

Rob G6EIH

  • 102 Posts
  • 12 Reply Likes
Have the same problem here with 2.4.9, did a full reset and imported the memories again with the same errors showing. The memories were saved with the previous version and worked fine.
Photo of David-N5PSM

David-N5PSM

  • 103 Posts
  • 23 Reply Likes
Flex...Please tell us how the memories work internal so we can understand this.
Photo of Dennis Terry

Dennis Terry

  • 32 Posts
  • 3 Reply Likes
If I were to guess, they save the frequencies as a floating point number and the conversion(s) are imprecise.  Sounds like this "feature" is new with 2.4.9.
Just my $0.02.
W4SG

Photo of AA0KM

AA0KM

  • 356 Posts
  • 65 Reply Likes

Thanks for the replies. I will wait it out and see what happens in the next version.

Glad to know I was not the only one having this issue.