Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can't start Port shows -1 HELP

Hi. I have been using the SmartLink to use my 6600M from my iPhone and iPad with no problems for a year. Suddenly, I can not connect to my 6600M. The radio shows up on the list but will not connect. When I check the information button, I see the port is now -1. I don't believe that will work. I can access the radio through my wifi at home, just not away from home using the smartlink. I have been using Xfinity with the XFi modem the entire time. Thanks for any help. 73

Answers

  • ka9ees
    ka9ees Fithian IL USAMember ✭✭✭

    @Daniel AA4HV

    Seems I had the same problem. I had port forwarded to a fix IP address instead of using UNPnP. I now use it instead of manually port forwards.

    I have the IP address for the rig set as a reservation in my router. Never had a problem since.

  • The 6600M has had the same IP address from day one. No problem there. It signs in to the SmartLink, and I can see the radio on the list when using SmartSDR remote, but it just won't connect. Only thing that looks funny to me is Port -1.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    -1 means that the port forward is not what you want it to be.

    Usually rebooting the radio and the router at the same time and resolve it. To be sure, log into your router and check to see what the uPNP settings are. You can Google your router type for steps on how to do that.

    This is what you are looking for. It shows the radio IP address, the ports it is using. You want to make sure the IP address of the radio matches the IP address in the uPNP table.

    This is mine with 2 radios on 1 router using uPNP. The automatic setup works very well.


    This video will give you some ideas.



Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.