Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

CAT port won't connect to FLDIGI

James Del Principe
James Del Principe Member ✭✭
edited February 15 in SmartSDR CAT

I have had FLDIGI working for a long time but now the frequency will not track. I believe it is a CAT port issue. There is no connection from FLDIGI to any port.

FLDIGI V 4.1.17 FLEX V 3.1.12.51 Other apps , like Logger 32 and Winlink ARDOP work fine with CAT. I have activity on their ports shown with CAT LOG. No matter what port I select, FLDIGI will not connect. This has worked fine in the past. I have checked this site and U-tube for answers.

I created new ports, shut both apps down but no luck. FLDIGI transmits and receives fine both with RIGCAT or HAMLIB. No problem with DAX.

Any thoughts on the CAT com issue? 73 All, Jim

Comments

  • jkb
    jkb Member ✭✭
    Hi Jim,

    works fine here with HamLib and Kenwood TS-2000 as TRX definition for my Flex.
    I left the Baudrate at 38400.
    Don´t forget to click "initalize" in the lower right corner of the fldigi Hamlib Configuration Dialog.
    (Use HamLib Checkbox ticked)

    73´s Jan
  • jkb
    jkb Member ✭✭
    For reference, here´s a screenshot of my settings.

    https://pasteboard.co/JO0t6gI.jpg
  • Pat_W5WTH
    Pat_W5WTH Keep Radio Fun!!! Member ✭✭

    This NOT a FR question, but I'm guessing some that are more familiar with FLDigi be looking at this and know...

    Running FLDigi Rev 4.1.14 and now FLDigi doesn't remember the screen location to run at. I have to move the window manually with every run. I, of course, have tried 'save config'. I have also looked through the .INI files for screen location with no success.

    If anyone has a hint on what I need to do I would appreciate it.

  • WX7Y
    WX7Y Member ✭✭✭
    edited February 12

    I am probably wrong but Screen location on a windows machine is a Windows issue and not a FLDIGI issue, you probably got a Windows update that broke your screen location settings.

  • OK, I have a solution but a further issue. first, a friend, KN4HH sent me a new Rig Description file, smartsdr.xml. Using RigCAT, that fixed the issue. But now the communications works in one direction only. FLDIGI can control the Flex frequency but not the other way around. Additionally, Logger 32 is the same way. If I click on a listing in Logger 32, it will set the frequency in the Flex. However, changing the frequency in the radio does not change the frequency indicated in Logger 32.

    So these two programs have the same symptoms. In both cases, they can control the frequency of the Flex but the Flex cannot change the frequency indicated in either of these programs. In both cases, I can see this in the CAT control panel log tool. I can see the frequency called out in one direction but not the other. Very strange. Jim

  • JKB, I tried your solution but have the same results. Setting up for Hamlib, selecting TS2000, etc and then initialize and save.... same symptoms. CAT commands in one direction only. Thanks for your input. Jim

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    Screen shots make the discussion so much easier.

    Can you post a screen shot of your FLdigi configuration screens and also of SmartSDR CAT layout.

    This video goes over the setup.


  • jkb
    jkb Member ✭✭
    I recently noticed that when using SmartSDR locally (Win) sometimes external programs won't track the frequency of the local slice anymore. After some Band changes in SmartSDR the Logging program, or similar, just wont track anymore. Although the SmartSDR CAT Monitor shows the correct Data. It looks that somehow the "virtual" connection between the FlexVSP (e.g. COM5/COM105) stops working. After restarting the Logging program (reattach the process to the VSP) it works again. This never happens when the Slice is "remote" and coming from a M-Series Frontpanel. So the external program cannot be the culprit. Strange.....
  • Mike, Thank you for the reply and the video. This is really an excellent production. I did have all this running in the past and I'm familiar with setting up for RigCAT, Hamlib and FLRIG. I had an issue where my USB ports seemed to be scrambled and had a problem with audio when I tried, for the first time, to do a Zoom conference on my shack PC. I did get the headset to work on the Zoom call but in the process, caused myself a great deal of grief.

    I'd love to post screen shots of the setup as you requested but must confess, I do not know how to do that. I don't have MS Snipit for example, on the shack computer. Right now I'm using my laptop to communicate.

    That said, it is currently working on Hamlib and I think it would work on RigCAT as well. Let me propose what I think happened. When I updated the rigCat definition file, smartsdr.xml, I checked all configs, clicked initialize then save and then checked RigCat and closed it.

    I also did the same when trying Hamlib for control. I made the necessary configurations, clicked initialized, saved, selected Hamlib and closed. I believe that order is incorrect and that's what - I believe - caused my issue. The proper sequence for either selection is to make all of the necessary changes, select RigCAT or Hamlib, initialize, save and then close. It is necessary to select either RigCAT or Hamlib BEFORE initialize, save and close. I hope that made sense. It can be confusing to describe.

    Many Thanks for your kind assistance. Let me know if I made sense. Best 73, Jim

  • Mike, Thank you for the reply and the video. This is really an excellent production. I did have all this running in the past and I'm familiar with setting up for RigCAT, Hamlib and FLRIG. I had an issue where my USB ports seemed to be scrambled and had a problem with audio when I tried, for the first time, to do a Zoom conference on my shack PC. I did get the headset to work on the Zoom call but in the process, caused myself a great deal of grief.

    I'd love to post screen shots of the setup as you requested but must confess, I do not know how to do that. I don't have MS Snipit for example, on the shack computer. Right now I'm using my laptop to communicate.

    That said, it is currently working on Hamlib and I think it would work on RigCAT as well. Let me propose what I think happened. When I updated the rigCat definition file, smartsdr.xml, I checked all configs, clicked initialize then save and then checked RigCat and closed it.

    I also did the same when trying Hamlib for control. I made the necessary configurations, clicked initialized, saved, selected Hamlib and closed. I believe that order is incorrect and that's what - I believe - caused my issue. The proper sequence for either selection is to make all of the necessary changes, select RigCAT or Hamlib, initialize, save and then close. It is necessary to select either RigCAT or Hamlib BEFORE initialize, save and close. I hope that made sense. It can be confusing to describe.

    Many Thanks for your kind assistance. Let me know if I made sense. Best 73, Jim

    One additional note: On hamlib, I am using Kenwood TS 2000 (stable) and that works fine. Also, since straightening this out, Logger 32 now tracks frequency properly and if I change frequency in any application, all of them follow as they should. Jim

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.