Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

YAESU FUSION WIRES-X install issues

Kent Hufford
Kent Hufford Member ✭✭
edited December 2020 in Third-Party Software

Tried to install a YAESU FUSION WIRES-X box on a Windows PC. Could not get the software to see the audio from the wires box.

WE JUST fixed it. Deinstalled the FLEX SDR software and FLEX DAX software and drivers, and FUSION/wires-x box works fine.

 No warnings on startup of the WIRES program and audio in and out of the conf rooms.

We tried everything. Did not think it was the FLEX/DAX drivers because they were not being used.

 

Kent

KQ4KK

Answers

  • Stu Phillips - K6TU
    Stu Phillips - K6TU Member ✭✭
    edited May 2020
    My guess is that the Yaesu software can't deal with the number of audio devices enumerated by Windows when DAX is installed.

    Yet another example of software written around a set of expectations that aren't always valid (like only a small number of audio devices in a system).  Lots of the digital mode software packages have the same problem.

    GL trying to get Yaesu to fix this or even find a way to post a bug report to them.

    Sorry but I think you are stuck.  It's a Yaesu problem, not a FlexRadio problem.

    Sigh.
    Stu K6TU
  • Cal  N3CAL
    Cal N3CAL Member ✭✭
    edited February 2020
    Hi Kent,

    I just put a Wires-X Box online today as well and had the same issue!  I finally got it working once I uninstalled the FLEX SSDR software.   They do not want to co-exist on the same Windows machine.

    Cal/N3CAL
  • Daniel Drolc
    Daniel Drolc Member ✭✭
    edited February 2020
    I have sem problems with wire x and dax
  • KENT HUFFORD
    KENT HUFFORD Member ✭✭
    edited February 2020
    Yes. The only way to make it work. Put wires-x on a different Windows Pc than a Flex.
  • Daniel Drolc
    Daniel Drolc Member ✭✭
    edited February 2020
    I wonder if second sound card will fix this problem
  • bjn644 .
    bjn644 . Member ✭✭

    I see this post is a few months old, has anyone found a fix for this issue ? I've tried 2 different computers and have 2 friends with the same issue. It appears the Wires-X software wants to use the virtual com ports that the Flex software installs.

  • Phil M0VSE
    Phil M0VSE Member ✭✭

    Not sure if anybody has tried disabling the unused DAX audio inputs/outputs but I have found that this fixes issues with various older software that only supports a certain number of audio interfaces.

    73 Phil M0VSE

  • Bobby Pace
    Bobby Pace Member ✭✭

    I had the same problem other than I already had the WiresX installed on my PC, when I downloaded the Flex SmartSDR my WiresX no longer would work, PC’s are cheap and I had a lot of other programs running on the PC so I just bought a new PC, I’ll put the WiresX on the new PC when I find the time, I’m hoping that will do the trick, my WiresX node it connectEd to a Repeater and the antenna is up about 450’ and I have friends that were using it 😎

  • Bob KC9RF
    Bob KC9RF Member ✭✭

    One fix is to plug in something to the audio jack. I was told this by a Yaesu rep.

  • Bob KC9RF
    Bob KC9RF Member ✭✭

    Unfortunately the WIRES-X software does not run as mentioned in other posts. Even adding a USB sound card does not fix the issue. The audio jack trick does not work with flex software installed. Maybe a virtual machine running win 10?

  • Bob KC9RF
    Bob KC9RF Member ✭✭

    This fix seems to do the job thanks to a post about disabling unused dax devices in sound settings via Windows device manager

    I first removed and reloaded Flex software including DAX drivers to make sure I started fresh. Make sure to backup any profiles before removal & reload. Note My first Cat port is serial port 6. This can be changed to a higher value to suit if needed.

    Also Wires-X mode must be on to find the serial port that is being used in the radio. I have a Yaesu FTM-300DR. when powering on depending on how it is used is power on, GM & DX buttons are pushed to enter wires -x mode. IF PDN mode is desired push power on and DX buttons at power up. Check serial port used in device manager. This assumes that you have registered the radio with Yaesu for wires-x. If not it won't be recognized by the PC either

    I have a Flex 6600 that uses 4 DAX audio ports 1-4.

    Start windows device manager and click sound, click playback then disable Ports 5-8 for playback & recording by Right clicking on properties of each Dax playback and record device that is not being used.

    If you have a 6400 I would suggest disabling DAX ports 3-8 on both playback & record

    I tried out my PC with both programs Smart SDR via smart link and Wires-x running and all is working.

  • N0XFD
    N0XFD Member
    The limitation is the Wires X software doesn't allow you to pick what audio device it is using. (Hey YAESU - It would be great to make the audio device used sticky - so the program always uses that device... I know - asking a lot here... :| ) So if your Ham Radio computer has several audio devices connected to it (like most of us do these days) then you are in for a bit of fun.

    *** HRI-200 ***

    If you have the HRI-200 connected to the computer the Wires X software should figure out what Input / Output numbers the sound card in the HRI-200 is and use those. Just make sure the HRI-200 audio device has not become the Default Device, or Default Communication Device for audio on the computer. If you run into an issue, set the Default Device and Default Communication Device (for audio) to something other then the HRI-200 audio device.

    -Right Click Speaker in Tool Bar (Lower Right Corner of Screen)

    -Click 'Sounds'

    -Recording Tab -- Verify HRI-200 Audio Device is not any Default Audio Device (You may need to plug something into your mic jack on the computer to be able to select that jack as the default so the HRI-200 is not).

    -Playback Tab -- Verify HRI-200 Audio Device is not any Default Audio Device (Set the Default to your Speakers or Headphones, if you don't have a speaker built into the computer you may need to plug something into your speaker jack to be able to set it as the default audio device)

    -Now start Wires X, it should use the HRI-200 audio device for all the audio stuff, and not some other audio device.

    *** Portable HRI Node ***

    If you are using your FT2, 3D, FTM-100, 300, 400... Directly connected to your computer in Portable HRI Node Mode (i.e. you want to connect to a Analog allowed Room or Node -- i.e. not a Digital Only Node / Room) then the audio setup of the Wires X software seems to rely on using the Default Communication Device of windows (and I think also Default Device, you may need to play with that). So whatever audio device you have the analog audio cables connected to, you need to make sure that device is set as the Default Communication Device and go from there. Note the Windows Sounds ('Ding', 'Click', 'Tah-Dah!') are usually routed to the Default Device (not default communication device), so we want to make sure your node doesn't send those out to other nodes / rooms / rf. You may need to play with that once you get Wires X started. In Wires X - View - Audio Adjustment - Sound Property will get you to the windows Sound settings also.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.