Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FLDIGI Not Keying Transmit

Using HamLib net CAT control on both software programs. Flex shows connected and FLDIGI responds to changes implemented on Flex. When I try to transmit, I am not seeing any sign of outgoing signal. Same basic setup works with dogparkSDR perfectly. Have explored every alternative I can think of and still no joy. Flex shows its transmitting when I push the tune button in SmartSDR but not when I do same in FLDIGI. All ideas gladly accepted.
73 de K7BAW


  • Dudley  WA5QPZ
    Dudley WA5QPZ Member ✭✭✭


    Make sure you have the Blue DAX button enabled and DAX TX button enabled and correct DAX channel selected in the Slice window, this is for the audio. To key the radio, SmartCAT either com port selected or TCP port if using network transport of CAT commands .


    Dudley, WA5QPZ

  • Ted  VE3TRQ
    Ted VE3TRQ Member ✭✭✭
    edited August 2020

    [Edit: Should have paid attention to the category - ignore my post - I have not yet purchased SSDR for Mac.]


    A bit more information might be useful. You mention "both software programs" - to which two are you referring? Also, you mention dogpark, so presumably a Mac. What version O/S? What are you using for Dax / Cat? What version of SSDR on the radio?

    It sounds like your Dax is having issues - are you connected to the correct slice? Sorry for more questions than answers, but digging in needs the answers.

    Ted VE3TRQ

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin

    It seems like there was a Bug that Marcus has fixed in v1.3.2.

    In the Mac store, you will want to update SmartSDR once it is released by Apple.


  • B) Thanks Dudley et al for responding. Just to clarify, everything works perfectly in SmartSDR except getting the radio to transmit from FLDigi. When I push tune button in SmartSDR, the radio transmits. When I push tune button in FLDigi the radio does not transmit. I can change FLDigi settings from the radio-for example band-but I can't get FLDigi to transmit. All of this is setup for digital-primarily PSK31-as I am profoundly hard of hearing and only do digital. Also, I am using Loopback to provide the digital cables to pass data between SmartSDR and fldigi. I am using TCP ports over my LAN. Thanks again to all.
  • George KF2T
    George KF2T Member ✭✭✭

    Have the same issue here. Using Hamlib, rig control is fine. DAX is solid. Just no PTT, despite "PTT via Hamlib command" checked. CAT setting in SSDR is for RigCtl/Hamlib.

    Am using VOX with no problem, though.


  • George KF2T
    George KF2T Member ✭✭✭

    Update: It's a reported bug and Marcus is on it.

  • George KF2T
    George KF2T Member ✭✭✭

    Update on the Update: Fixed in 1.3.5

  • Yes all is good. Been connecting with Marcus, who is an awesome example of great customer support, and now all is running smoothly here in the sun blistered Sonoran desert.