Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6700 radio won't connect through smart link

Tom OBoyle
Tom OBoyle Member ✭✭
I'm stumped.  It's been awhile since I tried using the radio with iOS and Smartlink.  The radio shows available but each time I tell it to connect, the app goes back to the main panadapter connect screen.  

So I tried it on the Windows PC -- even though the radio is available through SmartLink, it fails to connect.  I have done the following:

  • Rebooted, completely removing power on the radio
  • Verified that I am signed in the same way (via email) as the radio is registered
  • Uninstalled/reinstalled iOS app
  • Verified everything is on the latest versions
  • Reboot PC/Router/Radio/iPad
Any ideas?

image

Comments

  • Mark Earle
    Mark Earle Member
    edited January 2020
    In the ios app, settings, there is a value to enable smartlink, and then check smartlink status. You may need to fiddle with those two.

    While there, turn on prevent device sleep, and disconnect on close.
     
    There's also LAN mode, you may need to toggle it to off then back to Discover.. or leave it off if you're just using it on your local LAN.

    On the initial screen just to see if it makes any difference, tap the i to see if you get the radio S/n and IP.. that would show it's communicating with the app.. and you might try low bandwidth connect, again, just to see if that makes it "go".
     
    I'm running a 6400 200 miles from here, using Windows, ipad and iphone clients. So far so good! de Mark WA2MCT
  • Tom OBoyle
    Tom OBoyle Member ✭✭
    edited January 2020
    Thanks Mark for the help on this. 

    Yes, on the PC, I can get the Windows tip with the radio's SN/IP/MAC/Version and Smartlink TCP and UDP ports displayed. See below.



    I went to the PC to test when the iOS iPAD was not connecting.  So I don't think it is specific to the iPAD's software, but something else.

    73 de Tom, N9GUN

  • Mark Earle
    Mark Earle Member
    edited January 2020
    Those are not the "standard" udp ports. Mine are 4494 and 4493. The ios app has a similar 'I" screen. Have you changed the udp ports in the ios app? Also if you're not on the local LAN those ports may have to be opened/ forwarded from "outside" (WAN) to "inside" (LAN) in your router.
  • Tom OBoyle
    Tom OBoyle Member ✭✭
    edited January 2020
    Those are the same ports I've used for a year or two...  They are forwarded to the 4993 (UDP) and 4994 (TCP) appropriately.  Yes, I am "outside the local network" by routing the PC and iPAD via a different WLAN network that is isolated form my local LAN. When I am on the local network on the iPAD, I can connect locally to the radio.  It offers the SmartLink connection, but does not connect.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited January 2020
    Hi Tom

    Can you do the test where you get the Red or Green light.  It is in the SmartSDR SmartLink setup.    

    It sounds like your portforwards are not working correctly.

    Mike
  • Tom OBoyle
    Tom OBoyle Member ✭✭
    edited January 2020
    Hi Mike -

    Yes.  It is Green.

    73 de Tom, N9GUN


  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited January 2020
    Gotcha!  Sounds like you covered all your bases.  I'll convert this to a support case.
  • Gene Duprey
    Gene Duprey Member ✭✭
    edited January 2020
    I have the same issue, and I get the green test good indicator. Let me know what the fix is.

    gene, k1gd
  • Jim_K6KGW
    Jim_K6KGW Member
    edited June 2020
    I have the exact same issue but with using WIN10.  I travel extensively on business and really want to play radio reliably on the road.
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited June 2020
    Jim

    Have you followed the steps in Chapter 8 of the SmartSDR V3 manual?  When you did the TEST, did you get a green light that says everything is ok?

    Let us know so we can work on this for you.

    73
  • Jim_K6KGW
    Jim_K6KGW Member
    edited June 2020
    Hi Michael,

    Yes I did and I get the green light.  I have already submitted a ticket and Ken is working it for me.  Hopefully it's a **** thing I have just overlooked!
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited June 2020
    Good to know.  I'm sure ken will get to the bottom of it.

    I have the odd issue with it (about 1/yr) and it is 100% my router that messes up.

    73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.