Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX problem with wsjt-x

Al MatthewsAl Matthews Member ✭✭
DAX entries ok in Windows, but not in WSJT-X. I have had windows corrupt the dax entries in device manager. I did all the renaming, and they now look fine in device manager. However, they are not ok in WSJT-X. I have re-booted, removed and re-installed WSJT-x, and the problem persists. I have been experiencing WSJT-x stopping decoding every few minutes, and having to re-start dax to correct it. It happens do frequently it is virtually unusable. Does anyone know why the entries in wsjt don't agree with window (device manager)?  
Al / K1LTJ
image

image

Completed · Last Updated

Answers

  • Al K0VMAl K0VM Retired Member ✭✭
    edited March 15
    AL,
       You didn't say which version of (DAX) SSDR you have installed on your PC.   SSDR Versions 1.12.1, 2.6.1 and 3.1.8 where released specifically to eliminate the DAX naming issues.   These versions contain the DAX 3.1.0.5 drivers and are available at no charge for you licensed major version.  If you wish, you may just install the new SSDR version ( which contains the new DAX drivers) on your PC without up grading the firmware in you radio. But I recommend up grading the radio also.
    AL, K0VM
  • Al MatthewsAl Matthews Member ✭✭
    edited June 3
    Thanks Al, I am using 2.5.1, and it has been stable. Perhaps I'll take a shot at 2.6.1. Still, I dont understand why wsjt doesn't seem to read the win10 info correctly.

    Al

  • Al K0VMAl K0VM Retired Member ✭✭
    edited March 15
    AL,
      The DAX renaming procedure does have a potential trap when deciding what to name what.  Its likely that an IQ port got renamed with a non-IQ name and visa versa ( and still look correct in the device manager).   You could probably  work through the naming process again and find the problem but I recommend the upgrade to 2.6.1 and you should be done with the DAX naming  issues.  Like I said you can just install 2.6.1 on the PC but still run older version of SSDR on the radio if it is not removed from the PC.  2.6.1 does contain some other bug fixes as well.  Look at the change log.
    AL, K0VM
  • Michael N3LIMichael N3LI Member ✭✭
    edited March 16
    I've had an issue with WSJT-X with every update. The Dax Receive stays the same, but the Dax transmit setting in WSJT-X doesn't work.

    The whack-a-doodle fix is to change the settings (mono, right-left-both) in WSJT-X until it starts sending audio to DAX. Weird thing is, it is usually the setting used that worked before. Bt it wants me to go through the motions of changing everything, I guess.

    Given that all my other programs that use DAX stay the same, like fldigi, I heavily suspect it's a a WSJT-X problem.

    I now do  a pre-check after every Windows update. I've missed 2 ATNO's when trying to catch DX after an update.
  • Bob G   W1GLVBob G W1GLV Member ✭✭
    edited June 16
    Al, I had the same problem about a year ago. After many days of frustration with DAX, I consulted a fellow Windows IT expert. First of all I don't have any speakers connected to my computer and I'm running Windows 10 latest update. No speakers connected means that Windows has to connect to an audio source, any. It grabs the first DAX port available and creates havoc when you try to use anything that needs DAX. Solution, under $10.00 you can install a USB soundcard to your computer and voila! problem solved. Windows is happy with the soundcard and digital programs can use DAX without frustration. Good Luck
  • Al MatthewsAl Matthews Member ✭✭
    edited March 17
    That is very interesting Bob. I'll try it out

  • Al MatthewsAl Matthews Member ✭✭
    edited June 3
    So, after lot's of hassles I have it working better than every. I took your advice Al, and upgraded to 2.6.1, not just the drivers, the whole package. At that point I brought it all up, and still had the same issue. WSJT-x would decode for a few minutes, to perhaps half and hour, and then quit. For lack of any ideas, I completely remove the flex software (using the flex uninstall), and then re-booted and re-installed 2.6.1. It has been working for over 24 hours with no issues. I don't have any idea what was going on, just one of those windows mysteries, but it's nice to have it back. Thank you Bob, Michael, and Al for the great suggestions and help. This is the greatest forum ever. 
    Al

  • Al MatthewsAl Matthews Member ✭✭
    edited June 3
    I am now back to square one. Everything worked for 24 hours without interruption, but now it is back to the bad behavior. I have tried all suggestions received to date, and nothing helps. I noticed a way to tell when it goes into no operation mode. The waterfall display in wsjt-x will suddenly look as though you are looking through a piece of frosted glass. This happens every 4 to 5 minutes. The only way to get it back decoding is to close and re-open DAX. As far as I can tell, everything looks perfect, the devices in wsjt-x, in device manager, and in the audio panels. I have essentially identical installations on my desktop and laptop, and they both behave exactly the same way. They are both running clean installs of 2.6.1  I am out of ideas. Can anyone think of anything else to try?

    Al / K1LTJ
      
  • Logan KE7AZLogan KE7AZ Member ✭✭
    edited March 25
    I had a similar problem with the WSJT spectrum changing from square spectra to spectra that looked like rounded mounds.  I eventually went to Control Panel->Sound and found multiple instances of duplicate DAX devices that were greyed out along with the expected set of DAX devices that were flagged as Ready.  I did a right click on each of the greyed out devices and clicked  Disable and the problem went away. 

    On a later boot, I discovered that all of the greyed out DAX devices had disappeared to be replaced with greyed out devices for the audio channel on my monitor.  Now I have problems with that audio channel disappearing but it doesn't affect my operating, so I just live with it. (along with lots of PORTCLS.SYS BSODs when I reboot the computer).  Clearly the Win 10 Driver group needs to be summarily fired and the Win 10 driver management code for Sound devices rewritten.

    This happened on a clean install of Win 10 (I downgraded from Win 7) so I'm confident that there are no Win 7 residuals affecting the system.

    Maybe this will help.

    73
    Logan, KE7AZ
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 27
    This is a known issue where long-duration DPCs generated by the PC adversely affect the audio buffers of the DAX driver causing buffer corruption.  Stopping and restarting DAX reinitializes the buffers until the next time the corruption occurs.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.