Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

power genius xl utility

K6ANP
K6ANP Member ✭✭
I'm unable to get power Genius xl utility to discover the amp. when I boot up utility the available devices window is blank. I tried everything I could think of including reinstalling the utility program, shutting down and restarting the amp.  the amp, restarting the computer. I'm running windows 10 and found a non compatible note along with a fix it tab tried that and still no good.
Any suggestions will be appreciated. I see others posted it was truly plug and play for them....anything but for me!

de,
Len, K6ANP

Answers

  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited March 2020
    Verify that serial number is much to your radio.
    pgxl shipped with SN of the radio they used for testing
    Sergey, KN7K 
  • Ray - K6LJ
    Ray - K6LJ Member ✭✭
    edited March 2020
    In addition to advice above I put in a static IP address. I found that if the amp takes a bit of time getting the ip from your router it will time out and show a default IP on the front of the amp then will not connect. I always had to reboot the amp a few times until it was assigned an IP via DHCP. That issue was totally resolved by putting in a static IP. Hope this helps

    73 Ray
  • K6ANP
    K6ANP Member ✭✭
    edited March 2020
    The problem is the devise window in the utility program does not show that the amp exists so I’m unable to enter any data pertaining to the amp’s up address or its serial number
  • Ray - K6LJ
    Ray - K6LJ Member ✭✭
    edited March 2020
    Hi Sergey - During the startup / reboot what IP is the radio finding on the front panel of the amp? Is the amp connected to the same network thru a switch or how connected?
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited March 2020
    192.168.1.20. amp connected to the switch
  • Sergey KN7K
    Sergey KN7K Member ✭✭
    edited March 2020
    Open PGXL utility, go to FelxRadio tab, enter your radio SN for Port A and Port B



    also make sure your IP address is listed

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited March 2020
    Len

    A few questions and I doubt that re-installing the software will solve your issue.  

    It sounds like the firewall is on your PC for Local Lan connections.  As a test, you can turn off the firewall and make sure.  If your firewall is on, it will prevent the PC from seeing the data communications from the Amplifier.  By default, Windows tends to turn this on.

    On the front of the Amp, is there an IP address?  If so, can you share it with us and the IP address of your computer.  This will help us to make sure that the Amp and the Radio are on the same LAN network (called a SubNet).


    Mike


  • K6ANP
    K6ANP Member ✭✭
    edited March 2020
    The IP address on the amp is 192.168.125 [DHCP-IDLE] The computer shows IPv4 address 192.168.1.16 the IPv4 DNS server 192.168.1.1
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited March 2020
    Can you check the IP address on the Amp again.  There isn't enough digits.

    What about the firewall on the computer.

    thanks

  • K6ANP
    K6ANP Member ✭✭
    edited March 2020
    Frankly I don’t know or understand how to modify the firewall
  • K6ANP
    K6ANP Member ✭✭
    edited March 2020
    192.168.1.25
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited March 2020
    Hi

    Good news on the IP address.  That  looks right.

    https://www.lifewire.com/how-to-disable-the-windows-firewall-2624505  

    It is a few mouse clicks.  This should help you out depending on which version of windows you have.

    Mike

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.