Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex Firewire Driver Does Not Recognize Any Firewire Card in Windows 10 64bit

Flex 5000A will not work due to Firewire driver problem with Windows 10

I have an HP EliteDesk 705 G4 minitower computer (AMD Ryzen™ 5 PRO 2400G) running Windows 10 64Bit. The latest version of the Flex Firewire driver is installed, but it doesn't recognize either of my newly purchased PCI Express X1 Firewire cards: SIIG FireWire 2-Port PCIe (NN-E20012-S2) and VANTEC 3-Port FireWire 400 PCIe Host Card Model UGT-FW200 (same as Vantec UGT-FW200). Both cards have TI chips.

Windows Device Manager shows both cards to be installed and working properly with no driver problems so I believe there is a compatibility problem between the Windows OS and the Flex Firewire driver.

I have an older computer with Windows 7 that I was able to use by installing an older PCI (not express) card. With Windows 7 support ending soon, I am considering updating to Windows 10, but I'm afraid that it will cause Firewire to stop working. Perhaps I should just dedicate this computer for use with the radio and not connect it to the web.

Has anyone been able to find a way to make the Flex driver work with Windows 10?

Thank you


  • Bill -VA3WTB
    Bill -VA3WTB Member ✭✭✭
    edited November 2019
    I just bought a used Win 10 computer and and installed a PCIE fire wire card and it works very well. I downloaded the latest KE9NS PSDR software, it is Win10 compatible.
    This should work for you.
    Also if you keep the Win7 computer as a dedicated Flex box then Win support means nothing. Go ahead and do that if you want to.

    Now I have SSDR and PSDR on my Win10 computer and can switch between either of them in  seconds.
  • Lance Shively
    Lance Shively Member
    edited November 2019
    I recently purchase a Flex 3000 used, and an off-Lease Dell OptiPlex 990 Win 10 Pro 64
    I installed a Vantec (UGT-FW210) card, and after a hick-up where the computer would not see the card in device manager, I powered off, drained the PS, and reinstalled the card, 
    Windows 10 drivers worked fine and the system works great.
    I am sure you can work out your issues, Good Luck es 73, Lance K8LCS
  • Paul Rawlings
    Paul Rawlings Member
    edited November 2019
    It sound like you both got lucky with Windows 10. I have spend several weeks trying to get first the Windows 7 and then the Windows 10 computers working with my 5000A.

    The Windows 7 computer is working and I intend to keep it that way by not upgrading it to Windows 10. The Flex firewire driver acts flakey with Windows 10 and my HP computer. At first SmartSDR got hung in a loop saying the the radio firmware needed to be updated. I got that problem solved and then the Flex firewire driver wouldn't detect the Firewire card. I tried two new cards an SIIG and Rosewill. I got that problem solved and now when I start SmartSDR and click the start button the panadapter, waterfall and S meter show no received signal not even noise. The radio is totally deaf on all bands. I know the radio hardware is good because it works with the older Win 7 computer. Also, I get a Port Audio Error and an Invalid Stream Pointer error when I enable Virtual Audio Cable 1.

    I will write a detailed history of the problems that I have had with the Flex 5000A and both computers and I will post it to this string. Maybe it will be helpful to someone else and maybe there is someone who can tell me how to get the Windows 10 computer working with the Flex 5000A.

    The radio works great when it works. I only had the radio 3 years before it was discontinued by Flex Radio. They are either unable or unwilling to provide support beyond what you can find posted on their website. It would be nice to see a 2.80 version of PowerSDR with a robust firewire driver running under Linux. The way that Flex has treated the owners of their "legacy" products, I doubt that I will ever buy from them again. The Yaesu FTDX101D seems to be a better way of doing SDR; an embedded computer with no PC and OS to be patched or upgraded.
  • Lance Shively
    Lance Shively Member
    edited November 2019
    I can understand your frustration, I purchased a nice used off-lease
    Dell Optiplex 990 I7 / 16GB Win 10 Pro (1 PCIe port) to run my New/Used Flex with, and after a couple weeks of frustration, I was ready to give up.
    It worked ok on my old old Acer Win 7 machine with built-in firewire, but that computer would not do justice to this Awesome Flex SDR

    It took a note to the Firewire card manufacturer to find it was a card installation problem, hopefully this will help others;

    From: Vantec Tec Support - 
    Try this:
    1) Shutdown system.
    2) unplug power from the wall  outlet that was powering your system. A MUST, if you have any other power coming into the system, power them off too.
    3) unplug the Firewire card from the slot and wait a WHOLE minute.
    4) if you have more than 1 PCIe slot move to another PCIe slot. If not, plug back in to the same slot.
    5) undo what you did in step 2.
    6) Power back on your system.
    7) go into device manager to check if it shows up.

     Two thing may have happen.

    1) The PCIe bus may be alive (powered) when you insert the card and it shorted the card. Step 1 to 7 will fix that.
    2) Your system BIOS did not allocate any resources to the card as a result the OS cannot see it. Step 4 will fix that if you have to a different slot forcing the system BIOS to reallocate the resources and give Firewire card the resources it needs.
    ALL (any manufacturer) Firewire card drivers was originally built into the OS (XP,Vista,7), but Microsoft decided to remove them and put it as a separate drivers on their website and NOT built into the OS (8/8.1/10). If you are lucky this Dell model may have the Firewire drivers put back in by the Dell manufacturing (they did not do that for all their model). If they did not, you can get them from Microsoft. Microsoft wrote the drivers and we cannot distribute them. We can provide you with a link to download if Dell did not install it for you.
     If no drivers was installed, in device manager you should see a other device with yellow exclamation mark, you will need to download the drivers. If it see IEEE 1394 or any variation of 1394, your system is detecting the card.

    I am usually brand loyal, but after getting **** for the last time, I gave up on HP several years ago, went to Dell and never looked back.
    My advice to you FWIW is to consider the many very inexpensive Dell Off-Lease computers available
    virtually everywhere, Craigslist, eBay, Amazon, DiscountElectronics.com in TX has Win 10 I3 computers for under $150 and I7 under $200 all with 1 year warranty
    The Optiplex is a high end business computer costing in the thousands when they were new.
    Mine is a mini tower, not the smaller SFF
    My I7 Dell runs about 9% CPU usage running the Flex 3000 on SSB  and CPU temp stays around 100 F 

    The VanTec UGT-FW210 card I have is recommended by Flex, and is available on Amazon.
    My Guess is for under a couple hundred dollars you could have your flex running like a new one.

    Good Luck, 
    73 de Lance K8LCS

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.