Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR contest bugs

Spotted two very annoying and time wasting bugs in SmartSDR (3.1.8) during my 2 x 12 hrs sessions in CQWW last weekend as M1C.

1) A few out of band ops being spotted in CQWW. Logging with N1MM. You click a cluster spot, without having noticed that it is out of band. N1MM sends the TX freq to the radio but it's slightly out of band (300Hz in one case). You go to TX and it locks you out (out of band error) as expected. However, you then cannot unlock your radio again without resorting to a complete power-down and restart of the radio. I have tested and this problem only happens when SmartSDR is being driven by a logger. It works as expecting when manually driving the SmartSDR. This happened 7 or 8 times during the weekend and I estimate it lost me about 20 minutes of contest time waiting for the reboots, and thus also losing your run QRG  etc.

2) I also observed 3 UHE errors from SmartSDR. When frantically busy during a contest is not the right time for a screen grab, but again it lost me time having to close and reload SmartSDR.

Overall approx. 30 mins of precious contest time lost due to SmartSDR bugs.


Comments

  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited May 16
    Steve

    I clicked out spots like that and when my TX bandwidth took me out of band, I was not able to tx.  This is by design. 

    I just moved my VFO knob and I was able to transmit again.  Did you try this?  What other things did you try to allow you to continue?    Can you recreate this?  Try this by sending a test spot and see what happens.

    If you are receiving UHE's, then you should open a support case.  Can you recreate what caused them?  

    Mike 
  • KI4PKI4P Member ✭✭
    edited May 22
    i happened to do the same on #1, clicked on a spot and it was out of band, took me a sec to realize what was going on, clicked on a spot in band worked like a champ. but im using DX Labs suite! JMO!
  • Steve G1XOWSteve G1XOW Member
    edited October 2019
    As i said, it works as expected when drivng manually and i understand how it would normally unlock. Seen that plenty of times. This is different. Problem comes from driving radio via cat. Even if you manually move vfo well back in band or even another band will not unlock it. Cold restart was the only method found that worked. Clearly something wrong in lock out processing that differs from cat and manual vfo moves.
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited October 2019
    Steven

    Can you recreate this?  I was running SO2R with N1MM on a 6600.   There was one station on 20M whose upper sideband was out of band.  I was going to work him and I could not transmit.  That was when I noticed he was violation of his license.   

    I got there by clicking on a cluster spot.  It did not lock up my Maestro at all.

    I  just tried on my cluster and I was not able to get it to fail on 20M.  You can see the transmitter is disabled as the RF Power is greyed out as I am out of band due to my upper side band being above 14.350.  (If you look at the cluster now, you'll see the spot I used).

    My maestro was not locked up in any way at all.

    What other programs were you using that can communicate via CAT to the radio?  Could one of those placed the radio into TX Inhibit and rebooting the Maestro broke that connection?    

    If you can help us recreate this, then I can pass that on to engineering.     I really need the steps you took to cause this to fail for you.  

    Thanks for your help with this.

    Mike va3mw
  • Steve G1XOWSteve G1XOW Member
    edited November 2019
    Hi Michael, yes I have just recreated it again some days later.

    The problem is localized to VOX use. I will explain: 

    if you go out of band via a CAT command (e.g. from n1mm 15m SSB mode with VOX on) then you try to TX you see the "TX not ready" in the bottom right of the screen as you would expect. 

    If you then manually slide the VFO back in-band you then see "TX ready" again (fine you would think!). You can then TX again by hitting the tune button. However, it still will not TX again using VOX until a cold reboot of the radio. I tried switching modes, bands, profiles nothing kicks it back in to life until a reboot of the radio. The problem is entirely reproduceable every time.

    If you want to use teamviewer or other RDP to take a look that is fine. Or, I can send a short video.

    However, the UHE errors will have to wait until I next see one outside of contest time to get a screen grab.

    73
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited November 2019
    I have converted this to a support case.     Please attach a video to the support ticket when you have a moment.  

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.