Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SSDR iOS App Freeze

Dan Trainor
Dan Trainor Member ✭✭

Hello,  I am using SSDR iOS app and every few minutes it freezes the graphic display and audio. It shows it is still connected. It experiences this when at my friends home Wi-Fi network. To get it to work again, I have to disconnect and connect again.  Then after a few minutes it freezes again - consistently. When we switch to cellular WAN connection, the App works as expected (no freeze). Any ideas on how to troubleshoot and resolve?  Thanks in advance.  dan

Answers

  • Scott N8UMW
    Scott N8UMW Member
    edited April 2019
    Does your friends Wi-Fi router have multiple antennas and a feature called beam forming? If so, have your friend go into the settings and disable it. That cured choppy and frozen connections with mine.
  • Mark NS9N
    Mark NS9N Member ✭✭
    edited April 2019
    Also check the speed of the wifi connection. Ping it. Had the same issue and found it was a slow wifi connection. In my case, the hard ware connection to the computer was no issue but the wifi was just too slow. Now I just connect using my cell network.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019

    We can connect fine with Windows version of SSDR and runs really well on same network. Wi-Fi download speed measured at 80 mbps and upload at 20 mbps.  So speed test is ok.  But, iOS version works for a few minutes at speed and then freezes.  That is the problem....
  • Mark NS9N
    Mark NS9N Member ✭✭
    edited April 2019
    Given what you have told us, this is either a WiFi issue at your friends location as others have outlined or Apple latest update has again caused an App issue. Many of my Apple apps have issues after the Ver 12 iOS update. So far all I have been told is Apple is working on another update. Don’t get me wrong, I love my Apple Flex app but really would love to get an Android Ver. I no longer believe a closed architecture adds any value. Wednesday night I will be remote with my Apple phone for my local net. If I have issues, my Windows tablet is my backup!
  • KI4P
    KI4P Member ✭✭
    edited May 2020
    I really think it's a Wi-Fi problem! We hold our club meeting at a local church, sometimes my waterfall slows or non existent! Switch to cell works great, no problem with apple updates on my end!
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited September 2019
    I have the same problem with iOS.  I don't seem to have the issue at home but if I use the wifi connection at work, it will work great for 4-5 minutes and then just freeze. Audio and panadapter will just stop.  If I disconnect and reconnect it works fine for another 4-5 minutes and then just freezes again.  If I use cell data, it works fine.  I have my Maestro in the office and it will run all day with no issues.  Same with SSDR and DogparkSDR from the same wifi.  They all run all day with no issues but iOS will only run for 4-5 minutes.  I have tried everything I can think of and nothing fixes.

    Burch
    K4QXX
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019

    Hi Burch, we have the same exact issue as you described.  I wonder if someone knows root cause?  Given that it works for several minutes then all of a sudden stops dead in its tracks seems to be a clue of something.  But what is causing it to go from running exceptionally well to frozen? Each and every time.  I can reproduce this by simply connecting, using the panadapter for a few minutes and then POW. Very puzzling.
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited April 2019
    I have been battling this for a long time.  I posted about this just minutes before SSDR V3 came out and my post got buried so I was glad to see this post.  I have two separate Spectrum internet services at my work and they both do the same thing.  Both connections are using a Netgear router but they are different models.   At the house, I don't get the frozen screens but I do sometimes get a lot of stutter and audio/video drops but it never freezes.  If I work at our Sarasota office I don't have the issue.  I am suspecting it is something in the router but I'm not sure what to change except for the beam forming that someone above suggested.  I recently brought in my Maestro to the office and ran it for 5 hours straight via the same wifi connection and I only had 65 packets dropped in 5 hours.  That's better than I get on my local wifi at home.  But iOS just won't stay running.  One of the wifi's that I use at work is located in my office and I am the only person who uses it so I know their's not another device that is connect that could be causing this.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019

    Very interesting.  It just so happens this home has Spectrum internet services.  Any other Wi-Fi network I have been on with the SSDR iOS App, it worked just fine.  And that has been many Wi-Fi networks.  Why only this one home?  My Windows SSDR works well here.  Every other application I use does also.  What is unique about this particular iOS app that would cause it to run perfectly for several minutes and then simple freeze solid.  I am beginning to think it is something deep in the network Wi-Fi configuration.  But, not sure where to look yet.  Perhaps in the fire wall, but that would just be a wild guess.   And "try everything" approach is also not an option. As we need to get this up and running as my flight leaves to go back home later this week. dan
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited April 2019
    As you say, the weird part is it runs perfect for 4-5 minutes and just stops.  Hitting disconnect and then connecting again it will run fine for another 4-5 minutes.   Really strange.  
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019

    We are now measuring the number of minutes it takes to fail.  Also we have a new theory.  The network could have something running on a timer.  And when that timer is triggered, the fault occurs.  What the time is and where it is and how to disable it is the path we are going down now.  This may take awhile, so I may have to change my return flight plans. dan
  • Mark NS9N
    Mark NS9N Member ✭✭
    edited April 2019
    So I just was demoing my station on my I phone on a cell network. Locked up two times requiring a restart of the program. This never happened before Apple did the V12 iOS update. Maybe two different issues but this app is now doing what other non ham apps are doing. If you don’t find anything, maybe the next Apple update will bring its all back to the orchard.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019

    Time from "Connect" to "Freeze" measured to be from 1 min 30 secs - 1 min 50 secs - from 6 measurements / data points.  Apparently "Something" in the network or the router is creating timed event which is causing the failure.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited April 2019
    On cellular network and/or some other Wi-Fi systems, the app works just fine and does NOT freeze.
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited April 2019
    My time is between 4-5 minutes before freeze.  Mine is not from iOS 12 as mine has been doing this for a year or two.
  • Scott N8UMW
    Scott N8UMW Member
    edited May 2019
    What kind of router is it?
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited May 2019
    Both Spectrum wifi services I have at work are Netgear.  I don't remember the model numbers but I can look tomorrow.  They are both consumer grade routers and both are 2.4 and 5ghz.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited May 2019
    He is not using the Router supplied by Spectrum, rather he is using an Apple Airport Express.
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited May 2019
    We tried test with multiple different iPads.  And same symptom appears.  SSDR iOS App runs fine for approximately 1 min 45 secs, then freezes (graphics and audio).  But, does not disconnect from radio.  You have to manually disconnect then connect again.  Then App runs for another 1 min 45 secs and freezes.  Etc, etc.
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited May 2019
    I timed the issue here in the office this morning.  It freezes right before the 5 minute mark.  I did find a workaround though.  If I connect to my VPN and run iOS, I don't have the freezing issue.  My issue only happens when I run wifi using Smartlink.  I'm not sure why using the VPN works but at least I have a work around for now. 
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited May 2019

    Thanks Burch.  We don't have a VPN (at least I don't think).  But, thanks for the workaround.  Something else we can look into.  Also, you mentioned a relationship with this issue and SmartLink.  That is useful info too.  Thank you!, dan
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited May 2019

    We went to a local grocery store and used the Wi-Fi there.  All the iOS devices iPads and iPhones worked great.  No freeze. So, that confirms it is something about this one home Wi-Fi installation and its interaction with iOS devices.  The Windows version of SSDR works fine.  I open a ticket with cable company and also iOS SW vendor in case they might think of a root cause.  How something can work fine for 1 min and 50 secs, then freeze cold. dan
  • Dan Trainor
    Dan Trainor Member ✭✭
    edited May 2019
    Good news is we made a nice 20 meter DX contact to Spain in the vegetable isle of grocery store :)
  • Scott N8UMW
    Scott N8UMW Member
    edited May 2019
    I see that the airport extreme is listed as having beamforming, but cannot find any information that the express version is. So much for that idea, unless another member knows.
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited May 2019
    I couldn't find any info on beamforming on my netgear router.  However, I did install a Google Mesh network today on our other Spectrum internet service.  Unfortunately, I have the same issue with the freezes after about 4-5 minutes.  If I use my VPN over either of the spectrum services, iOS works fine.  Unless it is some setting in both Netgear routers and the Google router, I am thinking it is something with the local Spectrum service.  We have Spectrum in our Tampa office so I will try connecting the next time I am up there.  What's strange is my Maestro, SSDR and DogparkSDR all work great on the Spectrum service.  It's just iOS.

    Burch
    K4QXX
  • Scott N8UMW
    Scott N8UMW Member
    edited May 2019
    My Netgear X10 Nighthawk has it. Another member mentioned the implicit beamforming feature, which I went into the settings and disabled. No more chop or freeze on the Wi-Fi. And that may not be the issue here at all. But something similar may be at issue. I have a small house, so I've had no need for features like that anyway, or mesh systems. Maybe these mesh systems use a similar feature that scans at regular intervals to decide which one your device will connect to.
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited May 2019
    The Netgear router I have in my office is a WNDR4500v3 and I don't think it uses beamforming.  I don't see that option in the advanced wireless settings like I do on other Netgear routers.  I am the only person that uses this router/internet service so my iPhone is the only device on the network.  I have no chop or audio drops using iOS for the first 4-5 minutes.  In fact, it works great.  It's like I am sitting in front of the radio at the hamshack.  It just won't work after 4-5 minutes.  If I disconnect and reconnect it runs great for another 4-5 minutes. Really strange that two different Spectrum networks and now 3 different routers have the same trouble.  I have Comcast cable with a netgear router in our Sarasota office and it works fine with iOS.
  • Scott N8UMW
    Scott N8UMW Member
    edited May 2019
    Yes, comcast here also.
  • DV
    DV Member ✭✭
    edited September 2019
    I'm adding to this chain because, I too have an identical problem to others of you with both my I-Pad and my Apple 8 cell phone. I'm using Smartlink on both devices.  I can connect to the radio with both devices via Smartlink, and it seems very stable, but after 4-5 minutes the app freezes and the connection seems to be lost.  Clearing the app and starting it again will give me another 4-5 minutes before it freezes again. The cell-phone will not freeze when I connect to the LAN directly, only when I use Smartlink to connect to the radio.  Also, I can connect my Maestro using Smartlink without a freeze. In all cases the devices are connected to my Netgear AC1200 router that, as far as I know, is not beam forming. Does anyone have a fix for this problem?
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited September 2019
    The only fix I have is to not use Smartlink and use a VPN connection.  I have been having this problem for over a year.  If I am at work and connect to either of our wifis (we have two different networks) using Smartlink, it works for about 4-5 minutes and then just locks up.  It does this on every Spectrum network I have used from Tampa to the Bradenton area.  If I connect via my VPN connection, iOS works fine.  I was listening to the hurricane net today via my iphone and it was working fine with my VPN connection.  After lunch I decided to use Smartlink instead.  Worked for 5 minutes and locked up.  I can connect fine on the same wifi network here at work with SSDR in Windows and everything works as it should via smartlink but not on iOS.

    Burch
    K4QXX

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.