Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

fldigi set up (cat )

edited November 2019 in FLEX-6000 Signature Series
Can anyone tell me how to connect my Flex 6300 to the Cat control on Fldigi as I am stumped! I have the PTT set up as when I open the program the TX goes on and off (shaking hands with PC?) I have downloaded the xml file for power sdr slice A from the rig cat download and installed it in the correct folder but still nothing happens no control it has my head battered Oh by the way I have created a cat  virtual com port too still nothing. Any help would be good using windows 10
thanks Keith M1VHT

Answers

  • edited July 2017
    Thanks for the reply Tim, followed both the video and set up guide to the letter and still no luck it's driving me mad thanks Keith
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    what version of Fldigi?
  • Bob- W5TXBob- W5TX Member ✭✭
    edited July 2017
    Is the Power SDR xml for slice A the same as the SmartSDR xml? Wrong file?
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    They are very different.
  • Bob- W5TXBob- W5TX Member ✭✭
    edited July 2017
    He states he was using Power SDR xml file with 6300. Misstated?
  • edited July 2017
    Hi, fldigi is version 4.0.7 the latest I believe? operating system is windows 10. rig description file is SmartSDR_SliceA.xml.   baud rate is 56700. The cat control on HRD works fine so not sure what is wrongimage
  • edited August 2017
    above is a screen shot of my cat control settings thanks Keith 
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    I have heard that there was a program change with Fldigi 4.0.7 that breaks RigCat if the com port stopbit is set to 1.  This is the way SmartSDR (and PowerSDR for that matter) have been configured since the beginning of time.

    You can use a text editor to open the RigCat XML for SmartSDR and modify the default value of 1 to 0 in the tag pair as shown below:  

    <STOPBITS>0</STOPBITS>

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    I just took a look at the Fldigi Yahoo page and many people are complaining that 4.07 broke RigCat and are reverting to v4.0.6
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    I have just confirmed that multiple versions of Fldigi up to 4.0.6 are working with the available RigCat XML files for both PowerSDR and SmartSDR and version 4.0.7 does not.
  • AA5JD JohnAA5JD John Member ✭✭
    edited July 2017
    Thanks Tim! Changing the STOPBIT value to zero fixed my Fldigi 4.07. Yippee!
  • Jay NationJay Nation Member
    edited May 2019
    image
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    I have it on good authority that this bug is being looked into and I am sure it will be corrected in short order.
  • Adde TjernbergAdde Tjernberg Member ✭✭
    edited July 2017
    Haha, so cool! I have the exact same problem right now. And found this info... posted 3hrs ago! TU! /73
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited August 2017
    Don't get used to the workaround.  I just finished some validation testing for Fldigi v4.0.8 and the RigCat bug looks to be fixed.  Once the new version comes out, you will need to change the stopbit back to 1 because "0" is not a valid option for that parameter.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    See my response below to AA5JD John.  The workaround is temporary.  Fldigi 4.0.8 resolves the issue.
  • edited July 2017
    Success at last, used v3.23.15 everything fell into place without any problems. Thanks to all who replied and helped me. Will be interesting to know when the bugs are fixed in the latest version of Fldigi
    regards Keith M1VHT 
  • RiaRia Member ✭✭
    edited November 2019
    I ended up using FLrig. Works well... I generally find fldigi to be a pain in the neck (pain is actually much lower...) when it comes to rig control but once you get it working just virtually apply superglue to the controls. :\
  • KC7ESKC7ES Member ✭✭
    edited August 2017
    Tim-Running SSDR CAT v 2.0 and Fldigi 4.0.8, but Fldigi doesn't always "see" CAT port 7. I have to shut down both CAT and Fldigi, relaunch both, then it sync's up, but a pain to have to do this. Are others having issues with v2 and Fldigi?
    Thanks!
  • edited August 2017
    I always assumed it was because I am dumb but I have also viewed Fldigi CAT as a "pain".  I eventually get the right config to make it work but there is something about it that is counter-intuitive especially if trying a separate CAT port with ye olde PowerSDR. Using VSP's with DDUTIL makes it less of a pain but them you had to deal with multiple issues from disappearing  virtual serial ports every now and again. 

    Andy K3UK
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited August 2017
    I am running 4.0.9.8 and I am not having any issues with RigCAT.

    Are you using the latest version of the SmartSDR_SliceA.xml file?
  • KC7ESKC7ES Member ✭✭
    edited August 2017
    I've found an issue, not only with fldigi but with AC Log also communicating with the port on SmartSDR CAT. SSDR CAT reports the the application are attached to the correct com ports, but they are not polling correctly. Solution is to shut down SSDR CAT, then start it again, then all programs communicate correctly. Is there a means to un-install just the SSDR CAT and re-install?
  • edited January 2019
    Tim, not working for me in January, 2019. Both the narrative and the video are now outdated to my eye. For instance, the video shows us DAX ver 1.2.17.0 while my current ver is 2.2.8.
    Sooo, I have established DAX audio. My problem is CAT rig control for the latest FLDIGI ver 4.0.18. I've downloaded and installed the file SmartSDR_SliceA.xml from W1HKJ, confirmed a free port, COM7. Initialized. No rig control.
    SmartSDR ver 2.2.8 operating with Windows 10 latest update. Guesses?
  • Jay NationJay Nation Member
    edited January 2019
    David 
    You've resurrected an old zombie thread about a slightly different and rather temporary SmartCat/Fldigi problem, If Tim w4tme. fails to respond to your post here, I can help you out, in the #FlexRadio IRC chat channel.image

        #FlexRadio IRC chat

    For real-time discussions

            SDRgadgets

    User-created documentation.
               Volunteer!!

             73, Jay - NO5J

  • edited January 2019
    Jay, you are too kind. I’ll take your advice with pleasure. Shall we set a time/date to IRC chat? I’m PST in LA. Early mornings, or late afternoon through early early evenings good for me. Many thanks — I’m close, but not there yet. David A. KK6DA, Los Angeles.
  • Jay NationJay Nation Member
    edited January 2019
    David
    I'm mostly available from around noon CST to Midnight CST, If you don't get a response in the IRC channel I may not watching it closely enough, I get audible notifications on any channel activity. Try to hang around long enough for me to respond. I'll make a metal note to keep an eye out for you when you join.

        #FlexRadio IRC chat

    For real-time discussions

            SDRgadgets

    User-created documentation.
               Volunteer!!

             73, Jay - NO5J

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.