Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartLink Servers Down - Again?

AE2AAE2A Member ✭✭
Cannot log into any remotely connected SmartLink devices.
Is anyone else having this problem?
I turned in a trouble ticket, but still having issues.

Comments

  • edited July 2018
    Yep...went down about 45 minutes ago...blinked on and off a couple times since.
    I need to get my plan B in place. 
  • WayneWayne Member
    edited July 2018
    PLAN B - NOT CLOUD BASED - NOT MICROSOFT BASED!
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2018
    Thumbs up on that.
    Centralized services that enable you to actually use your product are problematic at best.
    The reliability here has not been great.   To achieve "5 nines" uptime, would require that FRS
    place several different smartlink servers in geographically different locations, with auto-round-robin
    DNS to make sure a user can connect with whatever one is still online.   This is how many large
    corp high-volume web servers are done;  they have two or three regional servers, with automatic
    routing when you try to connect from your web browser.

    I will explore the personal VPN articles that people were playing with before SmartLink.

    Neal

  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    I never noticed the outage, since my connection was initiated this morning before the outage, so the rig kept sending.  But when I saw this post, I disconnected and tried to reconnect.  It showed the radio "not available."  What I discovered was that I needed to log back into SmarLink from my office computer.  It was no big deal, but I don't know how long the server was down, because it didn't dump my connection.

    Ken - NM9P
  • bahillenbahillen Member ✭✭
    edited July 2018
    It’s my understanding that once FRS Server routes your connection FRS is out of the loop. What is the experience with drop outs that disconnect you from your radio. On my local remote I seldom lose the connection. Weeks. Anything that improves remote reliability is a good move. With the Flex capability remote operation of our stations will be widely used. As a hobby we are involved with developing our capability at a very fast pace. I think there are alternatives to networks that are private and may meet more stringent users. VPN. There are a lot of smart hams in the Flex community and I am impressed with the ideas and dynamics of the exchanges. Our Cable networks from Comcast, AT&T and others are not without their down time and service interruptions. For an antenna farm maybe dedicated lines would be appropriate. This is an exciting time in amateur radio. 73 Bill W9JJB
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2018
    The FlexRadio SmartLink server is only involved in passing an authenticated client the necessary information for it to make a direct connection to the FLEX-6000.  Once that has been done (selecting the radio from the chooser), the FlexRadio SmartLink server is no longer involved in the SmartLink remote access.  None of the data that flows between the client and the radio traverses the SmartLink server.

    If you have connectivity or network problems after the SmartLink connection has been made, then the issue is in the network path (client endpoint connection (router, local network), the Internet or the radio endpoint (your router, local network) and not the SmartLink server.
  • N8SDRN8SDR Member
    edited July 2018
    Things you can test to see if its your ISP, or something internal perhaps to your network.
    1. Ping your ISP's hand-off from a device on the same subnet. (Confirms that there are no L2 problems between you and your ISP).
    2. Ping your ISP's hand-off from a device on one of your internal subnets. (Confirms that you have no routing/security issues between your internal network and your ISP)
    3. Ping an IP in your provider's network. If you can't find one that's publicly listed, or the helpdesk won't give you one, do a traceroute to something in the internet, and use the second or third hop. This confirms that routing between you and your ISP is configured correctly.
    4. Ping an internet IP. I normally use 9.9.9.9 or 149.112.112.112 Quad- Nine secure DNS servers. This confirms that routing from your ISP to the specific IP you've pinged is correctly configured.
    5. Ping an internet domain name. This verifies your/your provider's DNS configuration is correct.

    If steps 1 or 2 fail, it's most likely a problem on your internal network.

    If step 3 fails, there would appear to be a problem in your provider's network. Note, though, that if you get no response at all then your ISP may have simply blocked ICMP to/from their infrastructure addresses.

    Step 4 failing indicates a potential problem between your ISP and one of their upstream providers.

    Step 5 failing indicates issues with name resolution.

  • edited July 2018
    Hello All. I operate remote all the time...I have no choice. My station is in MN I live in FL. I log into SmartLink several times each day. [car patio office etc] There is no mistaking the authentication issue when it happens. I understand Flex wanting to authenticate users. Perhaps there's more than one way for them to skin that cat. I'd be grateful if there were a plan B. 
    Cant wait for the "invisible yagi and tower" to hit the market so I can have a station at home again. ;->

  • Tim OsborneTim Osborne Member ✭✭
    edited July 2018
    I had a problem earlier this week after many hours of trouble-free Smartlink operation from home and work to my remote shack.  I was able to do all the kind of stuff N8SDR points out above, so I assumed it wasn't my radio's internet connection.  I use Teamviewer to tunnel into the local (to the SDR) PC and the local SmartSDR could see the radio, but showed the Smartlink setup couldn't reach the server.

    Turns out I had to power cycle the 6400.  

    Moral of the story: I don't know why the 6400 got confused, but I sure am glad I installed an IP relay/remote power device so I could do it from 20 miles away.  

    Global Cache iTach IP2CC, totally worth the money, requires just a little bit of manual reading (sorry).

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.