Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

VPN with 2.3.9 now uselessly

HardyHardy Member
Up to 2.2.8 all was ok.
With 2.3.7 ist getting worse ...
With 2.3.9 VPN is uselessly.

All 10 seconds a break of approx. 3 seconds arises without audio or waterfall.


Comments

  • Burch - K4QXXBurch - K4QXX Member
    edited July 2018
    I am using my VPN with my Apple Mac and it is working fine here.  Made several FT8 contacts this morning using DogparkSDR from the office.  I am running 2.3.9.
  • K6OZYK6OZY Member
    edited July 2018
    I am using SoftEther to VPN to my house from my work 5+ hours every day running on my MacBookPro in VMWare Fusion, and it's rock solid on 2.3.9.   I keep FLdigi listening on 14072 for exotic digital modes. 

    I'm 99.99% sure that it's not the software or radio.
  • Mike_VE3CKOMike_VE3CKO Member ✭✭
    edited April 2019
    Have you looked at your internet connection somewhere perhaps getting worse. More kids home for summer doing what they do these days. Remember a kid's life before streaming/gaming, before sitting in front of display hours on end. It was called playing outside.
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2018
    :-)   So,  you actually "work" the other 3+ hours?   :-)

    Pity your poor employer...  (But I like it)  :-)
  • K6OZYK6OZY Member
    edited July 2018
    Background noise!
  • WX7YWX7Y Member ✭✭
    edited June 6
    Works fine here too, using SoftEther VPN
    I agree with Mike sounds like a network problem some where.
    73's
    Bret
    WX7Y

  • K6OZYK6OZY Member
    edited July 2018
    Hardy,

    Can you tell me the OS and version you are running?  Windows 10?  What build?  You can determine that by clicking start and typing "winver" and running that. 

    I think I may have found a bug..  It's an MS bug not a Flex bug.


  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited April 2019
    I have found that 2.3.9 on my Softether VPN has been rock solid.   No issues at all and I run mine 7x24 on a low band 1mb/sec upload from my remote base.

    Like others have said, you might have to look elsewhere.  What do your bufferbloat numbers look like on both sites?  That is the first place I look when things start to fall apart.   When they do and I confirm there is nothing else on my network, I call the ISP.

    In the last case (Rogers -- Very big in Canada), they were on the phone with me for 4 minutes and then thanked me for finding an upstream hardware issue that was affecting the entire neighbourhood.  They had it fixed in 2 days.   Your ISP will also have network issues and most users can't tell since most everything else is buffered in some way.  Not the same for HF radio operation.

    Mike va3mw

  • N8SDRN8SDR Member
    edited July 2018
    And if your unaware what Bufferbloat is or how to run a test to find out  how yours is follow this link: https://www.bufferbloat.net/projects/bloat/wiki/Tests_for_Bufferbloat/
  • Neal Pollack, N6YFMNeal Pollack, N6YFM Member ✭✭
    edited July 2018
    So, just learning;   is a "B" rating good enough on Buffering?  Here are my test results;
    http://www.dslreports.com/speedtest/35862351
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited July 2018
    B is really good.  F is really really bad.  
  • Burch - K4QXXBurch - K4QXX Member
    edited July 2018
    I actually have the opposite problem.  When using my iPhone in the office with Smartlink, it will only run for about 5 minutes and then the audio and waterfall stop and all I can do is close SmartSDR.  If I use the VPN on my iPhone and then connect to SmartSDR, it will run for hours with no issues (except the occasional audio drop).  The internet connection I have isn't great (15 down, 1 up) but the VPN works great vs Smartlink.  In our Tampa office, both Smartlink and the VPN work fine but the internet connection there is 30 down/ 30 up.

    Burch - K4QXX
  • Mark G ThomasMark G Thomas Member ✭✭
    edited July 2018
    Hardy, I know changes were made in v2.3.9 to work around network connections that do not handle packet fragmentation properly. I believe an update was necessary to DogParkSDR to remain compatible, but there may be other ramifications of the way the fix was implemented. I'm pretty sure Tim or someone from Flex recently posted about this affecting DogParkSDR users. I suggest confirming you are running the newest DogParkSDR version and reaching out to Don Agro. He provides excellent technical support. I know FRS is trying hard to please as many of the people as much of the time as possible, while keeping things as simple as possible, but it seems to me like more software switches to turn on and off optional networking functionality that might impact users differently would benefit us, and not make the product harder to use so long as defaults are reasonable.  -Mark KC3DRE
  • K6OZYK6OZY Member
    edited July 2018
    I'm on Cox gigabit 1GBps down / 30Mbps up using a pfSense SG-2440 router.  Normal speedtest.net shows my full Gbps, but this is only showing ~650-750.  This is not unusual for gigabit testing.


    image
  • K6OZYK6OZY Member
    edited July 2018
    I just tried SmartSDR  v2.2.8 (before fragmentation fix) & 2.3.9 (after fragmentation fix) on win10 v1803, win 10 v1709 both inside VMware and native on bare metal (no emulation) using both the integrated Win10 VPN client to my SoftEther VPN server and the optional SoftEther Win10 Client that supports multiple connection bonding.  All combinations worked fine.

    Work connection is gigabit fiber (1Gbps up and down) from Cox to my home Cox connection 25 miles away.   I cannot reproduce any issues.
  • N8SDRN8SDR Member
    edited July 2018
     Fioptics here with fiber connection (FTTP) Fiber to the Premises 100 down / 40 up,  my down is usually a little over the 100 meg, (not complaining)
     http://www.dslreports.com/speedtest/35864586 
  • HardyHardy Member
    edited July 2018
    My Setup:
    Windows 7 Enterprise 32bit / Windows 10 LTSB 2016 32bit / Windows 7 Enterprise 64bitVPN: Windows build in PPTP and Softether.
    Testet 1:1 with 2.2.8, 2.3.7 and 2.3.9:
    Up to 2.2.8 anything worked perfect.With 3.2.7 VPN-PPTP doesn't work any more (no watherfall at all window width)With 2.3.9 Also Softerther doesn't work any more. All 3-7 second an adio and waterfall dropout for 1-3 seconds.
    In all cases Smarklink does work BUT I have to use full tunnel VPN to control rest of station.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.