Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Cant connect to radio through smart link

2»

Comments

  • Mike  W1BFA in MaineMike W1BFA in Maine Member ✭✭
    edited December 2019
    yes...  on the Ipad it never fully commits although during the setup process it appears to have the connection enough to drop another user when prompted.  That's really as far as it gets.  The Maestro really wants to work but can't seem to pass the meta data for the panadapter or something.  fun puzzle huh?

    the hobby changes over the years but the fun of solving the puzzles stays the same :-)

  • KD8KKD8K Member ✭✭
    edited April 10
    I am having the same problem. I am attempting to connect using 2 different IPad's on 2 separate networks, same symptoms on both. It discovers the 6600, the window displays the 6600 as an available Smartlink connection but when I select the 6600 and attempt to connect, it will eventually time out after approx a minute with a  "No Response from Smartlink Server Error", They had been working and both stopped working at the same time.  SmartSDR for Windows works fine at both locations/networks.


  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited May 2018
    Hi John

    This is where it gets harder.  If it works on your local network and does not work remote, then the problem is in the "internet".  Something outside of Flex is stopping the Vita49 packets.

    Mike

  • KD8KKD8K Member ✭✭
    edited May 2018
    A local connection works when using direct connection (Not Smartlink) Smartlink does not work locally when using SmartSDR IOS. I do not believe it is an ISP problem as SmartSDR for Windows works fine at the remote location using the same wireless network. I assume SmartSDR for Windows uses the same Vita49 packets as SmartSDR for IOS? If the ISP is blocking the packets I would expect both versions (IOS and windows) to not work.
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited May 2018
    I chased a similar problem for a long time and it was solved by me doing 1 of 2 things.  1, I changed routers and it worked.  On the other test, on a more commercial router it was a Hardware setting on the NIC card in the router that fixed it.

    You also might want to check (and you might have and I missed it) that the uPNP port forwards in the router at the radio end does point to the actual IP address of the radio just in case the radio IP address changed.  I have seen that happen too.
  • KD8KKD8K Member ✭✭
    edited May 2018
    Thanks for the info Michael, uPNP is off, I will double check port forwards.  Does SmartSDR for IOS require different ports or protocols then SmartSDR for Windows? At this point, I am not sure why SmartSDR for Windows works fine and SmartSDR for IOS does not.

    Thanks

    John
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited May 2018
    SmartSDR and SmartSDR for IOS use the same ports.  


  • KD8KKD8K Member ✭✭
    edited May 2018
    Would it be correct to assume that the firewall configuration is correct if Smartlink on SmartSDR for Windows works? Is there any specific changes that need to be made to permit SmartSDR for IOS to work?
  • WW1SS - SteveWW1SS - Steve Member
    edited April 10
    I am having the same issue here Except I can connect via ipad but not my Iphone. I can also connect if I use my Iphone as a hotspot and connect my Ipad to the hotspot. Iphone will not connect by itself using the app.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Yes.  If you are remote from the radio and connect with a PC running SmartSDR for Windows or a Maestro via SmartLink and you cannot connect using SmartSDR for iOS via SmartLink, then the SmartLink configuration at the radio end is good.

    Make sure you are using the latest version of the iOS app and that you have logged into your SmartLink account by going into the iOS app Settings and tap SmartLink Status.  I know the latest version of the iOS app works because I am currently connected to a SmartLink radio as I type this on my iPad
  • KD8KKD8K Member ✭✭
    edited May 2018
    Thanks Tim. I am on IOS 11.3.1 on a IPad 2018. This also occurs on an IPad Air. Smartlink status seems to complete successfully, it shows me as logged in, with an expiration one minute after the current time. There has got to be a reason why this is occurring for some and not others. I am using Google authentication, could it be related to the authentication method? Thanks, John
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    It is possible that this is a Google authentication issue.  I use just an e-mail account (that is maintained by Auth0) and it is not having a problem.  Is it possible to create an e-mail type account, register the radio to it and give it a try?  Also, my iPad version is 2.4.1 for your reference.
  • KD8KKD8K Member ✭✭
    edited May 2018
    I re-registered the radio using an email address instead of Google authentication, it still will not connect. Smartlink had been working quite well using IOS. I used it to connect to my 6500 and then 6600 since it’s release., and have had no problems until recently. It appeared to stop arround the time of the last SmartSDR IOS update, but I cannot say for sure it was exactly that time. There have been no changes that I can think of , same firewall, same ISP. It’s occuring on 2 different IPads at 2 different networks, and SmartSDR for Windows works at the same locations. I may try a wire shark capture when I get a chance. Thanks, John
  • WW1SS - SteveWW1SS - Steve Member
    edited May 2018
    Tim,

    What is an Email account I can register with that uses Auth 0 . I use google and Icloud now
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    When you set up a SmartLink account, you have three options; email, Google or Facebook.  If you choose email, then the account credentials are directly associated with Auth0 rather than using FB or Google credentials that get passed to Auth0 to access a SmartLink account.

    Please note that from a SmartLink account perspective, logging on the SmartLink using either of these three methods are independent of one another.  Meaning, if you log in using email, and register your radio, when remote, if you use a different method (Google or FB), you will not access your radio because these appear as different accounts - not one account with three different ways to log into it.
  • Mike  W1BFA in MaineMike W1BFA in Maine Member ✭✭
    edited June 24
    I have always used the email verification. Really no sign that it is an authentication issue. I tried the IPad again today at a different location through a different provider and same result. Odd that the Maestro lost functionality at seemingly the same time. I should have some play time tomorrow. Any more suggestions? I believe I have tried everything in this thread. Thanks! Mike W1BFA
  • KD8KKD8K Member ✭✭
    edited May 2018
    I did get Smartlink on IOS working. The 6600 is now configured using password authentication and the IPad is configured using Google Authentication. For some reason, using that combination appears to have made it work. I tested Smartlink using SmartSDR IOS at a remote site and it connected fine. Thanks everyone for your assistance with this.


    John
  • KD8KKD8K Member ✭✭
    edited May 2018
    An update to my previous message... On the next reboot of the 6600 smartlink displayed as unregistered. I reregistered using email authentication, it completed successfully. After shutting off the 6600 and restarting, it displayed as unregistered again, so I registered using google authentication and that seemed to keep after several reboots of the 6600. I think the issue I was having with smartlink was due to something going wrong with the authentication process, perhaps not completing successfully even though the prompt indicated it did, not sure. It does appear to be working now with Google Authentication.

    John
  • Mike  W1BFA in MaineMike W1BFA in Maine Member ✭✭
    edited May 2018
    I finally got a chance to go through this piece by piece and found when I did the router change to manual port forwarding at one point, I evidently hadn't saved the setting for 4993 so I was only half working  :-).  I fixed that and took a ride to camp this morning and fired up the Maestro and we had liftoff!  After playing with that a few minutes I started the Ipad and that worked fine as well.  Mission accomplished.  Thank you for all the help and education.   Mike


  • Dave WB7WHGDave WB7WHG Member
    edited September 2018
    I am having the same problem with email verification- it worked fine 3 days ago, but now it won’t connect - the SmartLink status looks OK, shows my call, and the SN of the 6300. Am I supposed to have manual port forwarding on the router, and IP Ver 6 set, on my 6300?
  • edited December 2019
    Scott I know I am late to the party (just getting stuff back and running after my health issues) I know this post if old but it just solved my problem (I hope). I unregistered the rig (finally got the 6400 up and running) and then re-registered it. now its working on my iphone on cell data and the WiFi is turned off. Its great to hear this through my hearing aids, I have never been able to understand HF this good even when I was much younger. If you get bored sometime we are trying to get a group of guys playing on 6 meters in the early evenings. I have to get up daily at 6am to take my Grand Daughter to school so the late nights are a thing of the past for me.......

    Thanks again Scott!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.