Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Cycle Power On/Off Twice before Connecting

To connect to my Flex-6500 I have to cycle the power twice. When I first turn the radio on I can see the radio icon in Smart SDR, but when I click on Connect the software locks up. I have to close SmartSDR and then cycle the radio power and then it will start. I have to do this everytime now for some reason.

Comments

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    Is there a wifi "link" in the network path between the PC and the radio?
  • edited October 2019
    There is but I also get the same problem on a computer that is not on a wifi link in the network path.
  • edited October 2019
    Let me be more precise: The radio is in my garage apartment on a bridged router with the main house where the internet connection is located. I have a computer in the main house and one in the garage apartment. The computer in the garage apartment and the radio are connected to the bridged router with cat5. SmartSDR on the computer in the main house and SmartSDR on the computer in the garage apartment have the same lock up issue.

    I am using SmartSDR 2.1.33 and also have registered with SmartLink. I only say this because after I close SmartSDR after the lock up, I sometimes get the SmartSDR login screen pop up and it says I'm unregistered. Once I reboot it says I'm registered again. Closing SmartSDR without a reboot does not help.
  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited April 2018
    Sounds somewhat like what happens to me.  I am connected by wifi  through my pc using a network bridge.  What I finally figured out was to hover over the radio in SmartSDR before I click connect.  The IP address will pop up.  If I see that the rig is not showing up at the correct IP address, I know not to hit connect. That just gets me into a vicious cycle.  What reliably gets my rig started is to disconnect my internet using the little network and internet connections icon in the lower right of the screen. Then I start up my rig and immediately restart my network connection.  Almost always that does the trick.  What I am doing made sense to Dudley, but I can't remember what the explanation was.

    Hope this helps.
    73
    Bob, WK2Y

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    Bob & Mark -  I am going to assume your home networks are on the 192.168.x.x network since that is the most commonly used private IP address space.

    If you boot the radio and start SmartSDR, when the radio shows up in the chooser, place your cursor over the radio but do not click on it.  It will show the IP address of the radio.  If it is not in the 192.168.x.x of your home network, but instead shows 169.254.x.x, then the radio failed to get an IP address from your DHCP server (this is usually your Internet firewall router).

    So if the radio's network path to the DHCP server has to traverse over a wireless bridged link, then what is happening is that the establishment of the bridged connection through the wireless link has not happened since it takes a little time, but the radio is sending its DHCP request anyway because it is on an Ethernet network and sends the DHCP request immediately after the network interface comes up. 

    Without the wireless link for that new device on the network being fully established, the DHCP requests sent by the radio never make it to the DHCP server so the radio believes there is no DHCP server available for it to get an IP address.

    Since the radio believes that there is no DHCP server, it assigns itself a link-local IP address in the 169.254.x.x network.  When you reboot after this failure, the radio boots faster than the MAC address ages out of the wireless bridge's MAC address table, so the wireless link does not have to go through a re-establishment process tp pass traffic.  In this case, the DHCP DIscover packet, reaches the DHCP server, it assigns the radio an IP address in the 192.1.68.x.x network and all is well.

    I have debugged this issue many times and with packet traces provided by Wireshark, I see the DHCP protocol failure with this type of network configuration. 
  • edited October 2019
    I've yet to stump you guys on any issue...well done Tim!

    I'm not a WiFi guru, but I've been learning a lot over the past two weeks trying to link my ham shack in the garage apartment to the modem/router in the main house so that I can reliably remote into the radio from anywhere. I've tried numerous techniques, and the bridge seems to be the best solution other than running a cat5 wire back through the walls of the main house and burying another 150ft of cat5 to the ham shack. Its not an ideal situation, but the best I've come up with so far. If anyone has a better solution, please let me know.

    Is there anyway to speed up the bridged link between the DHCP server and the radio, or slow down the radios DHCP request without having to reboot the radio each time? I would have thought that having a static IP address on the Flex using SmartLink would have solved the issue by locking the IP address.
  • WX7YWX7Y Member ✭✭✭
    edited June 6
    I have mine set to a static address to eliminate the DHCP problem because the Radio always stays on my LAN IP.

    73's
    Bret
    WX7Y

  • Bob Gerzoff, WK2YBob Gerzoff, WK2Y Member ✭✭
    edited April 2018
    Thanks Tim.  I'm saving that answer for future reference.  
  • Oz DiGennaroOz DiGennaro Member
    edited April 2018
    Run the cable!  Cheap and it always works.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    ....slow down the radios DHCP request without having to reboot the radio each time?

    The last I looked, it makes three attempts to reach a DHCP server before resorting to a link-local IP address.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2018
    Better yet, run fiber.  I don't advocate running copper in the ground or overhead unless you live in a place where lightning never occurs.  I learned this in my early days of networking when lightning struck near (telephone pole) a buried conduit where we had 10Base5 (thick wire Ethernet) going between the hospital and the offsite materials warehouse.  It blew out every DEC "vampire tap", the DEC bridges connected to it and about half of the PCs (IBM XTs and ATs) connected to the bridges.  A very expensive mistake. 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.