Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

flex Control

flex control: I swear I am just about ready to throw in the towel. Flex 6300, logitech keyboard and mouse. windows 10. Three main problems: 1. On cw when using the keyboard for very fast cw, sometimes the keyboard will just quit.Maybe it is rf since it is a wireless keyboard though the mouse always works. 2. Flex control about two weeks old now. Under settings on 6300 a window comes up that says flex control not detected even though flex control will work sometimes. Port 102. Was thinking about getting a maestro but if can't get the flex control to work, sure not going to spend that kind of money for a maestro.I have tried changing ports, plugging flex control in beforfe turning on radio (6300) and after turning on radio. Kind of frustrated. v2.1.33 Bob K

Comments

  • Bill EnglishBill English Member
    edited January 24
    That’s odd, I have a 6300 and the Flex Control. It’s never caused me any problems. Extremely useful addition. You do have it plugged into the PC, right?
  • KF4HRKF4HR Member ✭✭
    edited April 2018
    Reference your keyboard problem.  Try temporarily swapping out your wireless keyboard for a wired keyboard and see what happens.  It might be a wireless connectivity issue.

    If you have your Flex Knob plugged into your Flex 6300, plug it into a USB Port on your PC.

    Unless I missed it, I don't see your 3rd main problem.
  • Michael CosloMichael Coslo Member
    edited April 2018
    I'm calling two problems. First is RF getting into the computer.  Put some good ferrites on the mouse and keyboard. 

    Second is check your ports in device manager. See if the knob is seen. If you aren't certain, pluc and unplug and see what happens. Next possibility is that maybe you plugged the flex control knob into a different USB port? Windows does some funny things with drivers
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited May 2018
    Since the last Win 10 update, my FlexControl has also become mostly inop. If I plug it into a different USB port on the PC it will briefly work, then quit. It ran for 3+ years with no problems on 1.xx SSDR, and 2.xx release prior to the current one. I’m highly suspicious of a MS update issue. I’ve replaced the driver and tried changing the port number all with no joy. Apparently there are only a few of us having this problem.
  • GeraldGerald Member
    edited March 2019
    My exact problem too. I changed to an old wired IBM original keyboard. If your antenna is too close to your radio computer and other problems my result from RFI. My computer would reboot.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited May 2018
    Sorry to hear you are having issues.  As others have speculated, I think you have RFI problems.  The above suggestions are reasonable to correct the issue.
  • AA0KMAA0KM Member ✭✭
    edited April 2018
    image
  • WayneWayne Member ✭✭
    edited June 2018
    Win 7 or 8 or 8.1 the only way to go ...
  • Michael CosloMichael Coslo Member
    edited April 2018
    And do not forget, Microsoft helps us by often resetting these settings when they update. 
  • Michael CosloMichael Coslo Member
    edited April 2018
    Well - Win 7 anyhow. 8^)
  • Michael WheatleyMichael Wheatley Member ✭✭
    edited June 2019
    Your problems could be related to USB connections.  Make sure your devices are connected to USB ports on the back of the computer (not the front) or to a good quality powered USB hub which in turn is connected to a USB port on the back of your computer.

    Michael
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited April 2018
    In my case, no RF is required to cause the problem. Just turn on receive and never transmit. The FlexControl just stops working a few seconds after starting. Everything in this setup has worked perfectly for 3+ years with a 6500 and 1.x software. Worked fine with the new 6600 and the previous release of 2.x SSDR until a couple of weeks ago. This is not RF related on my setup.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    I have had fewer RF problems at my station since I went to a wireless keyboard/mouse combo instead of a wired setup.

    I have had few problems with FlexControl in about 5 years.  But very occasionally, as Michael said, Windows fouls it up.  I have usually had luck with disconnecting it, rebooting the computer, and then plugging it back in. (Sometimes I needed to repeat that)  I then sometimes need to open Device Manager and reassign the port to a higher port (100 at my station) .

    There was one time that I needed to reinstall a corrupted FlexControl Driver.

    Again, these problems have happened only about once a year.  Usually when I was participating in the fast-release Windows 10 testing program.  I have since quit that because I lack the time to do it justice.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.