Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR on LAN PC "unable to connect to the radio. Please try again"

Matt NQ6N
Matt NQ6N Member ✭✭
edited April 2019 in SmartSDR for Windows
First some background information: 
  • I am able to ping the IP of the radio from the same PC
  • I am able to connect to the radio and interact with it using netcat on port 4992 from the same PC
  • I am able to connect to the radio using SmartLink via both SmartSDR and SmartSDR IOS remotely. 
  • Windows 10 firewall is completely off on the PC.
  • I restarted both the PC and the radio and the problem still occurs. 
  • Previously, SmartSDR had hung or crashed a few times due to issues with DAX TX audio no longer working after remote desktop connect/disconnect. I operate the station remotely via SmartLink for SSB/CW but via Remote Desktop for digital modes.  I'd been using Chrome Remote Desktop and had been testing Microsoft RDP. 
Any suggestions for further debugging?  

73,
Matt NQ6N

Comments

  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited April 2019
    Hi Matt

    That is a good one.  You have hit all the obvious stuff (nice writeup btw).

    Can DAX and CAT connect?  

    I would uninstall SmartSDR and reinstall it.  Do other versions work and connect from the PC?

    Mike

  • Matt NQ6N
    Matt NQ6N Member ✭✭
    edited March 2018
    Mike -- 

    Thanks!  DAX and CAT cannot connect.  I reinstalled SmartSDR and now when I type my credentials in to log into SmartLink it does not successfully log me in, even though the password is correct.  

    Previously, before the reinstall, I logged out of SmartLink and was unable to log back in.  The password was correct, it was as if it was accepting the password but was not successfully storing a token that I had successfully authenticated.  This same behavior is happening now.  I am able to log in successfully using those same credentials from other PCs. 

    Also, after reinstalling SmartSDR the radio does not show up as having been discovered on the LAN, but I can still connect using netcat and ping the IP. 

    I think SmartSDR is supposed to "discover" the radio on the LAN even if I have not logged in, but it is not discovering the radio now. 

    When I click the "Log In" button it brings up a window with a SmartLink login box in it, where I type the password.  If I type in an incorrect password, it tells me the password was incorrect, but if I type in the correct password it closes the window but still shows me as not logged in and does not show any radios in the list. 

    Thanks for the help, just let me know what to try next.  

    73,

    Matt NQ6N
  • Mike-VA3MW
    Mike-VA3MW Administrator, FlexRadio Employee, Community Manager, Super Elmer, Moderator admin
    edited March 2018
    Hi Matt

    We are having a SmartLink authentication issue.  We are working on that now.  So, nothing for you to do on that end at the moment.  We can set aside SL for now based on that.

    If SmartSDR doesn't see the radio, then for some reason the software isn't seeing the L2 Vita 49 packets being broadcast by the radio.  That is how it is discovered.   If you can think of any reason why we can't see the broadcast let me know.  

    Beyond that, we may have to convert this to a helpdesk ticket.

    Mike
  • WK2Y
    WK2Y Member ✭✭
    edited March 2018
    This sounds like the problem that I was having right after my upgrade to 1709.  I finally figured out that one should never click the connect button on SmartSDR until you are certain that the rig is looking at the correct IP address.  What I have to do now is after I power up my rig, I will see, by hovering over the rig in the SmartSDR panel, that the IP address is 169.###.###.# or something like that. That is some type of local link which will not connect to your LAN.  I then shut down SmartSDR and power cycle the rig. Every time I do this, it finds the correct IP address on the second start up, and I can then just click connect in the SmartSDR panel.

    Hope this helps.
    73,
    Bob, WK2Y


  • WK2Y
    WK2Y Member ✭✭
    edited March 2018
    Agh.  I forgot an important detail.  When the rig (not SmartSDR) powers up the first time, it disconnects my internet.  I need to reconnect the internet before I power up the rig for the second time. Obviously,  if there is no internet connection nothing will work.  I wish I could figure out why starting the Flex disconnects the LAN.
    Bob
  • Matt NQ6N
    Matt NQ6N Member ✭✭
    edited March 2018
    OK I double checked my router settings and rebooted it.  It looks like the configuration was not applying properly because I'd installed a few add-ons and had filled up the writable storage.  

    I would have noticed that something was wrong sooner, but since I'm a new user of SmartSDR I didn't realize that the radio listing after discovery should have indicated that there was a problem with LAN connectivity. 

    Thanks to Mike and Bob for the help. 

    73,
    Matt NQ6N

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.