Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smartlink Login

Rich McCabeRich McCabe Member ✭✭
Not sure if there are issues with the Smartlink server or I am doing something wrong.  Flex sent me a 6600 to replace my failed 6600m.  It arrived today and everything seems to be working OK so I want to register it and get remote working.  I had logged into to the first 6600 as it showed my gmail avatar but I did not attempt to use it remote.

So I am trying to login to Smartlink now and it just returns back to the login box. I assume the password is same as my Gmail account but sent a password reset request which never came.  I tried to add a second dedicated Gmail account but same results.

Rich

Completed · Last Updated

«1

Comments

  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited March 2018
    Rich - try registering without depending on Google. Some folks have been reporting the Google authentication as inconsistent. I set mine up separately from Google and all has been well. GL and pse report back. 73 Steve K9ZW
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    Steve,

    Thanks for response.  Just created an account using a non Google email and got the Verify your account email and clicked the verify link. Received the "Your email was verified. You can continue using the application" message.

    Try to log in and does the same thing which takes me back to the login box.  Tried it from my shop computer and same problem.  Opened my notebook to find it was still logged into the original account. So I logged out on that machine and it wont log back in now either.

    Rich
  • WX7YWX7Y Member ✭✭
    edited June 6
    Try logging the radio out and re-login in with the non Google account you just created. You will need to be in front of the radio to use the PTT to log it out and back in! Bret WX7Y
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    I have even tried power cycling the radio, rebooting, etc. Wont hold the login.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2018
  • Rich McCabeRich McCabe Member ✭✭
    edited April 2019
    Thanks Tim. No big deal. You are supposed to be resting.

    Rich
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2018
    I am resting and making good progress healing from surgery. 

    This is a serious issue and I wanted to make sure the Community was made aware that we know about the problem and are actively working on a fix since this is a global issue.

    Time to stop typing.   It took me 15 minutes to write those 2 paragraphs with only a left hand :-O  73
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited March 2018
    And, he typed that all with 1 hand!

  • edited March 2018
    Hi,

    after one day, SmartLink login still not working. Any estimate when the the serivce will be available again?

    73
  • Eric W1NEJEric W1NEJ Member
    edited April 2019
    Day two for me. Began Tuesday (3/13/18) here.  Anyone else still having this issue?
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited April 2019
    Stand by.  We understand the issue and a fix is being tested.  So sorry for any  impact this may have.
  • edited March 2018
    Thanks Mike...appreciate the update

  • John AK4ZJohn AK4Z Member
    edited March 2018
    My Smarlink quit yesterday. Changed to non-Google account today. Still having issues. Thanks for posting that this is known problem being worked. 
  • edited March 2018

    Apparently the fix you have been testing does not work.  How about restoring a bare metal backup from last week…!!!  That should have been done early yesterday...
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    David, how do you know the testing does not work?  You don't know who is testing it do you?  I agree that a backup to something that works should happen.


    
  • Mike-VA3MWMike-VA3MW FlexRadio Employee, Community Manager admin
    edited March 2018
    The fix is a SmartSDR fix, not a service side fix.  If we could do it on the server side, we would do that as a priority.  Again, sorry.

  • edited March 2018
    Yes...Very disappointed in the time it is taking to correct this problem.
     
  • Eric W1NEJEric W1NEJ Member
    edited April 2019
    Tuesday night went to a friends house and met several hams there; was going to show them how I could operate my new 6600 over the Internet.  I had built up how great it is.....needless to say was pretty embarrassing after the build up I had given it.  They were still eager to see it and were hoping we could get together Wednesday night, but I told them still not working.
  • Eric W1NEJEric W1NEJ Member
    edited March 2018
    Will be a new version of SmartSDR to fix this problem?
  • edited March 2018
    Where was SmartSDR changed?  Not on my computer or Flex Radio! Are you saying that we should expect an update to SmartSDR to fix this? This would be a real issue while traveling away from my home QTH.
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    Michael, not questioning this but as a technical minded group I am curious to how this is a SmartSDR issue. We have not had any SSDR updates that I am aware of that broke this.  It was working on this version of SmartSDR before.

    It seems to me that something had to change on the server side and you are testing the Fix on SmartSDR. Is that correct?
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited March 2018
    Why do you guys keep drilling down on everything he says, just let them work on, they know a lot more about it then we do. Remember it's just a fun hobby.
  • edited March 2018
    Apparently they don't ... This is taking a very long time to correct whatever they changed in their software. Yes this is a hobby but open discussions are a big part of it.
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    LOL at Bill :)

  • WW1SS - SteveWW1SS - Steve Member
    edited April 10
    Im not bashing Flex but that just seems to be the norm . . . Not Working . . . Not Working. Issues with new radios,Smart SDR login not working, bluetooth in Maestro not implemented (hardware supposedly there, Smart SDR random disconnects, one user is on his 3rd Flex 6600 series it just goes on and on and on. I have my own issues here with the disconnects and no wi fi networks available but I just deal with them.
  • Eric W1NEJEric W1NEJ Member
    edited March 2018
    According to Tim there was a change on the Auth0 authorization API that is used to log into SmartLink.  While none of us know for sure, it sounds like whatever changed that broke the SmartLink login cannot be changed back and it looks like (from the comments above) the issue will need to be resolved on the SmartSDR side.  As Rich said, since this is a technically minded group, we are naturally curious as to what is going on, and while this is not a business critical product (after all, it is a hobby) we still are interested in finding out what it will take, and how long, to get this resolved, especially since we have, patiently, waited so long to get V2 and/or our new 6400/6600 radios!
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited March 2018
    This is not the first time I have seen people think they know more about Flex related problems then Flex does..Lol
  • edited July 2018
    This begs the question....when I bought the radio I bought it specifically because of the RC ability...I was surprised by the 'secure login' system vs me connecting directly to my radio. I'm assuming there's a reason we can not do that, and that its associated with the use of their software. Is there no other way to do this? In my situation, RC only, my access...to my radio online...is at their mercy. Not ideal. Perhaps a plan B should be available.
  • Eric W1NEJEric W1NEJ Member
    edited March 2018
    Just want to understand what is going on.
  • Rich McCabeRich McCabe Member ✭✭
    edited March 2018
    I think the reason for a third party service system is to avoid users trying to connect directly. Direct would require dynamic DNS (in most cases)  and other network changes to make this happen.

    This should be the simplest and most reliable method.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.