Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6500 No rf power from display but I have power

mark Catonmark Caton Member
edited February 2018 in FLEX-6000 Signature Series

Playing with Mics today (RE20/ShureSM7B) and my Studio Projects VTB1 also. After an hour of playing with them, NOW there is NO RF power coming from the meter. I am being heard on the air, so did I push something by accident. New to the 6500, so Thank you for your time and patience. Mark


  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited February 2018
    were are you on the band, maybe I can join you, I'm on 40
  • 9k2od9k2od Member
    edited February 2018

    hi . be sure that your choosing the mic from mic inputs .. its located upper the processor button... 73


  • mark Catonmark Caton Member
    edited February 2018
    Hello Bill: I put my Telepost digital watt meter in line and I am seeing .64 watts. DOES NOT sound good!!!
  • mark Catonmark Caton Member
    edited February 2018
    Osama: Thank you for the input. I have used a Telepost 100A watt meter and NOW found out that I am only doing .64 watts. The Mic inputs are on BAL. This radio only has about 2 minutes of transmit on it.
  • edited February 2018
    Be sure you are transmitting into a matched antenna. It sounds like you may not have transmit & receive set to the same antenna. So, the radio is protecting itself by dropping power. (I know from experience) Also, check mic gain etc. Just some quick suggestions. The 6500 is a great radio. James WD5GWY
  • mark Catonmark Caton Member
    edited February 2018

    Hello James: Thank you for your input. I have everything were it should be, hopefully!!

    Slice A RED  Ant1 and Slice A Blue Ant 1 also. Mic gain is at  38 because of Preamp doing the work. Thank you Mark

  • Gary  w8viGary w8vi Member ✭✭
    edited February 2018
    Try changing your MIC and Transmit profile settings. I've had the same issue and selecting different  options fixed it. 

    When you push Tune is that working correctly?


  • mark Catonmark Caton Member
    edited February 2018

    Hello Gary: I am at work as of this writing to you. I will be home tomorrow morning after 8 am PST and will try your settings. Thank you for your input also.


    Hello Gary: I tried those MIC and Transmit profiles and nothing happened. Thank you again

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.