Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Delay to release TX for USB controlled DEMI 2m Amp 2LMDPA

EA4GLI
EA4GLI SalvadorMember ✭✭✭
edited March 2019 in SmartSDR for Windows
I have been using the 2LMDPA 2m amp from DEMI with my 6700 for a few weeks. It functions but there is a noticeable delay, most noticeable when I release PTT and it takes up to 1 second to release at the amp completely.
Has anyone else noticed this delay?
It seems to be a delay at the USB connection. Some features, like enabling PreAmp takes a few tries sometimes.

I have the USB from the DEMI LMDPA connected directly to the 6700, not through a hub.

Any ideas? Has this been noticed by the alpha team?

Comments

  • David Livingston
    David Livingston Member ✭✭
    edited April 2018
    Good Afternoon,

    I received my 2MLDPA for my 6700 about three weeks ago.  I operate it through relay #2 (relay #1 is used for my ALS-1306) on the Flex Radio. Mine works perfectly. No delay. When I release the microphone button it immediately goes to receive. I believe there is an issue with the latest release of SmartSDR with the new use of the USP ports. I would bet there will be an update within a few weeks,  I would suggest using the relays to control your 6700, pretty straight forward.
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited January 2017
    Thanks David. Knowing there is an issue with the software and the USB relay activation I will not bother with it until the new update. 

    My guess is you are turning it on, enabling PreAmp and activating Relay through the aux port of the DEMI amp? vs using USB.
  • David Livingston
    David Livingston Member ✭✭
    edited April 2018
    DEMI furnished a cable for my 6000 series Flex radio. It connected to the serial port on the DEMI with two cables coming out of the serial connector. One white which is not needed and one black with a standard RCA connector that you just plugs into a Flex Relay port. The relay port are in the Flex setup / TX area. Just enable the relay in a profile for the DEMI. Takes all of two minutes.

    image

    image
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited January 2017
    Oh OK. I do not have that. Mine is the black cable that goes to USB and the white that is not connected to anything.
  • David Livingston
    David Livingston Member ✭✭
    edited April 2018
    Personally I would rather have the direct grounding of a relay in the Flex controlling my amplifier. It is either on or off. I believe DEMI would exchange cables if you wanted. There may be another issue why yours is a USB.  Do you have the Remote Function on your DEMI. I do not...!!! If that is the case, I would use the computer and not the radio to control the DEMI for now...
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited January 2017
    That is exactly it David. I have the remote function. I will wait for the updated software. Tons of little projects in the workbench, if the software is delayed over a month I will tackle a cable, I am pretty sure it should be easy to modify to a manual ON OFF, Relay and PreAmp ON-OFF

  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited March 2019
    So this continues to be an issue. And it has a very odd behavior. Sometime the TX release request will be very fast, others it can take up to 4 seconds. I have not been able to pin point the root cause.

    I just found something. If I have the 2 USB FTDI cables connected to the Flex 6700 I get the strange behavior. If I only have the USB from the DEMI Amp it works as intended.

    Is this still in the radar as a USB Cable Bug?

    @Tim, if you see this, Should I open a ticket for this one?
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    Are they the same cables?  Both from DEMI?
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited May 2017
    Nope. One is the DEMI one the other is an FTDI that I use with the Expert Amplifier. Both are recognized.
    The FTDI for the Expert amp works well regardless of the DEMI one. No delay changing bands.
    If I DISABLE the FTDI one the DEMI one still fails to work properly.
    If I DISCONNECT the FTDI one the DEMI one works.

    The FTDI cable I use is this one
    https://www.amazon.com/gp/product/B004ETETZK/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

    image

    It is a double SERIAL out of a single USB

    image

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    See my reply below.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    This appears to be a defect of some sort.  I have written it up and put it in our bug tracker as issue #4790 for further investigation.  Please report any additional information related to this specific issue in this community topic.  Thank you.
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited May 2017
    Thanks!!
  • Wayne VK4ACN
    Wayne VK4ACN Member ✭✭
    edited May 2017
    Try changing the Gearmo cable for one of the USB cables that flex sell.  I had a gearmo usb-4port serial, but i had problems with it on the flex.  I had it controlling a SPE 1.3, and would sometimes be slow changing bands on the spe, and every now and then, the spe would throw up an error on the display, (cant remember what it was now).  I changed the gearmo for one like flexradio sell.  (got it from mouser).  Never had a problem since.  Works perfectly.
    73
    Wayne

  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited May 2017
    It is definitely worth a try. I want the double serial as it allows me to use both INPUTS from the 6700 into the Expert Amp.

    I have not notice any errors or delays, as a matter of fact it has worked great, changing bands and power levels back and forth between amp and Flex radio.

    Mouser sends to Spain but it gets pricey, I will try to find a real FTDI locally before and try it.
    Thanks Wayne!
  • Wayne VK4ACN
    Wayne VK4ACN Member ✭✭
    edited May 2017
    Maybe you need 2 of those cables with a usb hub into the flex.  Mouser is good to Aust.  Spend $60, and you get free shipping, and its Dhl or ups, so you get it in 3 days.  Thats a pretty good deal
    73
    Wayne

  • Ed.G
    Ed.G FlexRadio Employee ✭✭
    edited May 2017
    Salvador - did using a different cable fix your issue? We've seen problems like this with certain cables that 'misbehave' and starve out other USB cables connected. 

    Another suggestion would be to ground all the unused pins in the cable going to the Expert amp. 
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited May 2017
    I have not received it yet. As soon as I do I will report. I will try to ground the other pins see if that helps. Thanks for following up.
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited June 2017
    I received a new cable. I bought a couple from Amazon, made by UGreen, FTDI certified.
    The serial number doesn't start with FTxxxxx like the other cables or the one on the DEMI amp, but it gets recognized by the Flex radio, directly and through a hub. The Serial starts with AIxxxxx.

    So far so good. I engage and disengage the radio on 2m and the amp follows accordingly.
    I will try with Satellites and hopefully it will release TX instantly.

    I still think it is good to leave the issue in the bug tracker as the gearmo cable is an FTDI chip cable. But as Wayne pointed out, the Gearmo seems to be the culprit.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.