Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6700R not work with the Maestro any longer?

Watts - K4QJZ
Watts - K4QJZ Member ✭✭
edited February 2018 in FLEX-6000 Signature Series
My Maestro at some point during the last upgrade time period has stopped seeing my 6700R, it sees my 6700 with no issues. This is true when on the same LAN, WiFi or VPN. The PC version (SmartSDR, sees them both and the iPad version sees both no matter how it connects.
The Software version is on both radios and Maestro. Whats troubling is it used to see both and offer me the option to choose which I wanted to work with? Since it has been a while since I worked with the 6700R I can not say for sure it saw both after being upgraded. I have tried the advanced Network settings "Enforce Private IP Connections;" and found it made no difference.
Fix IP in both radios and both on the same physical network.
Suggestions / recommendations please...


  • Mike va3mw
    Mike va3mw Member ✭✭
    edited February 2018
    A few things as this might be a network issue.

    How is your Maestro connected to the network?
    Is the IP address on the Maestro the same subnet as the radio?
    If you plug the Maestro right into the back of the 6700 with a LAN cable, does it see it?

    Can you go to DHCP and see if that works for both the radio and the Maestro as a test?

    Can you describe more about your network?

    Mike va3mw

  • Watts - K4QJZ
    Watts - K4QJZ Member ✭✭
    edited February 2018
    The Maestro has been connected directly to the radio and did not see it. (It did in the past)
    Connected through the same switch both radios are on and only saw the 6700. (Local LAN, wired) WiFi tried as well, same results.
    Normally its been connected remotely via the Softeither VPN the 6700 is also on. On the remote end the Maestro and the Laptop are on a dedicated switch on the VPN box with nothing else on the VPN. Both have no issues as to conflicts with their Static IP address which they have had for some time.
    I have done a factory reset on the 6700R as well and reset the IP address, etc. No change. Everything sees it and works with the 6700R but the Maestro?
    Not sure what to try next....
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited May 2017

    We want to keep this very simple to start and then build up from there.

    Can you confirm that on the Maestro and the failing 6700 both IP addresses are set to DHCP first.  This is only as a test.  That will confirm that the LAN connections of both devices are functional.

    Any cable with work, as it doesn't have to be a cross over cable.  

    I'm trying to understand you setup.  You have a local 6700 and a remote 6700R and you can't see the remote one?  Is that correct?  That part isn't clear.

    If that is it, then log into Softether and make sure that the bridged lan connection is correct.  I have had this happen more than once with the Softether bridge has failed as the wrong ETH device was assigned to the bridge.

    Can you sketch a diagram on a piece of paper, take a picture of it and post it?


  • Watts - K4QJZ
    Watts - K4QJZ Member ✭✭
    edited May 2017
    Thanks, yes I did the DHCP test one at a time to insure there were no conflicts I was unaware which had come from other devices on the net with the addresses.
    The cable used when connecting directly between the Maestro and the 6700R was tested by using it connect to the 6700 as well.
    Both Radios are in the same physical location less than a foot apart and normally connected to the same 24 port switch. I even swapped the ports each was connected to, to insure proper port operation (dumb 10/100/1G switch).
    The is a PC connected to the same switch which see both units with no issues. On the same switch is a Raspberry PI VPN server which feeds the network. This is the VPN server through which we can connect remotely to the network when I wish to operate remotely. Worked with no isses for the last 5 months.
    The switch is connected to the system high end router and wireless access point (Netgear 8000 Knighhawk). It in turn is connected to Comcast cable modem (150M down and 15-20M up).
    If I use the Maestro wired or wireless (2.4 or 5G) it does not see the 6700R any longer. It used to see both units and offer me the option to chose which I wanted to work with in the same way the PC software, IOS iPad app and Apple Mac DogPark applications still do.

    When I am away from the local network and connect via the VPN (Bridge) interface I get the exact same behavoir as if it was local and hard wired to the network. My remote laptop sees both radios and works both with no issues, SmartSDR or DogPark SDR. The Maestro sees only the 6700.
    I can VPN into the net, make the 6700 busy so the Maestro can't automatically connect to it and it will not automatically connect as expected but still no longer shows the 6700R as being on the network and available.
    The remote configuration is as follows; Comcast cable modem to Netgear 6000 router and access point. VPN bridge via 5G link to access point. Eithernet port from the VPN bridge to 4 port switch. Cable from switch to Maestro, cable from another port to the Laptop. Both the Laptop and the Maestro if in DHCP mode get addresses effectively from the Remote router. However both are currently set to static with the same address used when connected directly to the now distance Prime network the radios are on. This is the same configuration which used to work fine for many months.
    Hopefully this is clearer than my last description. I am of the belief the issue is with the Maestro as nothing else on the net that I can find has changed.
    If I knew how to force a factory reset of the Maestro unit back to its shipped defaults I would be inclined to try that next, I have seen no information on how to do that.
    That reminds me I did a factory rest on the 6700R early on believing it had taken some sort of hit.(twice a day apart with a cold reboot each time)
    Any thoughts...

  • Mike va3mw
    Mike va3mw Member ✭✭
    edited May 2017
    What happens if you do the initial DHCP test today that used to work at one time?  

    Their is no reset for the Maestro like you are thinking.  You can boot it into previous versions if you like and see if that helps, but I doubt that is the problem.

    I assume you can ping all devices and you are sure that there are no duplicate IP addresses?  You also want to make sure that the right device responds with the ping.  The easiest way to do this is ping the device and then unplug the lan cable and see if ping fails to that device.

    I somehow doubt it is the Maestro if it is working on 1 device and not the other.  This is why doing the simple test with a LAN cable from the Maestro to your 6700R ensuring DHCP is turned on for both devices.  If that works, then you have eliminated the radio and the Maestro as part of the problem.  This is a key critical test.

    What is a 6700R?  I'm not familiar with the model or is that just your naming convention.    

    Again, a sketched diagram would be much more helpful so we can understand your topology since it is somewhat unique.  

    Mike va3mw

  • ka7gzr
    ka7gzr Member ✭✭
    edited May 2017
    6700R is a receive only 6700.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    I have entered this problem report into our bug tracker as issue #4812 for additional investigation. Thank you for the defect report.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.