Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSRD for iOS Now Acts Different iPad to iPhone

Mike W8MM
Mike W8MM Member ✭✭
edited July 2019 in FLEX-6000 Signature Series
I am enjoying SmartSDR for iOS on my iPhone 6 and iPad Pro.  Both worked great until now.

Lately, only my iPad Pro comes up with "Searching Error" after I tap to connect and it can't "Discover" my 6700.  If I start the app on my iPhone, my 6700 is discovered immediately.  

Both apps have the same settings and are configured to disconnect on exiting the app.  Both are running SmartSDR for iOS V1.2.8.  Both iOS devices were running iOS version 10.3.1.  I upgraded the iPad Pro to 10.3.2 without any change in behavior.

I've tried using the scan mode on my iPad and that works, but not every time.  The last time I tried it in Scan mode, it said it found (1) radio, but never showed it to me nor would let me connect.  Other times, it scans and finds the radio just like "Discover" used to do.

What should I try next to return to the good old days of using my iPad Pro?


  • Dave - W6OVP
    Dave - W6OVP Member ✭✭
    edited July 2019
    Similar problem here between iPad and PC.
  • Mike W8MM
    Mike W8MM Member ✭✭
    edited May 2017
    I've had that before, but in my case it was because I had closed SmartSDR on the PC, but had not closed DAX and CAT, which were still connected, thus blocking other connections.

    This is different.
  • Mike W8MM
    Mike W8MM Member ✭✭
    edited July 2019
    Now that Dave mentioned the PC vs. iPad issue, I remember that this odd behavior started right after I figured out the DAX and CAT persistence issue.

    I wonder if the error handler in SmartSDR for iOS has some sort of "hang" under "just wrong" conditions?  I say that because the "Searching Error" title is displayed immediately when I tap on the screen before it has had any time to test conditions on the network.  Almost like it is a value held in NVRAM between sessions.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.