Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

2 Raspberry Softether Setup help needed

ka7gzrka7gzr Member ✭✭
edited November 2019 in FLEX-6000 Signature Series

Hello,

I have 2 raspberry Pi3s with SoftEther installed. With the help of the fantastic k6ozy (Chris) videos I have successfully connected to my Home Pi via my remote Laptop. I am now trying to VPN in with my Maestro with my second Pi3. I am also using k6ozy videos for this. The remote path goes through my iPhone. The Pi3 connects to the hotspot fine. On the Maestro I see I am connected with a yellow triangle/explanation point meaning it doesn't see the internet. Of course the "radio" page of the Maestro is blank.

I could use some help in sorting through this. I am out of ideas.

TIA,

Jim

ka7gzr

Answers

  • RiaRia Member ✭✭
    edited November 2019
    Hi Jim,

    The most important thing is that you must (must must must) have a bridge setup in the softether config on the pi you are connecting to the maestro. Otherwise your softether connection has nowhere to go. That bridge will bridge the RJ45 LAN connector to the SoftEther connection. 

    It is at 12:18 in Chris's video:
    https://www.youtube.com/watch?v=HaH8LJ6_MQc&t=1046s

    Make sure you select eth0, since he clearly says wlan0 was a mistake. 

    Ria
  • ka7gzrka7gzr Member ✭✭
    edited November 2019

    Hello Rea,

    Yes I am aware of  Chris's error in specifying "wlan" instead of "eth0". He has a note that pops saying "don't listen to me- it should be eth0". I laugh each time I see it. I have been through his video so many times I have it about memorized.

    One very good thing is that I know a whole lot more about Linux than I knew before!

    I do understand that a bridge needs to be set up- I believe where the issue is the connection between the Remote Pi and the Home pi is not being realized.

    Jim

     

  • RiaRia Member ✭✭
    edited February 2017
    Sorry, lost internet here (very unreliable).

    There are a few elements for this to work properly:

    1. The server side pi (radio side) must be setup to allow LAN to LAN connections, I assume you did that.

    2. Port forwarding on your router must be setup correctly - 500, 4500, 5555. I believe 5555 is a TCP port and the rest are UDP (off the top of my head). 

    3. The client (maestro) end must have wifi connectivity. You can use the method Chris describes or something else I found a lot more elegant:

    https://planb.nicecupoftea.org/2016/03/20/wifi-connect-quick-wifi-access-point-to-tell-a-raspberry-p...

    (I recently did a pi for someone with this plus a status indicator and reset button using the GPIO btw, pretty slick, they can see the connection status and even "forget" known wifi on demand). 

    4. The maestro end must have a cascade connection setup to your server end (radio end) pi. 

    5. There must be a bridge on the maestro end pi. 

    Without seeing details of your configuration, it's hard to guess but I'd run through these to see. I think in most cases it's either the bridge part or the firewall port forwarding that trips people up. 

    You can use the GUI to check the status of the cascade connection. As Chris advised in his video, you should put an IP on the wired ethernet interface for admin purposes and you can use that to connect to the Pi to check connection status. 

    If you're still stuck, post some screen shots of your config. 

    Ria
  • ka7gzrka7gzr Member ✭✭
    edited November 2019

    One other item I don't understand is my wlan address of my router is never specified. I have port forwarded the ports of my home raspberry. However, on the remote raspberry Pi I never specify the wlan address of my router. Maybe that's the issue. Did I not miss-interrupt  Chris's directions?  

    Jim

  • RiaRia Member ✭✭
    edited February 2017
    Usually what you do is set up dynamic DNS on the home pi (whereby you get a hostname like ka7gzr.softether.net and that is tied to your home internet's external IP) and then the remote pi connects to that. When setting up the cascade connection on the remote pi you'll connect to the dynamic DNS hostname. Hope that made sense.

    Ria
  • ka7gzrka7gzr Member ✭✭
    edited November 2019
    Yes I understand that. On the Maestro Pi I specify on the "cascade" host entry as "ka7gzr.softether.net"  Where is that specified on the Home Pi?
  • RiaRia Member ✭✭
    edited February 2017
    In the "dynamic DNS" section.
  • Bill  /  VA3QBBill / VA3QB Member ✭✭
    edited August 2017
    Another thing you can try is to connect from a Windows 10 laptop using the built-in VPN bridge to your home Pi and make sure the Pi server is working OK. Then continue to troubleshoot your remote Pi. 73 Bill VA3QB
  • ka7gzrka7gzr Member ✭✭
    edited February 2017

    Thanks Bill,

    Yes I can "successfully" connect with my Laptop remotely. Although the connections often drop and are mostly unreliable- but that's a different subject...

    Jim

  • ka7gzrka7gzr Member ✭✭
    edited February 2017

    Thanks Ria.

    I did check and everything in the "dynamic DNS" section is how it should be. I assigned a name to the "****.softether.net" on the Home side. I have established a bridge on the Maestro side- at least I think I have. :)

    I will send you config files if you like. Any specific ones?

    Also I can send you the two config files for my home and remote txt files.

    Earlier Chris (k6ozy) was able to get into my Pi3s and look at them remotely but he has not been around for awhile.

    Jim

    ka7gzr

  • ka7gzrka7gzr Member ✭✭
    edited February 2017

    Problem Solved!

    I found my last fatal error which was not including 3 alphas in my DNS Hostname.

    Thanks for all the help especially Ria (N2RJ) and Chris (k6ozy).

    73,

    Jim

    ka7gzr

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.