Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

D-Star Problem with 6500

Bruce WBruce W Member
edited April 2019 in SmartSDR for Windows

Attempted to setup DSTAR simplex mode today but it acts like the ThumbDV dongle isn't working correctly.  Followed the directions precisely according to the D-Star How To Guide.  The fellow on the other end saw my Call Sign one time out of many attempts but never any audio.  His panadapter (and mine) showed a short burst of the expected TX pattern followed by a narrow carrier signal at the center frequency during PTT.   When He Transmits I occasionally see his Call Sign come through and a reasonable looking panadapter and waterfall presentation but no audio.  We both tested with and without amplifiers and in normal sideband, audio and signal strength was very good . I stuck the Thumb DV into my PC and it loaded drivers and said the ThumbDV was ready to use.  Put it back in my 6500 and same as before.  Used software versions 1.9.13.23 and 1.10.15 Beta with same results.  Power cycled, uninstalled and reinstalled waveforms with no change.  I also have a 6300 which I'm about to try but the 6500 is D-Star challenged.  Has anyone seen anything like this?


Open for Comments · Last Updated

Comments

  • Mark GottliebMark Gottlieb Member
    edited April 2017
    I am having exactly the same problem with the FLEX 6300.  I have exchanged e-mails with Dudley on this issue as well over the last two weeks.  I am able to use my DV Mega for one reflector only since it is not accepting reflector commands from Smart SDR DStar.

    Mark
    WA2DIY
  • Mark GottliebMark Gottlieb Member
    edited April 2017
    I see a signal from the local DStar repeater which is only about 6 miles from my house and, sometimes, even hear some audio.  But, TX is not available.  When I do hit the local repeater, my call sign appears in SmartSDR DStar as "*******"
  • edited April 2018
    I also have this problem with my 6700.  I believe the issue is with the new USB functions on the Flex. The USB ports were just recognized in the last two beta releases. I expect it to be corrected in a possible beta release in the not to distant future.
  • Cal  N3CALCal N3CAL Member ✭✭
    edited March 2017
    Bruce,

    If you tried to revert back to 1.9.13 SSDR software did you also uninstall the latest D-STAR Waveform and revert back to the earlier D-STAR Waveform program?   Maybe Flex can confirm this but I believe the latest D-STAR waveform is only compatible with the Beta SSDR software?

    Cal/N3CAL
  • Bruce WBruce W Member
    edited February 2017

    There is only one SmartSDR D-Star Installer in the Waveform Download section and I did re-install it under both 1.9.13 and 1.10.15. 

    Bruce  WB3BW


  • Cal  N3CALCal N3CAL Member ✭✭
    edited March 2017
    I wonder if going back to D-STAR waveform version 1.0.7.9 with SSDR 1.9.13 would be worth trying?  I've still got a copy of it here on my system. 

    Cal/N3CAL
  • Mike VE3CKOMike VE3CKO Member ✭✭
    edited April 2019
    With 1.9.13 I did see Dstar in USB Cables but with 1.10.15 it is not there and I've re-installed and cold started the 6700. DSTR is an option in modes though. Haven't seen a Dstar QSO yet to test the mode.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2017
    The ThumbDV dongle was not supposed to show up as a USB cable because it isn't a USB cable device.  This was a bug in 1.01.8 that was corrected in 1.10.15
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited April 2017
    I have entered this problem report into our bug tracker (issue #4457) for additional investigation. Thank you for the defect report.
  • Mike VE3CKOMike VE3CKO Member ✭✭
    edited February 2017
    Makes sense as it's USB cables and not USB devices. Thanks as always Tim.
  • WesWes Member
    edited February 2017
    I'm using the ThumbDV (thanks Cal) on my new 6500, 1.10.15 and the latest Dstar waveform and it's working fine, but the performance of this Dstar setup doesn't work as good as the FreeDV. My friend Cal N3CAL and I tested Dstar on 80M last night with an S9+ signal and it was about 50 to 60% decode,
    We switched to FreeDV waveform and decode was about 95 to 99%. It's just structure of the codec between FreeDV and Dstar. There not much you do about Dstar as it was developed a long time ago and requires a very solid unwavering signal do to the pour error correction built in the codec. 
    73
    Wes
    N3WZU    
  • Bruce WBruce W Member
    edited February 2017

    Thanks Tim.  As a note I get exactly the same results on my 6300.  I suspect the ThumbDV may not be working.  I got it with my 6300 back last spring but I never tried it until my 6500 arrived.  Two of the guys I've been working with (N3WZU and N3CAL) have made QSO on D-star using their 6500's with the latest version 1.10.15 but they can't hear me and I can't hear them even with 20 over signal.  I get no digital signal on the panadapter when I TX.  Only a spike at center frequency. In RX I get a good digital pattern on the panadapter but no decoded audio. So it looks like the THUMBDV is not encoding audio for TX because there is no digital pattern in the panadapter and even though there is a pattern in RX it isn't decoding audio. Got a spare ThumbDV?

    Regards,

    Bruce WB3BW


  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2017
    If you got the ThumbDV from us, then open up a HelpDesk ticket.  If it is truly defective, we'll make it right.
  • Dudley-WA5QPZDudley-WA5QPZ Inactive Employee
    edited March 2018
    Gordon,

    I've found that you need a 10 db over s-9 to get solid copy on HF DStar, and QSB effects it very badly,  FreeDV is much better on HF for getting the voice through,  but DStar sounds better but takes a lot of frequency spread,  6 KHz verses 1600 Hz on FreeDV . 

    Dudley
  • Mark GottliebMark Gottlieb Member
    edited February 2017
    Tim,

    I did purchase the Thumb DV from FLEX and have written a HelpDesk ticket #16646 and Dudley and I have been exchanging messages for about two weeks.  What is my next step?  Order Number:: AB-9322.  I did not have the opportunity to use it until I got my DEMI 70cm transverter.

    Thanks

    Mark

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2017
    Dudley should be updating you shortly on your HD ticket.
  • KS4JUKS4JU Member
    edited February 2017
    Having the same problem with my 6300. Strong signal on panadapter and the helper app shows call signs, but no audio.
  • KS4JUKS4JU Member
    edited February 2018
    Anybody having any luck getting the ThumbDV and D-Star working on their 6300 under the latest version of SmartSDR? I can copy plenty of callsigns with the helper app, but no audio is decoded.
  • WesWes Member
    edited February 2017
    I have to turn on the preamp to +20 on all bands to decode signals. Good luck with Dstar.
  • KS4JUKS4JU Member
    edited February 2017
    Thanks. Tried that even with S9 signals, still no audio.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2017
    I previously entered this problem report into our bug tracker (issue #4457).
  • James NelsonJames Nelson Member ✭✭
    edited June 2017
    mine too   . no tx or Rx.   just the centre carrier.
  • Kev MallinKev Mallin Member
    edited March 2018
    Is this issue resolved, I've searched through all the mails but can't see any answer.
    I have still the delay/decode problem.
    Kev

  • WesWes Member
    edited July 2017
    That would be sweet if that was fixed.
  • Lee MaiselLee Maisel Member
    edited February 2018
    I guess they only care about the new stuff they're selling.
  • Lee MaiselLee Maisel Member
    edited February 2018
    OK  It's been over a year and NOTHING.  Is this going to be fixed or should I just get a refund from Flex for the dongle?
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited February 2018
    Lee, it is no mystery that we are not a big company with a large team of engineers, so we do have to be mindful to allocate our resources judiciously.  We are aware of the D-Star issues and the defect is in a scheduled milestone to be addressed.
  • James NelsonJames Nelson Member ✭✭
    edited March 2018
    I accept that from Tim, however we were wondering if the dongles are faulty or the driver not not picking up the waveform. Problem for two down here in Sydney we are hoping we don't have two defective dongles that would be hard to get refund from 18 months from date of purchase. We are using our Icoms to play AMBE 2020 (aka Dstar mode on HF). On a similar thought DMR mode needs to be on the agenda now as well. Not sure if that is open source however Chinese 2 & 70cm rigs are appearing on eBay for a few dollars.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.